• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Far Cry2 Cat 8.10 HotFix render errors

Page 2 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.

apoppin

Lifer
Mar 9, 2000
34,902
0
0
alienbabeltech.com
Would you mind sending me your game save so i can attempt to duplicate it on 4870/280GTX with Cat 8-10 [not hotfix and then again with hotfix drivers] and 178.74

Best is to stand at the exact scene where you took your screen shot. Save it. Send it to me; you have my email address

yes, it should be explored in an article and you already have the ideal screen shot to look at.
- that is some nasty differences

finally, did you run fraps to see if there is ANY performance difference or it it is just a cat Bug?

EDIT: "FarTCry2" ?
(in your screen shot)
- now that really stinks :p
:D
 

nRollo

Banned
Jan 11, 2002
10,460
0
0
Originally posted by: apoppin
Would you mind sending me your game save so i can attempt to duplicate it on 4870/280GTX with Cat 8-10 [not hotfix and then again with hotfix drivers] and 178.74

Best is to stand at the exact scene where you took your screen shot. Save it. Send it to me; you have my email address

yes, it should be explored in an article and you already have the ideal screen shot to look at.
- that is some nasty differences

finally, did you run fraps to see if there is ANY performance difference or it it is just a cat Bug?

EDIT: "FarTCry2" ?
(in your screen shot)
- now that really stinks :p
:D
Saved game and screens sent, and I was using 16X AF in the CP.

 

apoppin

Lifer
Mar 9, 2000
34,902
0
0
alienbabeltech.com
Big thanks! i will wait to see if anyone else wants me to check anything else FC2 IQ-related and then i'll log off and go to work on the IQ and benching; expect an email and a link from me when i am done this afternoon, hopefully in a few short hours.
:clock:

BtW this post of your is an awesome coincidence for me, as i was exploring FC2's IQ - right now, this very morning!!

You are going to have me hopping back and forth among partitions. i will use cat 8.10 and 8.10-hot fix with 4870/1GB and 178.24 and 178.13 with 280GTX
- i doubt i need to go back to 8.9 unless i don't see much between 8.10 and the hotfix drivers; i don't think 8.10 'anticipated' FC2 anymore than 8.9 would have and the hotfix seems created just for it.
- Does that sound about right? i will use a resolution of 19x12 and also explore the Frame rate performance delta between the latest 2 drivers sets; both AMD's and Nvidia's.

i am guessing i will need to apply *varying* levels of AA - 1x/2x/4x and also check see if 16xAF makes any difference in the screen shots. AF does not clean up the vertical jaggies in game play; i note texture crawling in the short Ranch demo with all my GPUs no matter the settings.
 

nRollo

Banned
Jan 11, 2002
10,460
0
0
Originally posted by: vj8usa
Originally posted by: nRollo
First, I had problems with missing textures in the Cat 8.9s, so I upgraded to the 8.10 hotfixes.

I didn't mention the stuttering or show NVIDIA screen shots because I'm not trying to turn this into "Look! NVIDIA renders the game more accuratrely!", I'm noting that it looks to me like some detail is lost on things like small rocks and tire tracks with the 8.10s.

The 8.10s did do better with the textures, but to me it seems like the early Crysis drivers with NVIDIA, some things are missing/rendered differently.

I'll post more screens today to back up my point. (have some ducks to shoot and soccer to watch now)
I'd actually like to see a screenshot of that same scene on an nvidia rig, just for the sake of comparison. I'm curious now. If the rocks look the same with an nvidia card as they do with 8.10, does that mean (in your opinion) that nvidia cards have the same rendering error, and that 8.9's the only thing that's right? Or perhaps 8.10 was rendering it properly all along...
Done- check the gallery again, added the same shot with a GTX280.

This appears to be an optomization that lowers image quality for ATi, or a bug in the drivers.

 

Keysplayr

Elite Member
Jan 16, 2003
21,219
50
91


So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.
 

SSChevy2001

Senior member
Jul 9, 2008
774
0
0
Originally posted by: nRollo
Originally posted by: vj8usa
Originally posted by: nRollo
First, I had problems with missing textures in the Cat 8.9s, so I upgraded to the 8.10 hotfixes.

I didn't mention the stuttering or show NVIDIA screen shots because I'm not trying to turn this into "Look! NVIDIA renders the game more accuratrely!", I'm noting that it looks to me like some detail is lost on things like small rocks and tire tracks with the 8.10s.

The 8.10s did do better with the textures, but to me it seems like the early Crysis drivers with NVIDIA, some things are missing/rendered differently.

I'll post more screens today to back up my point. (have some ducks to shoot and soccer to watch now)
I'd actually like to see a screenshot of that same scene on an nvidia rig, just for the sake of comparison. I'm curious now. If the rocks look the same with an nvidia card as they do with 8.10, does that mean (in your opinion) that nvidia cards have the same rendering error, and that 8.9's the only thing that's right? Or perhaps 8.10 was rendering it properly all along...
Done- check the gallery again, added the same shot with a GTX280.

This appears to be an optomization that lowers image quality for ATi, or a bug in the drivers.
Nothing more than a rendering problem. The texture of the street is overlapping parts of the rock, nothing that would give a peformance increase. Clearly it's just a bug in the profile, but you want to make something big out of it go right ahead.

Honestly there's lots of problems with this game, and clearly ubisoft is to blame. I'll see if I can reproduce this probem, but right now I'm on 8.11 beta and don't have any such problem.
 

SSChevy2001

Senior member
Jul 9, 2008
774
0
0
@keysplayr2003

1) The OP change pictures around from his original post. The original pictures clearly showed rendering problems with 8.9 drivers.
2) In the current pictures everything is being rendered, minus some texture overlapping problems.
3) Since when is rendering problems considered optimizations?

Sorry for the double post.
 

apoppin

Lifer
Mar 9, 2000
34,902
0
0
alienbabeltech.com
Originally posted by: keysplayr2003
YBS1
tuteja1986
450R
clandren
RIFLEMAN007
BFG10K
Quiksilver
MarcVenice
nismotigerwvu
vj8usa

So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.
He is working on it; there is a driver bug that screws up FC2 running in fullscreen mode - nevermind the edits to player config

http://forums.slizone.com/inde...c=29286&st=20&start=20

Alt+enter worked for some; reinstalls for others - i got it fixed :)

ANYWAY, i figure i have 15 screen shots to match - using 19x12 - 1st, no AA/AF, then 16xAF - and finally adding 2x, 4x and 8x AA to each run and matching SS [5 for Geforce; 10 for Radeon]

So far i have the 5 performance runs completed for GTX280 with the latest 178.24
- i guess i don't need to look at earlier geforce drivers; so now that i have fullscreen back, i just need the 5 matching screen shots.

After that, i will repeat the performance runs for 1GB 4870 and the 5 matching screen shots - but this time with Cat 8-10 [why the heck should i go back to 8.9?; that makes no sense to me as FC2 is a brand new game!] and then again with the Cat 8-10 hotfix.

So, i have 15 screen shots to take and ten matching performance runs left to go .. then i have to make it all pretty for you and do the "graph thing" [which for me atm, takes the longest]


 

IlllI

Diamond Member
Feb 12, 2002
4,922
9
81
Originally posted by: keysplayr2003
YBS1
tuteja1986
450R
clandren
RIFLEMAN007
BFG10K
Quiksilver
MarcVenice
nismotigerwvu
vj8usa

So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.

thank you for taking time to list everyone Nvidia Focus Group member





 

Keysplayr

Elite Member
Jan 16, 2003
21,219
50
91
Originally posted by: clandren
Originally posted by: keysplayr2003
YBS1
tuteja1986
450R
clandren
RIFLEMAN007
BFG10K
Quiksilver
MarcVenice
nismotigerwvu
vj8usa

So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.

thank you for taking time to list everyone Nvidia Focus Group member
You are most welcome, earthling. ;)
 

Keysplayr

Elite Member
Jan 16, 2003
21,219
50
91
Originally posted by: SSChevy2001
@keysplayr2003

1) The OP change pictures around from his original post. The original pictures clearly showed rendering problems with 8.9 drivers.
2) In the current pictures everything is being rendered, minus some texture overlapping problems.
3) Since when is rendering problems considered optimizations?

Sorry for the double post.
Texture...... overlapping...... problems..... Hmmm. It could be.

And since when is texture overlapping automatically considered rendering problems?
Instead of making a final judgement on what exactly is going on here, why not wait for further data. I am. Can't you? Not so tough.
 

Keysplayr

Elite Member
Jan 16, 2003
21,219
50
91
Originally posted by: apoppin
Originally posted by: keysplayr2003
YBS1
tuteja1986
450R
clandren
RIFLEMAN007
BFG10K
Quiksilver
MarcVenice
nismotigerwvu
vj8usa

So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.
He is working on it; there is a driver bug that screws up FC2 running in fullscreen mode - nevermind the edits to player config

http://forums.slizone.com/inde...c=29286&st=20&start=20

Alt+enter worked for some; reinstalls for others - i got it fixed :)

ANYWAY, i figure i have 15 screen shots to match - using 19x12 - 1st, no AA/AF, then 16xAF - and finally adding 2x, 4x and 8x AA to each run and matching SS [5 for Geforce; 10 for Radeon]

So far i have the 5 performance runs completed for GTX280 with the latest 178.24
- i guess i don't need to look at earlier geforce drivers; so now that i have fullscreen back, i just need the 5 matching screen shots.

After that, i will repeat the performance runs for 1GB 4870 and the 5 matching screen shots - but this time with Cat 8-10 [why the heck should i go back to 8.9?; that makes no sense to me as FC2 is a brand new game!] and then again with the Cat 8-10 hotfix.

So, i have 15 screen shots to take and ten matching performance runs left to go .. then i have to make it all pretty for you and do the "graph thing" [which for me atm, takes the longest]
LOL! What's with the 3rd person reference!

Anyways, take your time. Much appreciated.
 

apoppin

Lifer
Mar 9, 2000
34,902
0
0
alienbabeltech.com
He has a bad headache and it helps him to think about it happening instead to someone he doesn't like :p
- and back working formally as an editor will sometimes do strange things to a writer
:Q

Anyway, i am done with the 280GTX runs and the matching screenshots. There is some variability in them as the rifle barrel moves up and down as the plants sway side to side; but you will get the picture. And GTX280 suffers a big performance hit - about -10 frames per second penalty - for each 2X of AA applied. AF is nearly free [but does not make a big difference]

OK, i''m off to the Radeon partition.

Don't tell me to take my time .. or i would take a nap now
 

legcramp

Golden Member
May 31, 2005
1,593
51
91
Originally posted by: keysplayr2003
YBS1
tuteja1986
450R
clandren
RIFLEMAN007
BFG10K
Quiksilver
MarcVenice
nismotigerwvu
vj8usa

So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.

I will admit I will apologize if it is true.

But you guys lose all credibility being a member of Nvidia Focus Group anyways.

But I will wait for apoppin tests.

Also, can I attack you instead? It will make me feel better :)
 

thilanliyan

Lifer
Jun 21, 2005
11,218
1,064
126
I'm not sure which picture is what exactly but the 1st one looks better than the last 2. I see the last one is a GTX pic and to me that is the same as the 2nd pic and they both look worse than the 1st pic. The rocks just sort of floating out of the road there looks like crap. If the 2nd pic is the 8.10s (which looks the same as the GTX 280 pic) then it looks like nVidia has some rendering errors (or whatever you wanna call it) too.

So which one is 8.9 and which is 8.10?
 

SSChevy2001

Senior member
Jul 9, 2008
774
0
0
Originally posted by: thilan29
I'm not sure which picture is what exactly but the 1st one looks better than the last 2. I see the last one is a GTX pic and to me that is the same as the 2nd pic and they both look worse than the 1st pic. The rocks just sort of floating out of the road there looks like crap. If the 2nd pic is the 8.10s (which looks the same as the GTX 280 pic) then it looks like nVidia has some rendering errors too.

So which one is 8.9 and which is 8.10?
Well nRollo is complaining about the 1st picture, which is from 8.10 hotfix or at least he says. These are his original posted pictures. Yes I saved them. :)

8.9
http://img508.imageshack.us/img508/8896/89rocksqi1.jpg

8.10
http://img396.imageshack.us/img396/6731/810rocksof9.jpg

Clearly you can see the problem with the 8.9 picture.

Overall I'm still having a hard time understanding this thread. ATi mostly fixed 4870x2 DX9 performance with this hotfix. It did hardly nothing for the single 4870 performance.

http://www.pcgameshardware.de/...otFix_BB2_1680_DX9.PNG
 

apoppin

Lifer
Mar 9, 2000
34,902
0
0
alienbabeltech.com
i am really lost :p

i just compared HD4870 and 280GTX performance and IQ with varying levels of performance - however, i used the *regular* Cat 8-10 and the latest Geforce drivers.

Where is the Hotfix? all i could find are these and they are for these cards:
# Radeon? HD 4650
# Radeon? HD 4550
# Radeon? HD 4350
http://support.ati.com/ics/sup...ledge&questionID=38750

is there *another* Hotfix driver for 48X0?
:confused:

Originally posted by: nRollo
IQ comparison

I was testing out Far Cry2 on a Radeon 4850, and found some there are definite differences in the new Cat 8.10s with the Far Cry 2 hotfix.

It looks to me like the speed increases might be coming at the expense of accuracy.

I've updated the images, taken from a save point with a renamed executable.
if Rollo is using a Hotfix driver intended for 43-4500 series card for 4850 there are bound to be issues


the latest drivers AMD directs me to is the regular Cat 8-10 on their page.
 

SSChevy2001

Senior member
Jul 9, 2008
774
0
0
737-38664: Far Cry 2 HotFix

The information in this article applies to the following configuration(s):
Far Cry 2
Radeon? HD 4800 series
Radeon? HD 4600 series

Improves performance for the DirectX 9 version of Far Cry 2 on CrossFire? compatible systems
Improves performance for the DirectX 10 version of Far Cry 2 on both single and CrossFire? compatible systems
The hotfix download package includes both the Display Driver and Catalyst Control Center. The hotfix can be downloaded by clicking on the links below.

http://support.ati.com/ics/sup...r.asp?questionID=38664
 

apoppin

Lifer
Mar 9, 2000
34,902
0
0
alienbabeltech.com
thanks .. i finally used the correct term for my search

"Far Cry2 Hotfix"

it is very specific

back in a few

nothing unusual to report when looking at the regular Cat 8-10s compared to GTX280's IQ
- performance-wise, the GTX is smoother. But it takes a much bigger AA hit


EDIT: this seems important:
This hotfix

* Improves performance for the DirectX 9 version of Far Cry 2 on CrossFire? compatible systems
* Improves performance for the DirectX 10 version of Far Cry 2 on both single and CrossFire? compatible systems

The hotfix download package includes both the Display Driver and Catalyst Control Center. The hotfix can be downloaded by clicking on the links below.

Far Cry 2 XP HotFix (includes XP 32-bit and 64-bit)
Far Cry 2 Vista HotFix (includes Vista 32-bit and 64-bit)

Note: This driver is provided as is and is not supported by AMD. It has not completed full AMD testing, and is only recommended for users experiencing the particular issue described above


So i would not normally bother with it at all

 

CrystalBay

Platinum Member
Apr 2, 2002
2,175
1
0
I don't know ,but you might be on to something Jethro... Hardly any websites to my knowledge do this test anymore...

How did you scout this ? Did you get a kick from corporate of this IQ investigation ? It is interesting however...
 

BFG10K

Lifer
Aug 14, 2000
21,797
775
126
Originally posted by: nRollo

2. Renamed the Far Cry executable to remove any game specific optomizations.
Um, why? That breaks the driver because it removes application specific optimizations. Furthermore you didn?t appear to do this in your first batch of screenshots but are now trying to compare the second batch to the first! What a joke.

So?you intentionally broke the driver and then posted screenshots. How about if I changed nVidia's AA flags and post screenshots of games having problems with AA as a result? Or how about I rename the executables and then demonstrate the ?problems? with SLI when it doesn?t scale as a result? Would that be okay?

The question is, why now? Is nVidia running damage control because of DX10.1 in Far Cry 2? Or does it have something to do with preparing for the 55 nm GT200 launch?
 

BFG10K

Lifer
Aug 14, 2000
21,797
775
126
Originally posted by: keysplayr2003

So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject.
I talked about the subject. If you can't see the gaping holes in his testing methodology (or don't want to see), there?s no point in discussing this with you.
 

Tempered81

Diamond Member
Jan 29, 2007
6,375
0
76
i think all the bs is because nvidia has lost the performance crown since R700 came around. It's been forever since the 9700pro.

 

thilanliyan

Lifer
Jun 21, 2005
11,218
1,064
126
Originally posted by: SSChevy2001
Well nRollo is complaining about the 1st picture, which is from 8.10 hotfix or at least he says. These are his original posted pictures. Yes I saved them. :)

8.9
http://img508.imageshack.us/img508/8896/89rocksqi1.jpg

8.10
http://img396.imageshack.us/img396/6731/810rocksof9.jpg

Clearly you can see the problem with the 8.9 picture.

Overall I'm still having a hard time understanding this thread. ATi mostly fixed 4870x2 DX9 performance with this hotfix. It did hardly nothing for the single 4870 performance.

http://www.pcgameshardware.de/...otFix_BB2_1680_DX9.PNG
Yeah in those pics I definitely see a difference and to me the 8.10s look better there. What about in the newer pics? Which one is 8.9 and which is 8.10? I personally think the 1st pic looks better than the last 2.


Originally posted by: keysplayr2003
So none of you saw anything missing. And now that you do see, because you can't not see it, what will you all say now? Will you all attack the poster...... Again? Or will you all talk about the subject. Stay Tuned folks. I'm damn curious to know.

Could be a driver bug. Could be an optimization. Lets see if Apoppin can duplicate this.
And what if it's complete BS? What are you gonna ask for from the OP?
 

BFG10K

Lifer
Aug 14, 2000
21,797
775
126
The second set of images definitely have rocks missing in one of them and that's potentially an issue. BUT he's also renamed the executable so it's a totally different ball-game now.

Both IHVs rely on application stings these days and both drivers can break if executables are renamed so he really hasn't proved anything.
 

ASK THE COMMUNITY

TRENDING THREADS