• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

AMD driver killing input devices in windows?

fralexandr

Platinum Member
Apr 26, 2007
2,071
81
91
www.flickr.com
For some reason when I went to update my AMD graphics drivers upon restart all of my input devices failed to work in Windows. Furthermore, sometimes the computer would fail to recognize inputs and not enter bios, after which Windows would fail to load. I tried 18.6 at this time.

Windows 10 64-bit Pro
i7 860
evga h55
2x8gb patriot ddr3 1866 running at 1600
Powercolor rx480 blower
corsair force 3 90gb
micron 1100 2 tb
seagate 1TB 7200 rpm
inland 480gb ssd
corsair vx450w PSU
antec 300
ps2 keyboard
corsair strafe silent red keyboard
kona pure mouse

I originally thought it was something to do with either my sandforce based corsair ssd, or the RX480 dying so i'm using the inland 480gb as a boot drive atm. Windows automatically installed an AMD driver for 17.x, and after installing everything and restarting a few times I tried running OCCT to test the RX480 for errors everything was working fine, so I installed some more stuff and restarted the computer a few more times. I then went to update the RX480 drivers to 18.5 this time, and the problem started again.

I then reinstalled windows again and booted without connecting to the internet and tried directly installing the 18.5 before connecting to the internet and restarted and the input issues showed up again.

All devices work fine at the bios before windows successfully loads, but then both USB and PS2 devices don't work in Windows. Furthermore, again, sometimes the computer fails to register inputs during startup IF Windows fails to load resulting in a blank screen and the computer locking up.

Is there some way to resolve this other than not updating to a newer AMD graphics driver?
should i bother replacing my h55 with my old asrock p55 pro motherboard? or would that probably not work?

I was planning on waiting until icelake or zen2 to replace this thing but now I might just go with a cannonlake... I can wait since I have an i5 7300hq laptop with 1060 but dunno...
 
Last edited:

tamz_msc

Platinum Member
Jan 5, 2017
2,837
2,587
136
You should disable Windows from updating your hardware drivers, use DDU to uninstall your current drivers and try again.
 

Shmee

Memory and Storage, Graphics Cards
Super Moderator
Sep 13, 2008
5,065
856
126
What version of windows 10 did you have/install? Was it 1803? If it was an earlier version, I wonder if the latest driver was not supported, as some drivers want your OS to be up to date. Also, you could try updating your motherboards BIOS. It may have some compatibility issue with the newer Radeon cards that an update could help.
 

fralexandr

Platinum Member
Apr 26, 2007
2,071
81
91
www.flickr.com
Yeah i was running 1803 every time. the evga bios is up to date they haven't updated it in forever... if evga's site is to be believed the latest bios version is from 2007 and pre-dates the lynnfield platform, hah. I guess i should try swapping to my old p55 pro, at least its latest bios is september 2010...

I tried installing 18.5 on a clean install of windows 1803 , but i guess i'll try again after swapping mobo?
 
Last edited:

ASK THE COMMUNITY