AMD Catalyst 14.9 Driver for Windows & Linux available now

Page 6 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.

Tarvaln

Senior member
Apr 28, 2004
310
2
81
Installed 14.9.1 Betas. That package does not include USB filter or RAID drivers. I also got a "package missing" error when it tried to install the steady video plugin.

Clean install using DDU and Driver Sweeper to double check to clean out files after uninstalling 14.7 RC3.

Only tested a few games but, everything seems fine in Crossfire. I'll have to test out more tomorrow.

Had a weird issue. Installed drivers, rebooted, launched Gaming Evolved and my system froze. Manual reboot, launched Gaming Evolved again and everything is fine.

Something I've noticed with past few drivers and crossfire. If I don't get the "Enable/Disable Crossfire" window after a new driver install I'll have a problem and will have to reboot. If I do get that window things a usually fine (except for the 14.9 driver). So, if you are installing the betas and you don't see that window after the reboot, I would reboot again. Depending on your system speed, you may to wait a minute or two for that window to pop.
 
Last edited:

3DVagabond

Lifer
Aug 10, 2009
11,951
204
106
New 14.9.1 beta driver has fixed all my issues (CTD, hard locks, restart issues etc)

Thankfully not such a wait for this fix. Thanks!

Hmm, no mention about the memory leaks in BF4 Mantle Crossfire, and I am wondering about mining performance. Worth a look though likely.


it's just to fix the issues above, which were caused by certain hardware combinations. If you aren't affected then there's no reason to use them.
 

Z15CAM

Platinum Member
Nov 20, 2010
2,184
64
91
www.flickr.com
Well "Hallelujah" this AMD 14.9.1b Dvr seems to be working on my system.

Unigne Heaven and BF4 now work.

Unigine Valley and Heaven Bench scores have increased from 5116 to 5159 and 2906 to 2913 in 1080p respectively with a modest 1105/1500 OC with my X-Fire 290X Elpida cards without artifacts. The 1440p Benches have also benefited about the same.

CPUID HMPro spills out 34/32/56C for the runs. Kinda makes me wonder if I don't have some more GPU OC'g room from this WB X-Fire setup.
 
Last edited:

psolord

Golden Member
Sep 16, 2009
1,698
1,076
136
Installing 14.9.1 over the 14.9 resulting in my system freezing after the 6th blanking of the screen.

Rebooted, tried again, got a 0x0000003b error.

Tried DDU, system froze again after the 6th blanking of the screen.

I re-installed a couple more times and the installation succeeded with only one error regarding hdmi audio but still everything seems to work fine now.

This driver is funny.
 

Erenhardt

Diamond Member
Dec 1, 2012
3,251
105
101
Installing 14.9.1 over the 14.9 resulting in my system freezing after the 6th blanking of the screen.

Rebooted, tried again, got a 0x0000003b error.

Tried DDU, system froze again after the 6th blanking of the screen.

I re-installed a couple more times and the installation succeeded with only one error regarding hdmi audio but still everything seems to work fine now.

This driver is funny.

Was that official 14.9 driver from amd site you had installed?

Well "Hallelujah" this AMD 14.9.1b Dvr seems to be working on my system.

Unigne Heaven and BF4 now work.

Unigine Valley and Heaven Bench scores have increased from 5116 to 5159 and 2906 to 2913 in 1080p respectively with a modest 1105/1500 OC with my X-Fire 290X Elpida cards without artifacts. The 1440p Benches have also benefited about the same.

CPUID HMPro spills out 34/32/56C for the runs. Kinda makes me wonder if I don't have some more GPU OC'g room from this WB X-Fire setup.

What was your previously stable overclock? Did you memory OC headroom increased?
 

Z15CAM

Platinum Member
Nov 20, 2010
2,184
64
91
www.flickr.com
What was your previously stable overclock? Did you memory OC headroom increased?
1105x1500x150x50 was my last stable OC using the 14.6RC Dvr. I normally ran it at 1100x1500x143x50 _Neither had any sign of artifacts. I have yet to determine if this 14.9.1b Dvr makes any difference for OC'g.

I doubt if a driver will affect the amount of Mhz's and Voltage you can pump through a device as it is basically hardware limited; but I'll give it a go ;o)

It a;ways seem I get slight white flickers on the leaves of the waving birch shrub about 3/4 the way through Valley Bench if I attempt to go higher then 1105x1500x150x50 with TRIXX settings/Synchronized cards in Multi-GPU ENABLED and this STUPID Elpida vRam seems to demand at least +0.143mV to hold at 1500Mhx's.

OK I tried 1110x1500x150x50 I scored 5159 exactly the same as the 1105x1500x150x50 clean OC with this driver compared to a 5116 clean score with the 14.6rc dvr but I had a very minor white flicker in that same birch shrub - So there you go - This driver does not make any different in the amount of MHz's and Voltage you can pump through a card.

I can safely run this 290X X-Fire a 1100x1500x143x50 24/7 if I choose. It's just that this 14.9.1b dvr gives me a few more frames faster at the same OC.

------------------

GEEZ!
I was able to run TRIXX reset at 1105 x1500 x 0.00mV x 50 and got a perfect 5132
score with Valley at 1080p - Something is a mist here - I do not believe TRIXX is
configuring the VDDC off-set and this 1105x1500 OC may be the MAX OC I get with
the cards at stock voltage - Windows Explorer worked BUT when I opened FF the
system CRASHED with that 1105 x 1500 x +0.00mV x 50 configuration. It is probably
because I left Valley open between benches? Gotta do some research here!!!

With out a doubt there is really something strange the way this 14.9.1b driver responds
to any configuration of of the VDDC off-set which can land you into a quagmire.
 
Last edited:

Z15CAM

Platinum Member
Nov 20, 2010
2,184
64
91
www.flickr.com
This is the method I use to Re-Install AMD GPU Drivers.
Hope it helps someone.
------------------------------------------------------

[How to Use DDU].TXT

Extract DDUv13400-[Guru3D.com].exe or latest version to a TEMP folder C: \TEMP and make a Shortcut to Desktop of the EXE.

Copy the New AMD GPU Driver to your Desktop.

Disconnect from Internet.

Ensure 100% DPI.

IMPORTANT: DISABLE X-Fire. This is to keep the GPU BIOS state in Sync with the Enabling of X-Fire.
If it don't react properly and you have a Yellow sign on one of the AMD GPU's in Device Mgr
you can always Shut Down - Shut off the PSU and wait until the MB Powers off and ReBoot
to acquire the proper Sync to load the driver properly and Enable X-Fire.

Disable everything in StartUpMgr except Desktop INI's.

Log Off/On

Use Control Panel CCC Express Uninstall.

REBOOT.

REBOOT into SafeMode "F8*.

Run DDU with Adm Rights to remove all traces of old driver.
Select Graphic Driver as AMD from Drop Down Menu.
Check Remove C: \AMD.
Click Clear and Restart.
Then you reboot,

make sure you are disconnected from the internet
otherwise your machine may try to automatically install MS' back-up drivers.

On ReBoot the System will complain Device Dvr Not installed and request another ReBoot - So REBOOT.

DELETE all AMD and ATi Folders in C: \Programs Files & Common Files
Program Files (86) & Common Files
USER\AppData\/Local and Roaming
ETC...

Do NOT Edit Registry to Delete instances of AMD & ATi entry's as DDU has DONE IT SAFELY.

While still disconnected from Internet,install new driver with Adm Rights.
Select Custom and UnCheck Gaming Evolved App.
Click FINISH - Do Not check allow Web Content.

When the new driver is fully installed, REBOOT as requested.

Be patient until AMD CCC window pops up which Enables X-Fire by clicking "Go" button.

Reopen CCC.
UnCheck allow Web contend and UnCheck Show this page.
Browse to Performance / Crossfire Tab to ensure X-Fire is Enabled.
Leave Page Open and Close CCC.
CCC should now always open on this Page.

Check Device Mgr to see if both 290X's are present and all 3 High Definition Audio Devices are installed correctly (MB Audio or Card and the 2 AMD Hi-Def Audio Devices).

ENABLE Apps in StartUpMgr and change DPI to 113% (I Use this DPI) - Log Off/On.

Reconnect to the internet, Edit START Menu, Clean DeskTop and DDU App in C: \TEMP.

REBOOT and make a Registry BackUp.

NOTE: If your System freezes due to a bad OC when running a Unigine Bench, it's best to shut off the PSU and pull the plug and wait for the MB to Power Down. This will ensure both your GPU's BIOS's reset and the X-Fire Enabled driver load in Sync.

This is particularly usefull if you ever get notice that NO AMD Drivers are installed on a ReBoot.
 
Last edited:

Warsam71

Senior member
Jul 29, 2013
287
0
0
Hello everyone,

I just wanted to bring your attention to a new thread I just started regarding the availability of our new Catalyst 14.9.1 Beta Driver. Here is the link to the thread: AMD Catalyst 14.9.1 Beta Driver for Windows Available Now

I kindly ask you to post your comments/feedback on that thread. This will help me track the thread better and more importantly report your feedback to the Driver and Support Teams.

Thank you! :)
 

ASK THE COMMUNITY