SharePlay worked perfectly for a year... now friend can't join my session for past month

WAZ

Golden Member
Jan 17, 2001
1,634
0
76
#1
My friend and I have been using Shareplay flawlessly, with no problems, for the past year. We both have good high-speed connections. Mine's a bit faster, so I always host and he joins.

Suddenly, the past month or so, he has not been able to join my Shareplay session. I'm not sure if it's since the 4.0 system update, or what might have changed behind the scenes on PSN, or what. But our internet speeds have not changed, settings have not changed, nothing has changed on our ends. One night he couldn't connect, and that was that. The weird part is, I CAN connect to him if he hosts. I can fire up NHL 17 and try to Shareplay -- no go. He fires up Borderlands and Shareplays with me -- and I can connect just fine. But again, that's the opposite of how we've played for the past year, and I own NHL 17 and intend on continuing to host.

I have mine set up with a static IP, and using Google's DNS servers (8.8.8.8 and 8.8.4.4). I've also tried port forwarding on my router. On speedtest.net I get about 90mbps DOWN and 12mbps UP... on PSN those speeds are anywhere from 30 to 85 down (usually in the 40 range, for whatever reason my PSN speeds are like half my actual speeds) and 7 or 8 up. When I host, it tests in the mid-to-high blue on the meter. My buddy gets about 65 down and 4 up on both speedtest and on PSN; his tests on PS4 are in the yellow. So his speeds on PSN are actually FASTER for download but SLOWER for upload than mine..... and yet he can HOST Shareplay but it says his connection is too slow to join. Super randomly, once he changed his DNS to Google's, it DID work for one night last week. We tried again last night, happy it had worked... and suddenly he couldn't connect again, even though we changed nothing. Does it matter if he has a static IP for port forwarding? Anything else EITHER (or both) of us can change?

This conundrum is maddening and doesn't make any sense to us, especially since it worked perfectly for a year prior to this.Why would it suddenly stop allowing him to join, telling him his speeds are insufficient to join... yet allowing him to host just fine? Again, all with nothing changing on our ends, and him having speeds of 65 down, 4 up, which should be more than enough to join as a client, if not host. It's so random.

Any help would be greatly appreciated. Thank you very much!
 

WAZ

Golden Member
Jan 17, 2001
1,634
0
76
#2
Bump!
 

Adam James

Junior Member
Nov 21, 2016
1
0
1
#4
Dude. Same issue here, almost exactly. I've tried calling Ps4 support and they say there's nothing they can do. I don't know how you survive as a company without a level 2 support desk.

I've added my ps4 to my network dmz, added static ips, removed the firewall from my router, and still no luck. I have no idea what's going on.
 

ASK THE COMMUNITY

TRENDING THREADS