• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Linux Ubuntu 18.04 LST to 19.04 upgrade failed

b4u

Golden Member
Nov 8, 2002
1,376
2
81
Hi,

I need help with a problem with a linux laptop machine. The laptop was installed with a Linux Ubuntu 15.10 and I took the time to upgrade the distro.

So I upgraded from 15.10 -> 16.04 LST -> 18.04 LTS and it all seemed so far, so good.

Then I put the machine to upgrade to 19.04 and went away from it, while it worked its way out and when I arrived, the screen was black.

I pressed the power button, and I got it to turn on, and after a while, I got the following message (copied by hand):

Code:
[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x25 (or later)
Couldn't get size: 0x800000000000000e
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 5.0.0-36-generic #39-Ubuntu
Hardware name: XXXXXXX/XXXXXXX, BIOS XXXXXXXX 01/31/2015
Call Trace:
dump_stack+0x63/0x8a
panic+0x101/0x2a7
mount_block_root+0x238/0x2df
? do_early_param+0x95/0x95
mount_root+0x38/0x3a
prepare_namespace+0x139/0x18e
kernel_init_freeable+0x23c/0x262
? rest_init+0xb0/0xb0
kernel_init+0xe/0x100
ret_from_fork+0x35/0x40
Kernel Offset: 0x3cc00000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)
---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) ]---
Is there any way I can recover it?


Many thanks in advance.
 
Last edited:

b4u

Golden Member
Nov 8, 2002
1,376
2
81
Hi,

Long night, but I recovered the laptop to a working status.

I attempted to load the grup menu in an attempt to boot into a previous kernel version, but was not able to do it. So I had to take the long road to recover the laptop into a bootable state.

Just to share my steps, I focused on the following message:

Code:
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)
Then I followed the steps:

1. Burned an Ubuntu 19.04 version to an USB pen (the version I was updating to);
2. Booted from USB into a livecd instance;
3. Opened a terminal and executed the following steps:

Code:
sudo fdisk -l
# checked the partition that contained the linux installation, as /dev/sdaX

sudo mount /dev/sdaX /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

update-initramfs -u -k 5.0.0-36-generic
# above version was identified in the error itself:
# CPU: 0 PID: 1 Comm: swapper/0 Not tainted 5.0.0-36-generic #39-Ubuntu

update-grub2
4. Restarted

Somehow the initrd file for that version was missing from /boot folder, but after the above commands, it was created.

Then I updated and upgraded to 19.10 version and it's working fine so far.
 
Last edited:

Iron Woode

Elite Member
Super Moderator
Oct 10, 1999
24,100
623
126
I am sticking with 18.04 LTS for my server. It works fine and is very stable.
 

you2

Diamond Member
Apr 2, 2002
4,442
65
91
For 'non-test' machines i generally stick to LTS versions; the non LTS systems are generally not stable or tested with regards to upgrades (i.e., bullet proof). Having said that I had a similar issue that you had when i upgraded from 16.04 to 18.04 and it took a while for me to get it fixed. I don' tthink it was a missing initd per sey but something in the grub configuration was messed up during the upgrade and i had to fix it with update-grub2. Luckily i was able to use a tablet to web browse until i found a solution ;)
-
I'll be moving to 20.04 this summer (I hope); 18.04 was one of the worse upgrades ever with the move to decon X. Also they broke hd graphics in sandbridge and i get frequent panic in the ati driver (I had to add a cheap ati video card because the kernel had problem with my intel graphic on sandybridge - this worked fine in 16.04).
-
There were several other bugs introduced in 18.04 that had been fixed in 16.04. You know one step forward two steps backward - 16.04 worked flawless for all my systems. I hope 20.04 is better.
 

ASK THE COMMUNITY

TRENDING THREADS