I have to boot my computer twice to get to Windows. Why? (M.2 NVME SSD primary boot drive)

gozulin

Senior member
Dec 21, 2004
219
0
76
Hello friends,

I have the weirdest problem!

I have an Asus Z170I Pro Gaming motherboard with an M.2 slot where I have placed a 512GB Samsung 950 pro as my primary OS drive. My secondary is a Samsung 850 pro SSD.

Every single time I boot the system, it goes straight to BIOS. Every.Single.Time.

when I press the power button to turn it off, and then turn it back on, it boots to windows normally.

This is not a huge deal, but it is annoying (because my PC is hooked to the TV, and my 980TI doesn't send video signal to the TV when it's in Bios, while the iGPU does...) and puzzling

Does anyone have any guesses as to what's causing this behavior, or if there is a solution? I really can't make heads or tails of it. I'm assuming it has to do with the M.2 slot somehow but I can't really come up with any solid theory. I feel ashamed :(

ps: having a 950 pro boot drive is overrated. I can't really notice the difference between that and a regular SATA 3 850 pro. Definitely not worth the price hike.
 

UsandThem

Elite Member
Super Moderator
May 4, 2000
15,667
6,626
146
Has the system always done this, or did you recently add/clone a drive, or any other hardware changes?

Are you are the most recent BIOS for your motherboard?
 

UsandThem

Elite Member
Super Moderator
May 4, 2000
15,667
6,626
146
What about your BIOS version? It shows they are up to version 1809 (August 5, 2016). They have had 5 BIOS updates this year, and all say "improve system stability". Is your drive formated in GPT or MBR? GPT is used for UEFI and MBR is used for 'other OS/Legacy' or CSM format (you can look at your boot order and see if it is booting to UEFI drive)

Also, I know this thread I am linking to isn't your motherboard, but it seems there have been quite a few people with Asus boards who have this 'boot to BIOS' issue. Some have fixed it by switching to a different keyboard, but there are several things to look at in the thread that might help:

http://www.tomshardware.com/answers/id-1755027/asus-z87-constantly-boots-uefi-bios-utility-windows.html
 

gozulin

Senior member
Dec 21, 2004
219
0
76
My Bios was from May. I've updated to the latest and it seems to have resolved it. The interesting part is that my 950 pro doesn't show up in the main Bios screen and I can't set it as primary.

Doesn't matter though, After it tries the other, it eventually boots from it anyways.

EDIT: F$#% !! The bios upgrade brought back System Display driver crashes (AKA black screens requiring me to reboot, which I started a previous anandtech thread about here:)
 
Last edited:

UsandThem

Elite Member
Super Moderator
May 4, 2000
15,667
6,626
146
My Bios was from May. I've updated to the latest and it seems to have resolved it. The interesting part is that my 950 pro doesn't show up in the main Bios screen and I can't set it as primary.

Doesn't matter though, After it tries the other, it eventually boots from it anyways.
It's probably just a setting or something odd. As long as it works, that is the important part.

Oh, and one last thing (so if anybody using a Google search comes across this thread). I never addressed your statement of the 950 Pro not being any faster than your 850 Pro in typical desktop usage. You are 100% correct, and probably one person a week on this site buys one, and also realizes it. Most people who just play games and do typical everyday tasks do not see the performance increase they were hoping for. However, if a person's work involves heavy I/O workloads, those are the people who will see it.

http://techreport.com/review/29221/samsung-950-pro-512gb-ssd-reviewed/6

Anyways, good luck.
 

gozulin

Senior member
Dec 21, 2004
219
0
76
And downgrading the Bios back to May did not resolve the black screen issue. FML!

I realized that the Bios upgrade reset all my settings (WTF, ASUS???) so I went and messed around with some GPU power settings, and at least now I know for sure that my motherboard is the issue with the GPU crashes.

We'll see how it goes.
 

UsandThem

Elite Member
Super Moderator
May 4, 2000
15,667
6,626
146
After flashing the BIOS, you are supposed to go in and load the defaults, save, and restart. Some changes they made could cause issues or not take effect until you did that.

After loading the defaults, you then could manually change any settings you needed to.
 

wpcoe

Senior member
Nov 13, 2007
586
2
81
After flashing the BIOS, you are supposed to go in and load the defaults, save, and restart. Some changes they made could cause issues or not take effect until you did that.

After loading the defaults, you then could manually change any settings you needed to.
Is that S.O.P.? I never knew that. I always assumed that whenever a new BIOS was loaded it totally overwrote the old version, including any customized settings.
 

UsandThem

Elite Member
Super Moderator
May 4, 2000
15,667
6,626
146
Is that S.O.P.? I never knew that. I always assumed that whenever a new BIOS was loaded it totally overwrote the old version, including any customized settings.
Yup. If you look in your manual, on pages 2-2 and 2-5 it has a finger pointing towards "Ensure that you load BIOS default settings to ensure system compatibility and stability."
 

[DHT]Osiris

Lifer
Dec 15, 2015
10,274
6,892
146
Check Windows, either the startup parameters (system configuration from start search) or if your board has an application which sets some startup flags or something... See if there's something telling it to boot from bios each time you get to windows (essentially flagging the computer for booting to bios after every windows startup, aka every other time).
 

mrpete

Member
Jan 24, 2009
26
0
61
I'm going to continue down the path that [DHT]Osiris mentioned ... the OS.

It hasn't been mentioned in this thread what OS you are booting. If it is Win10 then I want to bring up that some folks using Win10 has experienced "2 boots to startup" problems related to Win10 Fast Startup.

Try disabling it. See if that makes a difference.

Control Panel -> Power -> Choose what the powrr button does -> Change settings currently unavailable -> Fast startup [disable it].

Good luck!
 

DTN107

Member
Sep 7, 2016
26
2
16
I had the same issue with my ASUS Z-97A board and tried so many methods with no results. My only solution was to send it to Asus for an RMA. They were about to send me back my own board but I stress heavily about the double boot issue. If you go this way OP be sure to push for a replacement board.
 

ASK THE COMMUNITY