• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question HDR(Play HDR games and apps) keeps toggling off

Arun05Aravind

Junior Member
Oct 27, 2019
4
0
6
Unable to turn on HDR tried with 2160 and 1080 on both 60hz and 30hz it keeps toggling back off instantly.
Windows 10 Build 1903(18362.449)
Display- TCL iFFALCON 55K2A(I can play HDR10 videos via pendrive directly on the TV and it looks great)
PC(RX580 Red Devil Golden Sample 8GB) to Display(TCL iFFALCON 55K2A) via HDMI 2.0 cable

Note: When playing Resident Evil 2(2019) and Devil May Cry 5 HDR turns on automatically and the TV says HDR10 is ON but it makes everything look worse colors are washed off and looks foggy DMC5 I have to change the resolution to 1440p/1080p and then back to 2160p to turn off HDR to play without HDR(which looks better-normal) in RE2 I have to turn off HDR in game settings to turn off HDR and play without HDR if I play in windowed mode in any resolution on those games HDR won't turn on.

Sometimes if I play in 1080p HDR ON and in full screen and then if I switch to desktop using alt+tab or win+tab then in windows settings it shows HDR ON automatically but even my desktop looks way worse with washed off colors and a foggy screen and even the texts are unreadable, So I have to turn off HDR in the settings.

Radeon Settings Advisor keeps telling me to apply HDR and WGC when I hit apply same thing happens the screen flashes for a sec and then if I hit scan again it will show the same message.

will attach the pics of my radeon settings I never changed them it's all default

What might be the problem is there any way to fix it?
Please help me out.

Global Settings.jpgColor depth.jpgHardware.jpgRadeon Settings Advisor.jpgSoftware.jpegOverview.jpgPixel Format.jpg
Dxdiag info if that helps
---------------
Display Devices
---------------
Card name: Radeon RX 580 Series
DAC type: Internal DAC(400MHz)
Device Type: Full Device (POST)
Current Mode: 3840 x 2160 (32 bit) (60Hz)
HDR Support: Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.659180,0.339844), Green(0.244141,0.669922), Blue(0.129883,0.040039), White Point(0.312500,0.329102)
Display Luminance: Min Luminance = 0.010000, Max Luminance = 1499.000000, MaxFullFrameLuminance = 799.000000
Monitor Name: Generic PnP Monitor
Monitor Model: TCL SMART TV
Monitor Id: TCL0058
Native Mode: 3840 x 2160(p) (60.000Hz)
Output Type: HDMI
Monitor Capabilities: HDR Supported (BT2020RGB BT2020YCC Eotf2084Supported )
Display Pixel Format: DISPLAYCONFIG_PIXELFORMAT_32BPP
Advanced Color: AdvancedColorSupported
 

Attachments

Arun05Aravind

Junior Member
Oct 27, 2019
4
0
6
Don't you have to enable HDR in Windows 10 Settings, Display, Advanced, Color Settings? Native Win10 Settings menus, not AMD's Radeon Settings.
Yes that is the problem "Play HDR games and apps" in Windows settings under display menu right?
when I turn it on screen turns black for a sec then it come back but it turns off "Play HDR games and apps" automatically
 

myocardia

Diamond Member
Jun 21, 2003
9,291
29
91
You don't seem the type to make this mistake, but since you haven't mentioned it, it may very well be your problem. Your TV has three HDMI inputs, a total of one of which is HDR-capable. On 2017 models, it is HDMI #1, the top HDMI slot. On 2018 models, they changed it to be the bottom slot, HDMI #3. If that isn't/wasn't the problem, now you know why AMD cards are cheaper; nearly everything requires some workaround or other.
 
  • Like
Reactions: Arun05Aravind

Arun05Aravind

Junior Member
Oct 27, 2019
4
0
6
You don't seem the type to make this mistake, but since you haven't mentioned it, it may very well be your problem. Your TV has three HDMI inputs, a total of one of which is HDR-capable. On 2017 models, it is HDMI #1, the top HDMI slot. On 2018 models, they changed it to be the bottom slot, HDMI #3. If that isn't/wasn't the problem, now you know why AMD cards are cheaper; nearly everything requires some workaround or other.
Thank you. I have 4 HDMI in my TV 1,2(ARC),3,4 I tried in all of them still the same problem. I doubt my cable so I have bought a new cable which the seller said and also found in comments by users that 4K 60Hz with HDR On worked for them. I will test with the new cable on all 4 ports and update you
 

Arun05Aravind

Junior Member
Oct 27, 2019
4
0
6
You don't seem the type to make this mistake, but since you haven't mentioned it, it may very well be your problem. Your TV has three HDMI inputs, a total of one of which is HDR-capable. On 2017 models, it is HDMI #1, the top HDMI slot. On 2018 models, they changed it to be the bottom slot, HDMI #3. If that isn't/wasn't the problem, now you know why AMD cards are cheaper; nearly everything requires some workaround or other.
Finally fixed turns out all three cables that I have been using were HDMI 1.4v most people told me only the ports matter and not the cable but I ordered a HDMI 2.0b cable from amazon and it worked now everything is working fine. But a new problem started when HDR is on the games(tried DMC 5) are too dark I can barely see the character’s face only bright burning flames are barely visible I’ll play more with the setting and if I can’t fix it I’ll open another thread

hope his can help other who had the same issue as mine
HDMI cable version also matters
 

myocardia

Diamond Member
Jun 21, 2003
9,291
29
91
Yeah, I almost mentioned the cable, but since you had specified in the OP that you were using an HDMI 2.0 cable, it seemed redundant. Glad you got it fixed. BTW, HDR (at least in 2019) in games is a negative, not a positive. It's nothing more than one of those infamous check-box features that most of us ignore outright.
 

ASK THE COMMUNITY