• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Faulty BIOS chip?

prefiX02

Junior Member
Jun 20, 2018
2
0
1
So it all started yesterday when i was trying to fix my motherboard which had a corrupted ME area that was causing lots of overclocking issues. Since a normal bios reflash couldn't fix it I decided to follow this(http://www.overclockers.com/forums/showthread.php/72834...) guide. After setting up a bootable DOS usb and trying to flash the bios it gave me error 204 (data verify mismatch found). After spending hours trying to fix it I was getting frustrated and decided to erase the bios chip and use ASUS' bios flasback feature to do a clean flash of the bios and hopefully fix the ME. Now I feel kinda stupid for doing that since it only led to worse problems. My board now turns on for a split second and then turns off. It's stuck in a loop. The CPU LED does light up before turning off. I tried a different cpu, same thing. Different RAM, still nothing. I even tried removing the bios chip and nothing changed which leads me to believe that the chip itself is dead. I also confirmed that the PSU works.

I could order a new bios chip but that would take weeks to ship, so any help would be appreciated.

Specs:
Asus maximus V gene
i5 2500k
Gtx 780
12gb kingston ddr3 ram
XFX TS 450W PSU
 

ASK THE COMMUNITY

TRENDING THREADS