Question XMP settings not applying correctly on Asus AM4 board?

Chicken76

Senior member
Jun 10, 2013
245
28
91
System config:
Mobo: Asus Prime X570-P
Bios version: 4202
RAM: GSkill F4-3600C17D-32GTZKW
CPU: R9 5900X

As you can see in the first pic below, I have set the XMP profile (or D.O.C.P. as it's called on AMD) but the CAS latency is not 17 as it should be, but 18 (see second pic)
What could have caused this? I've tried going back to 2133, saving settings, rebooting and then setting it back to DOCP with the same result.
I should mention this memory kit is on the motherboard's QVL list, so it's been validated to work fine at the rated speed.

IMG_20220522_193136.jpg


2022-05-23 14_50_11-IMG_20220521_090828-2.jpg
 
Last edited:

Shmee

Memory and Storage, Graphics Cards
Super Moderator
Sep 13, 2008
6,119
1,443
136
I am not certain, but my guess is that the board does not want to POST at CL 17, and it auto adjusts the value to 18 in order to boot. As long as it is stable, I wouldn't worry about this too much, though you could try the following if you want: instead of enabling DOCP/AMP, key in the memory frequency, memory voltage, SoC voltage, and primary timings manually and see if that does the trick.
 

kschendel

Member
Aug 1, 2018
172
99
101
I vaguely recall that there was some memory setting that prevented Ryzen from using odd CAS latency clocks. Unfortunately I am not in a position right now to dig around and find it. I don't think it was gear down mode?
 

CakeMonster

Golden Member
Nov 22, 2012
1,213
288
136
Gear Down Mode (GDM) has some advantages, and I believe its recommended to keep it on in general, but it will stop you from running odd timings.

1653580413137.png
 

ASK THE COMMUNITY