• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."
  • Recovering from Halloween? Take part in our Spooky Giveaway to be in with a chance of replenishing your wardrobe. A simple riddle stands in your way. Visit the sweeptake thread over here.

Windows 8.1 Media Center HDCP issues

Medikit

Senior member
Feb 15, 2006
338
0
76
I recently replaced my HTPC with an intel NUC: http://www.bhphotovideo.com/bnh/cont...=REG&A=details

It has the Intel HD5000 chipset and I've updated all of the drivers. I am running Windows 8.1 which I think is part of the problem.

I have the HDhomerun Prime and it works fine on my Ivy Bridge Desktop computer which is also running Windows 8.1.

However, the NUC often pops up with a warning that "HDCP support is required". If I minimize the screen the video will start displaying. Conversely if I begin minimized it will say "HDCP support is required" but the video will begin displaying if I maximize the screen. Once the video is displaying it may crash and say "Video error" "files needed to display video are not installed or are not working correctly. Restart Windows Media Center or restart the computer".

This is the only problem I am having so far, Plex and Netflix work fine and I am liking the Metro Apps for these.

This is the HDMI cable I am using: http://www.amazon.com/Monoprice-Perf...hdmi+monoprice

With this adapter: http://www.amazon.com/Monoprice-HDMI...hdmi+monoprice

I am also using a 2009 model Samsung TV and a Denon E400 receiver.
 
Last edited:
Sep 12, 2004
16,852
58
86
For the HDCP issue make sure you have run the Digital Cable Advisor in Windows Media Center.

For the video error problem, disable Navigation Sounds.
 

LoveMachine

Senior member
May 8, 2012
491
3
81
That silly Navigation Sounds error is one of the most frustratingly simple fixes for WMC. That little Bwoop sound gave me the same problems (Win7 though), and this chicken guy above solved all my WMC problems with that suggestion. I have no idea why MS can't have one coder spend an hour to fix that little error.
 

Medikit

Senior member
Feb 15, 2006
338
0
76
For the HDCP issue make sure you have run the Digital Cable Advisor in Windows Media Center.

For the video error problem, disable Navigation Sounds.
I turned that off and haven't seen the video error since then. Thanks!

I did run Digital Cable Advisor already.

The HDCP thing is really weird. If I first start it up it will give me the error and the screen will repeatedly flash. And then if I change the mode- full screen if minimized, or minimized if full screen then it will start playing.

It works fine on my Ivy Bridge with Windows 8.1.
 
Last edited:

Aikouka

Lifer
Nov 27, 2001
29,074
341
126
The HDCP thing is really weird. If I first start it up it will give me the error and the screen will repeatedly flash. And then if I change the mode- full screen if minimized, or minimized if full screen then it will start playing.
I have a NUC (Haswell i3) with Windows 8.1, and I don't have any issues with HDCP and WMC (I use a Ceton InfiniTV 6 ETH, but that shouldn't matter). Although, if you have the absolute latest graphics drivers, I think I am one revision behind as I'm usually too lazy to update them unless there's an issue with the drivers.

When I had a NVIDIA-based HTPC (GTX 660 Ti), I had issues with HDCP. I found that as long as I went into the NVIDIA Control Panel, and looked at the HDCP page, it worked fine. If I didn't do that, I would get the HDCP screen in WMC. I don't know why I had to do that, but I did.

Anyway, it might be worth trying to downgrade the graphics drivers.
 
Sep 12, 2004
16,852
58
86
Like Aikouka said, it could be the graphic drivers causing the HDCP issue.

Another potential problem is the startup order. I generally have to turn on my TV, amp, then WMC PC to prevent any problems with the HDMI handshake.

The HDCP implementation can be finicky. Hopefully it will be improved in HDMI 2.0.
 

Medikit

Senior member
Feb 15, 2006
338
0
76
Like Aikouka said, it could be the graphic drivers causing the HDCP issue.

Another potential problem is the startup order. I generally have to turn on my TV, amp, then WMC PC to prevent any problems with the HDMI handshake.

The HDCP implementation can be finicky. Hopefully it will be improved in HDMI 2.0.
Will give that a shot. Looks like there are some Beta drivers that came out during the end of June, will give those a shot first.

Still doing that error. Will try to use an older version later.
 
Last edited:

BonzaiDuck

Lifer
Jun 30, 2004
13,968
700
126
I've experienced similar symptoms with an integration of my sig-rig, AVR-HDTV and the HD Homerun Prime.

Somehow I got rid of the problem. I can't say if it was related to the conversion to a new channel lineup by my cable-provider.

I can only say that it is a good idea to occasionally open the HD Homerun software and rescan for channels, then go through the same procedure with the Media Center Setup menu. Also, hardware changes on the computer can trigger these frustrating symptoms.

I think it's also important to schedule daily "Media Center Optimization" and inspect your MC UPdate operations to see if they're successful, or take action to correct the problem if they aren't.

Also -- one more. It might depend on which AV/Firewall "IS" suite you're using. If the software suite automatically chooses programs, DLLs etc. to exclude from the "fully trusted" lists, you may want to look closely to see that Homerun Prime or SiliconDust software isn't somehow put in a "partially restricted" category.
 

ASK THE COMMUNITY