Where can I download a (legal) virtualbox image of Windows XP?

Discussion in 'Operating Systems' started by JoLLyRoGer, Feb 10, 2011.

  1. JoLLyRoGer

    JoLLyRoGer Diamond Member

    Joined:
    Aug 24, 2000
    Messages:
    4,149
    Likes Received:
    1
    So my dilemma is simple. I have Oracle Virtualbox running on Centos 5.5 and need to get Windows XP up and running in a VM to do some stuff with LabView on this machine.

    So far all of my build attempts using my own copy of WinXP haved ended with a BSOD and I can't figure out why. My postulation is it has something to do with the Digium PRI cards I'm running with Asterisk not agreeing with the VB drivers/kernel modules somehow.

    Anyway, I want to test this a little further and am on the hunt for a downloadable .vdi image of a Windows XP install that I could possibly register/activate myself..

    Let me be very clear here. I am NOT looking to pirate anything. I have my own Retail registration key TYVM.

    And for anyone who missed that the first time... I'm NOT looking to pirate Windows XP (there are better OS's out there for that :D )!!!

    So, any links? or alternatively anyone here willing to do me a baseline VB build of XP and link me up via FTP? Does not need to be registered/activiated.. I will handle that.

    Thanks,
    JR
     
  2. Loading...

    Similar Threads - download (legal) virtualbox Forum Date
    Microsoft legal Windows 7 refresh media download? (FOUND) Operating Systems Mar 28, 2015
    Legal Download of xp Operating Systems Aug 2, 2012
    Vista Upgrade through windows marketplace (US / UK download export legality questions) Operating Systems Feb 5, 2007
    Can I download Vista legally for free? Operating Systems Feb 1, 2007
    where can i find the latest beta copy of whistler, and is it legal to download and install?? Operating Systems Feb 12, 2001

  3. lxskllr

    lxskllr Lifer

    Joined:
    Nov 30, 2004
    Messages:
    46,346
    Likes Received:
    534
    I think that would be illegal(anti EULA) unless MS offered it themselves(I doubt it). If someone here doesn't hook you up, torrents might be your best bet.
     
  4. JackMDS

    JackMDS Super Moderator<BR>Elite Member
    Super Moderator

    Joined:
    Oct 25, 1999
    Messages:
    28,075
    Likes Received:
    47
    The only XP download is the XP-Mode that works with Win 7.

    Any other installation of Win XP Virtual.

    Whether it is on Microsoft VPC, VMware, or Virtual Box, the installation is done via the original OS CD.

    I do not know why it does not work in your system, may be if you will give technical info and follow a track of finding out what is wrong with your installation, you will be able to resolve the issue.


    :cool:
     
  5. JoLLyRoGer

    JoLLyRoGer Diamond Member

    Joined:
    Aug 24, 2000
    Messages:
    4,149
    Likes Received:
    1
    Cool! Thanks MrChad.. Hopefully that will work.
     
  6. JoLLyRoGer

    JoLLyRoGer Diamond Member

    Joined:
    Aug 24, 2000
    Messages:
    4,149
    Likes Received:
    1

    Very well then.. here goes. Starting from when Dinosaurs Walked The Earth!

    Began with a base install of PBX In A Flash (which uses a combination of CentOS 5.5, Asterisk 1.6, Dahdi 2.4.0+2.4.0, Libpri 1.4 and FreePBX 2.6) to set up a base bones open source PBX.

    I did the PBX In A Flash build because my previous attemps of building from scratch and compiling from source never quite yeilded a bug-free install. I was always having issues with the PRI cards (Digium TE122Ps) loading properly. PIAF seemed to work... moving on...

    I want to do some work with LabView and manipulate a shared directory in CentOS/Asterisk where I can drop '.call' files to cause Asterisk to place calls automatically using LabView as a scripting engine of sorts (there are reasons I prefer not to do this with a shell script in Linux).

    I need five things to make this work properly.
    1. A stable build of Asterisk/Dahdi(Zaptel)/FreePBX
    2. A GUI Desktop environment installed
    3. A virtualization environment using Linux as the host
    4. A stable Windows VM
    5. LabView execution environment installed on the VM.


    Steps 1-3 are done. After the PBX In A Flash installation completed I did:
    #yum update -y; yum groupinstall "X Windows System" -y; yum groupinstall "GNOME Desktop Environment";

    And a quick reboot.

    Was able to start GNOME:
    #startx

    So Far So Good.. Asterisk is runing, PRI cards are stable, FreePBX is working, and I have a GUI Desktop.

    Time to install VirtualBox:
    #yum list | grep virtualbox
    ...no packes found

    Downloaded the CentOS 5 rpm from oracle.com:
    VirtualBox-4.0-4.0.2_69518_rhel5-1.i386.rpm
    #tar -ivh VirtualBox-4.0-4.0.2_69518_rhel5-1.i386.rpm

    install proceeds no issues.

    time to start VirtualBox:
    #virtualbox

    VirtualBox loads as expected so I proceed by clicking:
    New > Next >
    -I give it a name of Win
    -Operating System: Microsoft Windows
    -Version: Windows XP
    > Next

    -I assign 1024MB of memory (Host machine is running 4GB)
    > Next

    Virtual Hard Disk:
    -Boot Disk checked
    -Create New Hard Disk selected
    >Next

    Create New Disk Virtual Wizard:
    >Next

    Hard Disk Storage Type:
    Dynamically Expanding Storage selected
    >Next

    Virtual Disk Location and Size:
    Default location of /root/VirtualBox VMs/Win/Win.vdi
    and default size of 10GB
    > Next

    Summary:
    > Finish
    Summary:
    > Finish

    Here I select the VM "Win" and pressStart
    Welcome to First Run Wizard
    > Next

    Select Installation Media:
    -Accept default of "Host Drive ASUS DRW-2014L1T (hda)
    > Next > Finish

    VM Starts up at this point and the Windows Install begins:

    A quick look at the processor load from a Linux Terminal Window reveals the following:
    #top

    top - 15:47:23 up 2:45, 3 users, load average: 2.75, 1.69, 1.24
    Tasks: 137 total, 1 running, 136 sleeping, 0 stopped, 0 zombie
    Cpu(s): 6.7%us, 50.6%sy, 0.0%ni, 42.7%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 3368192k total, 969648k used, 2398544k free, 58500k buffers
    Swap: 779144k total, 0k used, 779144k free, 457940k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    6159 root 15 0 307m 64m 17m S 100.2 2.0 1:19.00 VirtualBox
    3888 root 14 -1 61136 20m 7784 S 11.0 0.6 2:54.17 X
    4145 root 15 0 64088 14m 9428 S 2.0 0.4 0:01.21 gnome-terminal
    4099 root 15 0 10532 3032 1984 S 0.7 0.1 0:00.88 VBoxXPCOMIPCD
    16 root 10 -5 0 0 0 S 0.3 0.0 0:01.82 kblockd/1
    6022 root 15 0 67800 26m 16m S 0.3 0.8 0:04.85 VirtualBox
    1 root 15 0 2160 640 556 S 0.0 0.0 0:00.45 init
    2 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0
    3 root 34 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
    ............

    VB is commanding nearly 100% of the CPU durring install (Intel Core 2 Duo 4300 on Tyan server MoBo)

    Windows XP Install proceeds normally:
    -Select the Unpartitioned space (10 GB) to install Windows XP
    -Do a quick format of NTFS

    so far so good

    Checking drive C: (after format)
    OK

    Setup is copying Files:
    Gets to 17% (copying driver.cab)
    BSOD!

    A problem as been detected and windows.. blah. blah. blah....
    ----cut-----
    Technical Information:

    *** STOP: 0x0000007F (0x00000000,0x0000000,0x00000000,0x00000000)

    Linux Host Info:
    uname -a
    Linux pbx.local 2.6.18-194.26.1.el5 #1 SMP Tue Nov 9 12:54:40 EST 2010 i686 i686 i386 GNU/Linux

    So there's the long version...
    ????
     
  7. Lifted

    Lifted Diamond Member

    Joined:
    Nov 30, 2004
    Messages:
    5,756
    Likes Received:
    1
    House of cards ;)

    I've only played around with PIAF, but I've set up pretty stable systems with Elastix a year or 2 ago using Digium hardware. If PIAF starts giving you nightmares you should give it a try. I didn't use it with a PRI as I didn't have the heart to push anyone who required a PRI onto an asterisks solution, but the analog Digium hardware worked fine.
     
  8. Fear No Evil

    Fear No Evil Diamond Member

    Joined:
    Nov 14, 2008
    Messages:
    5,922
    Likes Received:
    0
    You have a technet subscription? I'm guessing no but obviously if you did you could download an ISO off of there. I don't think YOUR key will work with the technet ISO though unfortunately so you couldn't even just get the ISO and use your own key.
     
  9. JoLLyRoGer

    JoLLyRoGer Diamond Member

    Joined:
    Aug 24, 2000
    Messages:
    4,149
    Likes Received:
    1
    Right ?! You're not kidding there! PIAF was definitely NOT my first choice. Like I said I've been trying to compile from source and haven't found that 'silver bullet' yet.

    I did try a couple different releases of Elastix along the way as I've had good luck with that distro in the past. In fact it's my de-facto go-to for "*" builds. Only this time when it boots the first time it goes to the process of loading the drivers and spits out all kinds of garbage about how it missed the interrupt and has to increase latency to compensate.

    All this after waiting a good 5 min for udev to time out right off the bat. Then to compound the issue once it finally does load I get a message about how the 'Digium Commercial' firmware taints kernel...

    THEN.. on the very next reboot it goes into a kernel panic and freezes up.... So that's been my experience using Elastix thus far.

    Beyond that I must have tried a dozen or so combinations of Asterisk, Libpri, Dahdi, and FreeBBX and just getting those damn PRI cards to load properly at boot time has been more than a struggle.

    I even downloaded old versions and rolled back to original Zaptel which seemed to work much better for the PRI cards but inevitably I'd grab a version of Asterisk that either wasn't compatible with the old Zaptel stuff or I'd get that all going and have a version of FreePBX that didn't agree with the older version of Asterisk, etc. etc.

    Really I'm ready to pull my hair out so when PIAF finally loaded everything and made it through the 1st boot-up I was in that mindset of "take what the defense gives you".

    But THEN, the issue with VirtualBox rears its ugly head and I'm like damn!! Can't a brother catch a break!?


    IDK, I've done several Asterisk builds before (including one at my house on the new 1.8 with free Google Voice calls to the US) but nothing that has given me this kind of grief!!

    "All I want are Friggin Sharks with Friggin LASERBEAMS attached to their heads!!"

    Thanks though... ;)
    -JR
     
    #9 JoLLyRoGer, Feb 10, 2011
    Last edited: Feb 10, 2011
  10. JoLLyRoGer

    JoLLyRoGer Diamond Member

    Joined:
    Aug 24, 2000
    Messages:
    4,149
    Likes Received:
    1
    Maybe I'll try a Debian/Ubuntu based install and go through this whole nut-roll one more time....

    It's an angle I've not broached yet.