• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

What is your HTML performance 2D

Page 2 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.

blastingcap

Diamond Member
Sep 16, 2010
6,654
5
76
My laptop (Intel Pentium P6100 with semi-embedded GPU... not same die, but next to each other) gets 16/20 seconds with IE9/Chrome on the first test.

In fishbowl with 2000 fish, it's reverse: 5/6 fps with IE9/Chrome.

So IE9 is not necessarily faster than Chrome at HTML5, even though it sure looked that way from my desktop tests.
 

2is

Diamond Member
Apr 8, 2012
4,281
130
106
I noticed the Nvidia guys aren't posting their results- besides this guy who got 7seconds on a 680. :D
First couple guys who responded were running nVidia cards too. Just for kicks I reran the test again today and I'm hitting 6 seconds on both my 680 and HD 4000 IGP. I really don't think the GPU matters at all. Only difference between my setup now and when I was hitting 7 seconds is a .005v bump in vcore after I noticed some odd behavior that I'd attribute to instability.

Hitting 45fps on fishbowl with 2000 fish.
 

Fenuxx

Senior member
Dec 3, 2004
907
0
76
I just decided it would be amusing to do this on the computer I'm forced to use at work. The result?

1793 seconds. In other words, 29 minutes and 53 seconds


Core 2 Duo E6750
3GB RAM
Intel Q35/GMA 3100 (1680x1050 resolution)
Windows XP SP3 (Install date: 12-09-2008)
Google Chrome 19

Proof:

 
Last edited:

blastingcap

Diamond Member
Sep 16, 2010
6,654
5
76
I just decided it would be amusing to do this on the computer I'm forced to use at work. The result?

1793 seconds. In other words, 29 minutes and 53 seconds


Core 2 Duo E6750
3GB RAM
Intel Q35/GMA 3100 (1680x1050 resolution)
Windows XP SP3 (Install date: 12-09-2008)
Google Chrome 19

Proof:

Hilarious! Usually threads like this are good for showing off e-peen, but maybe this thread can turn into an exhibition of lack of e-peen: who can boast the slowest performance in this test? I thought my laptop was slow, but your time takes the cake, at least for now. It's actually so slow that I wonder if you have a virus or were heavily multitasking or something. :D
 

Fenuxx

Senior member
Dec 3, 2004
907
0
76
This comp I use at work is so over bogged down with crap (it's a corporate comp) like crappy overbearing anti-virus, user group-policy enforcement, etc etc. Plus, the install of Windows is so ancient that it desperately needs a re-install.

I've done everything I can possibly do (that I have the privileges to do) to clean it out (disable services, uninstall crap, CCleaner'ed) but that realistically only did a small bit.
 

jpiniero

Diamond Member
Oct 1, 2010
9,939
2,285
136
8 seconds in IE9.

On Firefox, I have Direct2D turned off because of the fonts issue so I didn't even get to the point where you start the test, heh.
 

kami

Lifer
Oct 9, 1999
17,627
4
81
FF12 6 seconds

Fish bowl with 2000 fish in FF12: 60fps. too bad it cant go above 60
 

Qbah

Diamond Member
Oct 18, 2005
3,754
10
81
6 seconds in FF12
8 seconds in IE9
11 seconds in Chrome 19
Probably a few hours in Safari... runs at 4 FPS, takes 2-3 seconds to flip a page

EDIT: 3564 seconds for Safari D:
 
Last edited:

beginner99

Diamond Member
Jun 2, 2009
4,846
1,232
136
FF12 on an X220 laptop with i7-2620m:

478 seconds

I double checked GPU acceleration is enabled but it does not seem to work on HD3000!!!
Can anyone confirm this?

did not repeat the test fully with IE9 but it looked just as slow.

6 sec on desktop with hd 5850.
 

blastingcap

Diamond Member
Sep 16, 2010
6,654
5
76
FF12 on an X220 laptop with i7-2620m:

478 seconds

I double checked GPU acceleration is enabled but it does not seem to work on HD3000!!!
Can anyone confirm this?

did not repeat the test fully with IE9 but it looked just as slow.

6 sec on desktop with hd 5850.
Wow, are you sure you don't have a virus or any other programs running? How much system RAM are you allocating to graphics, and what speed is your RAM at? My laptop is a P6100 (about equivalent to a Core2Duo 2.4GHz) with a GMA HD semi--embedded GPU which is slower than your GPU, but I gave mine 64MB dedicated video memory with sharing up to 1.6GB more (I have 4GB DDR-3 1066Hz total), rez is 1366x768. Win 7 64-bit though I doubt that matters.
 

2is

Diamond Member
Apr 8, 2012
4,281
130
106
28 Seconds on my MacBook Air running safari

1.86GHz Core 2 Duo
nVidia 320m igp
 

JBT

Lifer
Nov 28, 2001
12,095
0
76
6 Seconds in Chrome and IE9
41 FPS with Chrome 2000 fish
44 FPS with IE9 2000 fish
with the rig in my sig.

Bunch of stuff running in the back ground.
 
Last edited:

mnewsham

Lifer
Oct 2, 2010
14,477
397
136
with my sig laptop:
Chrome 19: 7 seconds
FF12: 6 seconds
 
Last edited:

beginner99

Diamond Member
Jun 2, 2009
4,846
1,232
136
Wow, are you sure you don't have a virus or any other programs running? How much system RAM are you allocating to graphics, and what speed is your RAM at? My laptop is a P6100 (about equivalent to a Core2Duo 2.4GHz) with a GMA HD semi--embedded GPU which is slower than your GPU, but I gave mine 64MB dedicated video memory with sharing up to 1.6GB more (I have 4GB DDR-3 1066Hz total), rez is 1366x768. Win 7 64-bit though I doubt that matters.
Yeah pretty sure. Why would a virus impact html GPU performance? Beside that i would notice the high CPU/GPU usage from fan speed.

I installed newest drivers from Intel directly. Same result.
Realized i was on battery power -> pluged it in but: Same result.

Could anyone with a HD3000 run this test? Would be very interested if they get the same poor result.
 

lopri

Elite Member
Jul 27, 2002
12,842
325
126
GT 240, 6 seconds on IE9 and Firefox 12.0. Opera (my main browser) doesn't seem to utilize the GPU and takes a while so I stopped it.
 

Turbonium

Golden Member
Mar 15, 2003
1,772
2
81
I've been running this test in FF12 for a while now. Mobile Intel 965 Express Chipset (GMA X3100) with latest drivers on a T5470 (1.60 GHz) Core 2 Duo. CPU is maxed out.

In short, my average draw duration is 247ms, and I've only completed around 2800 billboard draws, with an FPS of 4. Desktop resolution is 1440x900.

This think will finish at some point, right?

Not really sure how many steps there are to this test btw, although I think I'm in part 2 of it if there is one (after first running through a test, it then gave me the option of running through another, which I selected).
 

Jeff7

Lifer
Jan 4, 2001
41,599
17
81
FF12.
Am I doing something wrong? How long until it shows a result? It's been going for two minutes now, and it's still flipping random letters and characters, at 6fps.

Win7 64 bit
i7 960 @ 3.2GHz
8GB RAM
 

blastingcap

Diamond Member
Sep 16, 2010
6,654
5
76
FF12 - 6 seconds.

Sig rig.

....so this means what exactly?
It means you should run fishbowl with 2000 fish and report your fps. :)

http://ie.microsoft.com/testdrive/Performance/FishBowl/

There was some discussion of this earlier in the thread as more capable of separating rigs, since everyone was sitting on 6-7 seconds in the OP's test.

Note that HTML5 does in fact use your GPU if available, though it only used a fraction (~25-30%) of my GPU's power according to MSI Afterburner.
 

Turbonium

Golden Member
Mar 15, 2003
1,772
2
81
I just reduced the window dimensions and it seems to be running slightly faster (the average draw duration is now closer to 200 ms). It's still running at 4 FPS though, and bogging down the entire system.

EDIT:

2728 seconds (almost 46 minutes)

And I cheated by reducing the window dimensions to make it run faster, too.
 
Last edited:

beginner99

Diamond Member
Jun 2, 2009
4,846
1,232
136
FF12.
Am I doing something wrong? How long until it shows a result? It's been going for two minutes now, and it's still flipping random letters and characters, at 6fps.

Win7 64 bit
i7 960 @ 3.2GHz
8GB RAM
It means you either have a ultra crappy GPU (probably not the case) or a browser that does not support gpu acceleration or has it disabled.
 

ASK THE COMMUNITY