What is this ShieldSquare business?

Apr 3, 2001
47,784
636
126
#1
I've never seen it before, now I've already gotten it twice today, once upon logging in, and then when opening threads.
 

allisolm

Elite Member
Administrator
Jan 2, 2001
22,856
266
136
#2
Is it an ad? Is it a popup? Is it on a PC? Mobile? Using Tapatalk? Why is whatever it is a problem?
 
Oct 9, 1999
11,452
102
126
#3
Me to its BS, if i have to do that stupid tell me which pictures have traffic lights captcha every few threads i open them im never coming back here, this is asinine.
 
Apr 3, 2001
47,784
636
126
#4
Is it an ad? Is it a popup? Is it on a PC? Mobile? Using Tapatalk? Why is whatever it is a problem?
Windows 7 PC, Firefox current version. Because it's a huge PITA when you click to open a thread, then you get directed to this page where you have to complete 2-3 CAPTCHAs before you can proceed.
Me to its BS, if i have to do that stupid tell me which pictures have traffic lights captcha every few threads i open them im never coming back here, this is asinine.
Yep, I'll definitely be gone if it stays around.
 

Attachments

allisolm

Elite Member
Administrator
Jan 2, 2001
22,856
266
136
#5
Thanks for providing more information. I have brought it up to the Purch people to look into.
 
Last edited:
Oct 9, 1999
11,452
102
126
#6
Thanks for providing more information. I have brought it up to the Purch people to look into.
I just got one again checking this reply when i got yhe notification there was a reply. This is beyond annoying, more so since neither of my captcha solving plug ins work with this one...

Im out for sure if this isnt resolved.
 

CommManagerJ

Community Manager
Staff member
Jun 27, 2016
276
22
81
#7
Thanks for letting us know. This can happen from time to time if you're on a VPN, on a network of known spammers, using outdated software, or spoofing extensions on your browser.

I'll let the devs know and update here once I receive a response.
 
Apr 3, 2001
47,784
636
126
#8
Thanks for letting us know. This can happen from time to time if you're on a VPN, on a network of known spammers, using outdated software, or spoofing extensions on your browser.

I'll let the devs know and update here once I receive a response.
I can say nothing has changed about the setup I'm using, and today was the first time I've seen it, and it's been at least 5 times today.
 
Oct 9, 1999
11,452
102
126
#9
I can say nothing has changed about the setup I'm using, and today was the first time I've seen it, and it's been at least 5 times today.
same here, nothing has changed, same browser, same extensions, same internet. And every single time i check the replies to this thread specifically i get the damn captcha as well as at other random times.
 

Broken

Platinum Member
Apr 16, 2000
2,457
0
81
#10
Thanks for letting us know. This can happen from time to time if you're on a VPN, on a network of known spammers, using outdated software, or spoofing extensions on your browser.

I'll let the devs know and update here once I receive a response.

While you're at it, let Purch know to fix the stupid hijack adds. Freaking rediculous!
 
Sep 25, 2001
25,207
118
126
#11
Thanks for letting us know. This can happen from time to time if you're on a VPN, on a network of known spammers, using outdated software, or spoofing extensions on your browser.

I'll let the devs know and update here once I receive a response.
using same laptop, os (win7), browser (IE 11) and vpn since 2 years ago.
today was the 1st time I saw this new captcha.
 
Aug 25, 2001
44,493
812
126
#12
Thanks for letting us know. This can happen from time to time if you're on a VPN, on a network of known spammers, using outdated software, or spoofing extensions on your browser.

I'll let the devs know and update here once I receive a response.
Well, it happens to us, NOT using a VPN, NOT spoofing anything in our browsers, and is residential FIOS connections,. "on a network of known spammers"? I'd like to know. As for the "using outdated software", I'm on the newest Firefox Nightly, on Windows 10 Pro, newest version.

I do have certain anti-tracking "privacy" add-ons, but as far as I am aware, they are not "spoofing" plug-ins.
 

scgt1

Golden Member
Feb 7, 2006
1,634
0
81
#13
Same problem here. Seems to have been going on since the site virtually wouldn't load the other day.
 
Jan 8, 2010
14,793
504
126
#14
I've been getting this too. Every time I refresh practically. At first it was just the checkbox, now it is that annoying click the pictures. No VPN, etc.

Since multiple people are seeing it start at the same time and different browsers, I'd definitely say it is something that changed on the AT side.
 

CommManagerJ

Community Manager
Staff member
Jun 27, 2016
276
22
81
#15
I've asked to white list all of you. I'm also working with the developers to prevent this from happening in the future.
 
Apr 3, 2001
47,784
636
126
#16
Well, whitelisting seems to have done the trick, thanks.
 

mrblotto

Golden Member
Jul 7, 2007
1,491
24
91
#17
I just got one of those ShieldSquare captcha things out of the blue........wha? Been using the same machine for months.......*shrugs*
 

FeuerFrei

Diamond Member
Mar 30, 2005
8,997
147
126
#18
I just got one of those ShieldSquare captcha things out of the blue........wha? Been using the same machine for months.......*shrugs*
Seconded. Same machine I always use. First time EVER seeing this captcha JUST NOW - on Firefox's initial load of forums.anandtech.com.
At least there's a thread on it already ... but I'd never encountered it until now.
 

FeuerFrei

Diamond Member
Mar 30, 2005
8,997
147
126
#20
I haven't had any re-occurrences since my post last week. Pretty isolated incident.
Seconded. Same machine I always use. First time EVER seeing this captcha JUST NOW - on Firefox's initial load of forums.anandtech.com.
At least there's a thread on it already ... but I'd never encountered it until now.
 
Aug 25, 2001
44,493
812
126
#21
I got one a couple of days ago, which I thought was kinda weird, if I was white-listed. Though, I don't know if the WL was by IP or username or what. Not a huge deal, as long as I'm not seeing them pop up all the time.
 

DeathReborn

Platinum Member
Oct 11, 2005
2,015
18
91
#22
Getting this every time I go to the AT Forums, getting a bit tedious now.
 
Mar 11, 2004
18,913
1,108
126
#23
Same thing here, but after I tried changing my add-ons (NoScript and PrivacyBadger) to try to be able to see what it actually was (I couldn't fully see the Captcha stuff, it just said Suspicious Activity and then had a checkbox inside a frame below it), it now just throws up 403 Forbidden (with nginx below the 403 Forbidden banner line) when going to the forums on Firefox. I'm currently on Chrome and it had no problem whatsoever.

Its fixed for me now on Firefox.
 
Last edited:

ElFenix

Elite Member
Super Moderator
Mar 20, 2000
98,293
536
126
#24
Got one earlier today
 

hardhat

Senior member
Dec 4, 2011
306
9
91
#25
I've been getting captcha challenges and 403 forbidden messages pretty regularly. Nothing has changed about my setup in months. Win 10 Pro/Firefox/no VPN/definitely not spoofing extensions or on a network of known spammers.
 

ASK THE COMMUNITY