Weird A7v/keyboard problem


Junior Member
Sep 28, 2000
I just attempted to put together a new computer but had a weird situation that stopped me dead in my tracks. My base hardware setup is as follows:

A7v motherboard (rev 1.02)
Duron 700
128mb Mushkin RAM
Visiontek GeForce MX
Fong Kai FK-603 case

After installing the basic hardware and booting, I attempted to get into BIOS but found that the keyboard was not responding. Tried 4 or 5 different keyboards (PS/2, don't have a USB and don't want to resort to one yet, the PS/2 is so basic, it should work) and nothing happened. Caps lock/etc keys won't light. Switched video card and monitor, same situation. What will happen is I boot, system POSTs and gets to the point where it finds no boot devices (booting from a floppy disk to a prompt still gives me no keyboard input). What is weird however is if I reset the comp and hold down delete, I can get into BIOS but can't do anything in the BIOS screen, still won't accept keyboard input. On one keyboard I noticed the caps lock/etc lights were just barely flashing on and off and a high speed.

At this point I'm guessing that it's a motherboard situation and I should probably send it back for a new one. Any ideas? What's puzzling is the fact that I can get into the bios every second time I boot, yet can't do anything. I'm wondering if this is just a weird A7v quirk, a friend has an similar setup and didn't experience this problem.



Sep 21, 2000
I have had this problem for 2 weeks now, called Asus and AMD, still nothing. I tried about every forum I can find, and many people have the same problem with A7V, K7V, and Abit KT7. I think it might be a problem with the VIA Chipset and certain RAM, but I'm not too sure. But for me, after about ten resets and/or cold boots, the computer will eventually boot up.