USB Problem


Junior Member
Apr 3, 2003
First off let me say I realize this is my third post on this matter but the last 2 were not getting me any results ;) hope this helps....

Now for the problem

If I click on "My Computer" or use Windows Explorer my system takes up to 5 minutes to show the folders and drives... with a little flashlight saying "searching for drives/folders"

I am running WinXP Pro Svc Pack 1
on :
MSI K7N2G-ILSR Motherboard and latest BIOS
with 512 MB DDR 2700
AMD XP 1800 (not OC)
running at about 28 degrees C and 80 degrees F
2 WD 40 Gig HD, on IDE 1
Master, Slave config
not using RAID or SATA

I had this exact problem with my last Mobo so I just bought this one and the Memery
so it is not the board of Mem, I have also used a 20 gig WD, so it's not the HD's

The one thing I do notice is that if I unplug all my USB Devices (4 total) it starts acting right again
but it will not remember my view settings. For example... I have my drives listed by type in "My Computer"
and when it does finally load or if I unplug the usb's everything shows but it is not grouped and their are no details (File System, Size and so on)

I bought this board for one reason because it hase 4 usb port's naturally, whereas my old board only had two and I used a usb hub. I figured since when I unplug my usb's on the old board things started acting right that this board with the 4 built in should resolve the problem. No luck there,

I also have svc pack one which has support for USB 2.0 so its not that.

I am open to any suggestions anyone has since I can not search this problem out on the net because
all the results come back with like a million "windows explorer tips"

in short HELP!!!!

Thanks in Advance
Vandit :wine:

Green Man

Golden Member
Jan 21, 2001
I think you have a couple of issues going on that aren't nessesarily related.

First of all, I assume that it is a fresh install of XP. Although there are methods to increase the chance of a successful migration of motherboard, I trust a fresh install more...especially when things are getting twitchy.

I'd work on getting your resources under control first, so the system is useable. You may want to unplug your USB devices to speed things up while you go into device manager (right click my computer, select properties, click the hardware tab, click the device manger button) Are there any yellow marks next to any of the devices. If there are, double click the device to get more detailed information about the problem.

If there are no problems in device manager, right click the task bar and select task monitor. Choose the performance tab and observe the CPU usage (after a brief spike when you open it, CPU usage should be near zero if no other application are running). Now look at PF usage and available memory. You should have significant available memory with 512MB. Browse to a folder on your hard drive and view the contents. Does it open quickly? While you're here, click the view tab and from the list of tiles, icons, details ect... select details. Now right click on the top of the details window where it says name and click to put a check mark next to each column you want to show in the view. Now click the tools tab on top and select folder options. If you don't want it to search for network folders, clear that check box...that might speed things up. Scroll down and find remember each folders view settings and check it. XP will remember 200 folders, so if you want to increase it search for a thread here in the last couple of days about how to do that. If you want all folders to be the same, click the button on top.

Now start plugging in your USB devices one at a time and see what happens. CPU usage should increase sharply while the device is detected and installed, then it should return to near zero. Available memory will decrease and PF usage may increase while this happens, then they should return to near previous levels. Record what happens. If anything stands out, we will know what to look for in perfmon when you recreate the problem.

After all the USB devices are connected, browse to a folder you want to view and open it. Observe the Task manager window for CPU usage if it takes really long to open. What happens?


Junior Member
Apr 3, 2003

It is a freash install of XP since this board has a diffrent chipset than the last. My old board has a Sis chipset this has the nForce2 chipset. All the things you have suggested I tried with the previous setup along with changing the HD, MEM, and removing all my cards, so it was only running the onboard stuff with all updated drivers. After 2 days I got tired of fighting it and bought the new board and memory, then I wrote zero's to the OS drive and formated it NTFS, as was the previous setup was NTFS.

Now my usb devices are as follows:

1. HP 5550 Printer
2. HP Scanjet 5400c Scanner
3. Logictech wingman controller
4. Wacom drawing tablet

All with the latest drivers.

All worked fine since I have had them and they still do except for this. Like I said if I unplug them all and plug them back in the system see's them and they work.

In the old system I had 2 onboard USB 1.1 ports, this board has 4 onboard USB 2.0 ports.

I have noticed one thing strange since my last post that I did not notice before. That is that if I boot up with my USB stuff pluged in (even just one) I have the problem, but if I boot with none of them plugged in and plugged them in while the system is on I do not get the problem. I guess I could just leave the system on and I would not have to worry about it, but this is unpractical becasue I dual boot Redhat 8.0.

So that means whenever I comeback to windows I have to crawl under my desk and start unplugging and replugging (needless to say this sucks)

Also everything works fine in linux, I just have a lot of software that I use that only runs on Windows, if it were not for that I wold have dumpped windows ages ago.

Also the device manager looks good, no trouble hardware anywhere to be found......




Junior Member
Feb 21, 2003
Are you booting from grub or lilo and if so have are you using the nforce2 linux drivers?