The Hackintosh Thread

Page 19 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.

destrekor

Lifer
Nov 18, 2005
28,799
359
126
Because I hate doing things one step at a time, I'm not sure which exactly worked, but it worked.

A) I dug back into the AppleAHCIPort.kext and compared with a different one, and that different one seemed a little more complete. I had tried it previously, but I had neglected to note the importance of it's greyed-out status. I ran an "unhidden" command (can't remember it now), and I also chown'd and chmod'd all the kexts (kext utility doesn't really work with the directory structure in Clover).
B) I also placed LegacyAppleAHCIPort.kext in that directory (prior to fixing permissions). It seemed to have more controllers, but it also seemed to have some differences in the strings.

I ended up just nuking the whole SSD that was originally shared between the previous Mountain Lion installation and a Windows Server 2012 installation. It was good to mess around with Server, but in this utilization, it's pointless. When I have a chance to dedicate a box, I'll get to work more on my play-lab environment... for now, no point keeping it sitting there doing nothing.

That, and the installer kept complaining about it not being a GUID-partitioned drive (that drive was MBR). So I just dedicated that disk to the cause - more system disk room to grow, making it more likely I can keep all system stuff on the disk for a long time and only need external storage for files.


Now, that all said - I have a Mac installation on a disk with three partitions: EFI, the main system, and what I'm assuming is some kind of recovery partition. Windows doesn't really recognize anything about the three partitions except the one is EFI. The third is 620mb.


More importantly, I have a Mac installation that I can't get to! :(

The USB bootloader/vanilla install disk doesn't give a means of going to that disk to boot - and when I choose, in the F8 boot menu, the SSD that OS X is installed on... it immediately starts booting Windows.

I'm going to need to, I assume, get into the main installation to really work on the config.plist using Clover Configurator, because the Configurator will not launch in the VM (a Lion installation, iATKOS specifically, in VirtualBox).
I guess I need to add an entry to the boot menu or something? Copy the kexts and current temporary config.plist, nuke the rest, and make a straight USB bootloader?

Windows 8 is not installed in UEFI mode, so, I'm not sure if I can actually make OS X boot in UEFI - I don't think my P8Z68 Deluxe has true full UEFI support, at least, not in the secure boot sort of way.
That said, if I were to make the OS X the default boot disk, would it even be able to launch Windows from a boot option? Would I be editing the boot files in the EFI partition?
Which... how do I do just that, considering I can't see my system disks in the VM?
 

destrekor

Lifer
Nov 18, 2005
28,799
359
126
For anyone following along:
(my Unix/Linux is very rusty.. let alone OS X)

I discovered how to mount the EFI filesystem on the USB (it is "MSDOS" [FAT32]- did not realize that).
By placing the Clover "EFI" boot directory into the EFI volume (after mkdir and mount), I was then able to choose the UEFI boot option in the F8 boot menu of my Asus motherboard.
The boot seems slow for the whole UEFI thing, but there are many many things I have to do yet. I can boot into 10.9, but... much work ahead. I need to load up some more tricks through the VM: Clover Configurator and probably a few kexts to start - no internet! apparently doesn't even list my Intel gigabit - thought that one common AppleIntel1000E kext was supposed to do the trick.

For now, I did just do a direct copy of the EFI folder I initially configured for the installer boot through the Clover installer (and a few tweaks).

I am not sure on how to really proceed with the booting though. Of course many tweaks to the actual Clover configuration lie ahead, but where the bootloader resides is killing me. I don't feel like goofing up my Windows system, and I've always been iffy around changing of bootloaders - in the past, something always got screwed up. lol
But now I'm introducing GPT when my systems have always had MBR, and currently is apparently in a dual MBR/GPT state. There is an empty FAT32 EFI partition on the Mac GPT disk that could play host to Clover - but I want to ensure that disk taking the boot lead and then linking back to Windows doesn't screw up the Windows bootloader (which really changed something awfully strange with Windows 8), and more importantly, actually boots Windows.

I have used and configured boot variables in Linux/Grub (GRUB2 the most recent, I think)... I am just completely unfamiliar with OS X and it's bootloaders.

Right now, I just know that every time I want to use OS X, waiting to press F8 to then arrow up/down to the UEFI USB bootloader, and then waiting what seems like 10 seconds for the Clover interface to pop up and then arrow over to the OS X installation... that's going to get bothersome. (/firstworldproblems? lol)

It seems (from what I've gathered from a few posts) that a lot of Asus boards make it difficult to "register" a new UEFI entry... which, I'm not going to kid you, I don't think I even understand yet. I've also been told using a specific register option within the Clover boot interface does exactly that for HDD-based UEFI loaders.

The question I'd have for that: with my current environment, do I want to write anything to any UEFI memory? With Windows not being installed in UEFI, how will it play out getting from one to the other?
Ideally, I'd like to avoid stacking bootloaders - it just slows down the whole process.


[This is becoming a fascinating experiment - something I needed to get my PC/computing juices a-flowin' again - being out of a job is killing me. ]
 

mosslack

Senior member
Nov 16, 2008
902
0
71
hq-a.weebly.com
It seems I have come into possession of 3 (new to me) laptops. I was given these to erase the hard drives and then do with them what I wanted. The 3 are, in order of size, a Dell Inspiron 1525, Dell Studio 1440/14z and finally an Acer Aspire One. None came with a power adapter and all had dead batteries, but I tried the PSU from my Neutrino netbook on the Acer and got it going no problem. It seems to have a good battery as well as it charged up to 97% and has held it's charge well. It only has 1 Gb of RAM and is running XP Home, but it does run well. I did an erecovery restore back to factory specs and it seems okay.

I bought my granddaughter a new Dell laptop when she went to college, so I used the PSU from it to try out the Dells. First up was the Inspiron, which came up in the Windows Vista desktop in no time flat. There were 3 users listed at boot and one didn't require a password, so I booted using that user. Checked the specs, 2.0 Ghz C2D CPU, 3 Gb RAM and a 1280x800 display. Windows reported that the battery is bad, but I've also heard from others that if the wrong Dell power adapter is used it won't charge the battery. There also seems to be a slight keyboard problem as the backspace doesn't seem to work. I used the F8 trick to get into the system restore and have the OS back to it's factory default, minus the Dell crapware.

Last up is the Studio model which does boot up to the user selection screen. Trouble is that the single user requires a password, so I couldn't go any further. Also could not use the F8 trick to restore to factory defaults as that too requires a local user password. I've check the BIOS also and was locked out of that too as a password is required. Also not sure if it has the 720p or 900p HD display.

I attempted to boot from my USB flash drive with the Windows 7 installer on it, but that would not come up. Funny I could use the myHack USB OS X installer flash drive to get as far as the Apple logo, but then when it's time to switch to the desktop the screen goes dark and the flash drive seems to stop responding.

I did try a few switches -x -v, etc., but nothing will get it do the desktop. From what I've read and according to the sticker on the keyboard, I believe the CPU to be some C2D, but I have no idea of how much RAM is installed.

My goal here is to have a stable Hackintosh laptop for traveling and selling the others on ebay. I'm pretty sure the Acer can be made into at least a Snow Leopard system, but I already have a couple of netbook Hackintoshes, so that system is almost certain to go on ebay after I purchase an inexpensive power adapter.

Out of the Dells, I believe the Studio model to be the newest and probably the easiest to Hack, but I'm not really sure of how well it runs yet. My plan is to try a live CD version of Linux and check it out. I do believe it will be just fine though. I did remove the hard drive and checked it out, everything was okay there.

I've heard there is a guide or guides for the Inspiron, but I believe it may be locked into a max of Mountain Lion. I could be happy with that, provided it is a stable system. I just want a full sized OS X laptop to use when I travel.

Okay, I have pleaded my case, now let me have the comments and suggestions. Which Dell needs to go to some lucky ebay bidder and which one needs to go on the road with me?

EDIT: Also forgot to mention that all 3 were a very grimy mess when I got them, but all 3 have cleaned up nicely. Not brand new looking, but above average for their age.
 
Last edited:

mosslack

Senior member
Nov 16, 2008
902
0
71
hq-a.weebly.com
As an update, I tried out the Dell Studio with Linux and ended up wiping the hard drive with it as there was no way for me to use the built-in recovery program to take it back to factory specs. Once I wiped the hard drive, I tried a few versions of myHack and UniBeast to see if I could at least get the installer to run. Finally got a version of ML going using an older version of UniBeast. It took a long, long time, but the installation will boot as long as I use the UniBeast flash drive as the bootloader. Attempts to install the bootloader to the hard drive using EasyBeast have not yielded a bootable system. At least I'm making some progress.
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
As an update, I tried out the Dell Studio with Linux and ended up wiping the hard drive with it as there was no way for me to use the built-in recovery program to take it back to factory specs. Once I wiped the hard drive, I tried a few versions of myHack and UniBeast to see if I could at least get the installer to run. Finally got a version of ML going using an older version of UniBeast. It took a long, long time, but the installation will boot as long as I use the UniBeast flash drive as the bootloader. Attempts to install the bootloader to the hard drive using EasyBeast have not yielded a bootable system. At least I'm making some progress.

Is that a laptop? I've had the same issue on other laptops before, USB-boot only. Very strange, haven't dug into it enough to find the core issue.
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
Just had a family member drop off a broken Hackintosh to repair. Original build date was 2007; last time I worked on it was 2009 when we upgraded it to 10.6 Snow Leopard. It had a copy of their imported & virtualized Windows computer in an ancient version of VMware Fusion. Power hiccuped at their house & killed the PSU (despite being on a surge protector). Swapped out the PSU, good as new again. Amazing!
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
OSX 10.10 Yosemite on a Hackintosh machine: anyone tried it yet?
DP1 can be found on certain torrent sites, if you know where to look.
Also here:
http://blog.shade.sh/index.php/os-x-beta

Someone on Twitter did it right after release successfully. You wont find public information on Tonymac because they try to stay as legal as possible, so no pre-release discussion per the TOS of the dev stuff on their forums.
 
Feb 25, 2011
16,786
1,468
126
Turbo Boost speeds are confusing me.

My point of reference is my Macbook Pro, i7-4750HQ. 2.0 GHz base, 3.2 GHz turbo. It reports 2.0 GHz. MacCPUID (the tool from Intel) also reports 2.0 GHz at idle. I am assuming this is how it's "supposed" to work.

But: The Hackintosh (tonymacx86, Mac Pro Early 2008, 10.9.1) is an i5-4670T, so 2.3 GHz Base, 3.3GHz Turbo. "About This Mac" reports 2.89GHz, (which is definitely not 2.3GHz) while MacCPUID reports 2.3GHz.

1) Why is the Hack reporting an odd speed?

2) What can I do to load the CPU in such a way that it will go into "turbo" mode, to check speed with MacCPUID? I tried a Python script doing really bad infinite loops, to load a single core, but it didn't seem to do the trick. Maybe I need to use floating point math?
 

Essence_of_War

Platinum Member
Feb 21, 2013
2,650
4
81
At the terminal, the 'yes' command should fully load one cpu core. You could try:
yes > /dev/null &
To throw a yes into background, and then run as many additional as you need to fully load up.

killall yes

Should work to kill them when you're done taking measurements.
 

destrekor

Lifer
Nov 18, 2005
28,799
359
126
Anyone got ideas for my onboard audio, ALC889, not working correctly after resuming from sleep?
I am using Toleda's patch and kext, specifically based on his instructions for use with Clover, including using the clover config.plist. After resume, audio might work for a brief moment, then it just goes mute and there is no way to get it back except to restart.

I'm on 10.9.3 by the way. Trying to keep as vanilla as possible, as once I finish some more work, I'll be utilizing Time Machine with my external disk.
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
Anyone got ideas for my onboard audio, ALC889, not working correctly after resuming from sleep?
I am using Toleda's patch and kext, specifically based on his instructions for use with Clover, including using the clover config.plist. After resume, audio might work for a brief moment, then it just goes mute and there is no way to get it back except to restart.

I'm on 10.9.3 by the way. Trying to keep as vanilla as possible, as once I finish some more work, I'll be utilizing Time Machine with my external disk.

I've had some mixed issues with audio patching; I finally got sick of it & got one of those $10 Syba USB stereo sound cards. Works great & sounds better (doesn't pick up noise from inside the case like the onboard audio sometimes did). I did the same thing with Ethernet...got a $10 natively-supported PCI card (Encore iirc). Makes installation & running updates a LOT less hassle.
 

smackababy

Lifer
Oct 30, 2008
27,024
79
86
You guys remember that thread about the MB company making the Hackintosh friendly boards and the guy who bought one? Any resolution ever come from that? I know they were jerking him around or something, but I can't seem to find the thread.
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
You guys remember that thread about the MB company making the Hackintosh friendly boards and the guy who bought one? Any resolution ever come from that? I know they were jerking him around or something, but I can't seem to find the thread.

That would be Quo Computer:

http://quocomputer.com/

The board is $229:

http://quocomputer.com/shop/z77mx-quo-aos/

I think it's a cool idea, but the Thunderbolt is already outdated (they're on v2.0 now) & it's really expensive. Tonymac's Unibeast installer is incredibly simple, so if you buy something off his compatibility list, it's generally pretty straightforward:

http://www.tonymacx86.com/436-building-customac-buyer-s-guide-june-2014.html

I cheat on mine...I keep a USB stick plugged in 24/7 with Unibeast as the bootup stick (I call the USB stick "Boot Drive" and the OS drive "Hard Drive"), keep the hard drive 100% Mac-only, and then use a USB sound card & PCI network card with native support so that patch updates are a breeze (although I still use Superduper to clone before I run updates, safety first!). I believe there are a couple PCI Express wifi cards that are recognized as native as well, such as this Rosewill model:

http://www.amazon.com/dp/B009VKON0S/

If you pick the right parts, it's nearly as easy as installing OSX on a real Mac these days!
 

smackababy

Lifer
Oct 30, 2008
27,024
79
86
Has there been any advancement in the "make a boot disc without needing a functioning Mac" area? That is what has kept me from trying a hackintosh.
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
Has there been any advancement in the "make a boot disc without needing a functioning Mac" area? That is what has kept me from trying a hackintosh.

iirc there were a few ways of doing it. Probably the easiest way is by installing OSX into a virtual machine (requires some hacks & no GPU support) & then setting up your USB stick. Here's a guide:

http://www.sysprobs.com/guide-insta...mware-workstation-with-windows-7-or-windows-8

As far as creating the stick goes:

1. Create an account at Tonymac
2. Download Unibeast v4
3. Format an 8GB (or larger) USB stick in Disk Utility using:

a. Volume scheme: 1 partition
b. Partition scheme: Master Boot Record (Options button)
c. Format: Mac OS Extended (Journaled)

4. Download Mavericks from the Mac App Store
5. Run Unibeast (depending on your USB stick speed, can take up to an hour)

Read a guide on your specific motherboard & video card; there are usually some BIOS tweaks you need to do to make things play nice (AHCI etc.).
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
You guys remember that thread about the MB company making the Hackintosh friendly boards and the guy who bought one? Any resolution ever come from that? I know they were jerking him around or something, but I can't seem to find the thread.

Oh and speaking of Quo, you can apparently go the DIY route for modding the BIOS:

http://www.skylineosx.com/ozmosis-a-firmware-based-bootloader/

They recommend a board with dual BIOS in case you screw something up...
 

DigDog

Lifer
Jun 3, 2011
13,468
2,102
126
Hi guys;

i'm looking for a ez- parts list for a hackintosh. I've just started reading the OSx86 website since i last looked at it years ago, but i figured here is a better place to get some straight answers.

Budget is around $2k, don't need monitors.

It will run mostly LogicPro, HT is welcome.

The owner (a friend) is a technophobe, so once the system is installed, up n running, it should be easy to boot/use/other stuff.

I do the build/install. I've done builds before, never a hackintosh install but i have google-fu. He knows OSX so he's self sufficient once the system is running.


Got any recommendations?
(i'm in europe so i'd rather *not* deal with ASUS and their rma center)
 

TheStu

Moderator<br>Mobile Devices & Gadgets
Moderator
Sep 15, 2004
12,089
45
91
Hi guys;

i'm looking for a ez- parts list for a hackintosh. I've just started reading the OSx86 website since i last looked at it years ago, but i figured here is a better place to get some straight answers.

Budget is around $2k, don't need monitors.

It will run mostly LogicPro, HT is welcome.

The owner (a friend) is a technophobe, so once the system is installed, up n running, it should be easy to boot/use/other stuff.

I do the build/install. I've done builds before, never a hackintosh install but i have google-fu. He knows OSX so he's self sufficient once the system is running.


Got any recommendations?
(i'm in europe so i'd rather *not* deal with ASUS and their rma center)

I usually go to TonyMac to check out their part guides. The usual rule of thumb these days is intel, Gigabyte, nVidia. Stick with those 3 brands and you're already ahead of the curve.

For Logic Pro, what's the thinking behind not just getting a Mac?
 
Last edited:

vailr

Diamond Member
Oct 9, 1999
5,365
54
91
Last edited:
Nov 20, 2009
10,046
2,573
136
Anyone finding Multibeast difficult probably needs to just go buy a Mac. The stuff on tonymac is about as easy as conscious humans need.
 

Kaido

Elite Member & Kitchen Overlord
Feb 14, 2004
48,409
5,269
136
Hi guys;

i'm looking for a ez- parts list for a hackintosh. I've just started reading the OSx86 website since i last looked at it years ago, but i figured here is a better place to get some straight answers.

Budget is around $2k, don't need monitors.

It will run mostly LogicPro, HT is welcome.

The owner (a friend) is a technophobe, so once the system is installed, up n running, it should be easy to boot/use/other stuff.

I do the build/install. I've done builds before, never a hackintosh install but i have google-fu. He knows OSX so he's self sufficient once the system is running.


Got any recommendations?
(i'm in europe so i'd rather *not* deal with ASUS and their rma center)

An updated parts listing is here:

http://www.tonymacx86.com/436-building-customac-buyer-s-guide-june-2014.html

I would recommend a Z87 Gigabyte motherboard ($300 max) for maximum compatibility, plus a 4ghz Intel Core i7-4790K CPU ($340) and 32GB RAM ($300) as the foundation of the system. Video cards range between $100 to $1200 depending on what you want to do with them. The base requirements for Logic Pro aren't super high:

4GB of RAM
Display with 1280-by-768 resolution or higher
OS X v10.8.4 or later
Requires 64-bit Audio Units plug-ins
Minimum 5GB of disk space. 35GB of optional content available via in-app download.

Do they need any special connectors like Firewire? I know the new Pro Tools stuff is Thunderbolt-based (buy it on the motherboard if you need it, since you can't add it later as an expansion card). As far as storage goes, a 1TB SSD is $432: (I believe a Hackintosh boot drive is still capped at 1TB max)

http://www.amazon.com/Samsung-Electr...dp/B00E3W16OU/

Or a slightly faster 512GB model is $215:

http://www.amazon.com/Crucial-MX100-...dp/B00KFAGCUM/

For data, you can snag a 6TB hard drive for $300:

http://www.amazon.com/Seagate-Deskto...dp/B00JBJ34WC/

For something like a basic GT640 GPU ($100), a speedy 512GB MX100 boot drive ($215), and a high-end Gigabyte board ($215), you'd be looking at just under $1200. Then add a case, power supply, Bluray or DVD disc drive, optional internal memory card reader, CPU fan (the 4ghz CPU doesn't come with one), and whatever other misc. stuff you want in there (case fans, higher-end thermal paste, lights & clear door panels, etc.). A 4TB USB 3.0 portable backup drive is $130:

http://www.amazon.com/Seagate-Expans...dp/B00BFFQN3M/

You could build a pretty monsterous rig for $2k in the Hackintosh world :thumbsup:
 

vailr

Diamond Member
Oct 9, 1999
5,365
54
91
An updated parts listing is here:

http://www.tonymacx86.com/436-building-customac-buyer-s-guide-june-2014.html

I would recommend a Z87 Gigabyte motherboard ($300 max) for maximum compatibility, plus a 4ghz Intel Core i7-4790K CPU ($340) and 32GB RAM ($300) as the foundation of the system.

The only potential problem with a Z87 + i7-4790K motherboard + CPU combo would be: if the board's bios is too outdated, it may not work with more recent CPU's such as the 4790K. In that case, a bios update using an older processor would be required to solve the problem.
One example:
GA-Z87X-UD5H requires bios version F9 or later:
http://www.gigabyte.my/support-downloads/cpu-support-popup.aspx?pid=4483

Actually, I'm not aware of any OSX compatibility differences between Z87 vs. Z97 chipset boards.
And: AFAIK, all Intel 9 series board bioses are also 4790K compatible out of box.
 
Last edited:

DigDog

Lifer
Jun 3, 2011
13,468
2,102
126
I usually go to TonyMac to check out their part guides. The usual rule of thumb these days is intel, Gigabyte, nVidia. Stick with those 3 brands and you're already ahead of the curve.

For Logic Pro, what's the thinking behind not just getting a Mac?
yupp, my google-fu brought me there, so i'm reading it right now.

re: logic, the truth is that the person who will be using Logic is not really a sound eng/musician/ other professional, but an amateur, so its really a matter of saving some dough.

he called me 2 days ago saying he got quoted £1600 for (who know what piece of junk entry-level mac), while a 4670k system w/ samsung evo, etc.. runs at £750 (plus another hundred for the i/o audio card).



if this was the core of a $200k Protools-based recording studio, lol, it would be a genuine mac from apple with all the trimmings and maintenance extras. but its just a homebrew recording gig.


@Kaido

tnx; i'll post back in a few days, when i've talked it through with him and i've got my parts list.
I'm gonna go with an ultra-safe build, 250gb boot and 1Tb HD.

if he gets the bug, we'll do the upgrade.
 
Last edited: