Question Sound Blaster X7 buzzing

Maedre

Junior Member
Jan 1, 2022
4
0
6
Hello,
I bought a Creative Sound Blaster X7 & XM7 speakers and I have a problem with speakers buzzing.

It's happening mainly when I'm connected with BT (PC and also Iphone), but also when I'm connecter with cable to my laptop.
It's very annoying as I can't leave them on high volume because of that, so I constantly have to be turning volume up and down.

I also have a bass problem which I've solved using an EQ app mentioned in this thread:

But that also made the buzzing extremely loud and speakers are basically unusable this way.

Another interesting thing is that when I connect my headphones to X7, they are also buzzing, so I assume it's not the speaker issue.

I love this setup and the sound is beautiful but so far I had a far more complications than good time.

Thank you very much for your help.
 

DaaQ

Senior member
Dec 8, 2018
822
513
106
Is it interference from the cell phone? move phone closer it gets louder? Kinda almost sounds like an old phone modem but with buzzing static not the fax noise, but it's similar.
Kind of like buzz-buzz-buzz click-click click sound coming from speakers.
 

Maedre

Junior Member
Jan 1, 2022
4
0
6
No, It doesn't change if I move my phone, however the buzzing gets louder when I turn the volume up.
I've tried several methods I've found on the internet (using only a single plug, different cables, etc.) but nothing helped.

The buzzing is also changing, for example when I pause a YT video, it stops for a few moments, then it starts again, then it stops when I play the song again. I really don't know what can be the issue.
 

Maedre

Junior Member
Jan 1, 2022
4
0
6
No, It doesn't change if I move my phone, however the buzzing gets louder when I turn the volume up.
I've tried several methods I've found on the internet (using only a single plug, different cables, etc.) but nothing helped.

The buzzing is also changing, for example when I pause a YT video, it stops for a few moments, then it starts again, then it stops when I play the song again. I really don't know what can be the issue.

Here I've recorded a sample of the buzzing.
 
Mar 11, 2004
21,897
4,107
136
What all cables did you try differently? Since it also affects headphones, I'm pretty sure its related to the power source. Could possibly be a faulty power supply or maybe something internal to the X7. Have you by any chance played with any of the opamps? There's a little door on it that you open up and can access socketed opamps, maybe check and see if they're secured in place and that there's nothing internally you can see from there that might be a tipoff.

My guess is you've got a grounding issue. Have you tried plugging the X7 into a different outlet from your PC and/or other (for instance if its near a large appliance like a refrigerator). Also hopefully you don't have it sitting on top of a wifi router or other device putting out signals.
 

DaaQ

Senior member
Dec 8, 2018
822
513
106
No, It doesn't change if I move my phone, however the buzzing gets louder when I turn the volume up.
I've tried several methods I've found on the internet (using only a single plug, different cables, etc.) but nothing helped.

The buzzing is also changing, for example when I pause a YT video, it stops for a few moments, then it starts again, then it stops when I play the song again. I really don't know what can be the issue.

Here I've recorded a sample of the buzzing.
Nope definitely not what my speakers do, and mine are not even plugged into a pc ATM. Though my sub is plugged in.
 

Maedre

Junior Member
Jan 1, 2022
4
0
6
Hey guys,

Thanks for your help. I've put this question on reddit as well and we've "solved" it there. It was probably a ground loop or something that was disturbing the amp. It's not 100% gone but it's way better than before.
https://www.reddit.com/r/SoundBlasterOfficial/comments/rtoyop
But I think that power supply might also be at fault a bit, but I do not have a way find out as I don't want to buy a new one just to test it...
 
Thread starter Similar threads Forum Replies Date
G Audio Components 9

ASK THE COMMUNITY