SOLVED: PCMCIA ethernet problems in win2K


Sep 19, 2001
I have a thinkpad t-20 for work, and prior to yesterday, I had it hooked up to my LAN using a generic PCMCIA 10/100 ethernet card from Comp USA, on Win 2K. Yesterday desk side support took my machine to install a larger hard drive. Now my ethernet card won't work. They apparently did a fresh install of win2K, as the driver wasn't installed when I got the machine back. So I re-installed the driver, and now I get the error message "This device cannot start (code 10)". I checked the resources, and there are no conflicts. I pulled the card and tried it in another laptop, and it works fine. I have uninstalled the driver, re-installed it, checked the card services, etc. I can't find any reason why it won't work. Any tips, hints, or suggestions would be greatly appreciated.

EDIT 12/11/01:

Turns out to be a problem with service pack two. If you install sp2 before you install your network conections, it causes the problem I encountered. The fix was to uninstall SP2, re-install the card, and then install SP2 again. That has to be somekind of wierd bug, since it affects only certsain brands of ethernet cards according to the tech support guy.