Question Rosetta went crazy or off-line today ?

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#1
So my 48 thread Threadripper has been idle for I don't know how long. I tried reset project, update, everything, and it won't get any tasks. I noticed almost everybody is way low today on Rosetta. I got mad and added WCG to that computer, so now it was work. I was trying to spread out the CPU work between WCG and Rosetta, but how can I when the project is down....
 

plonk420

Senior member
Feb 6, 2004
315
4
81
#2
i have my top project at 9999 resource share and backup projects at 10. maybe that would help prevent a stoppage?
 

crashtech

Diamond Member
Jan 4, 2013
8,770
42
126
#3
I would like the resource allocation to work that that, but what usually happens is when the high resource share project asks for work, the client will report that the queue is full (of the less desired project). The only way I know around this is to do a bit of babysitting, which doesn't always work out if one is busy.
 

emoga

Junior Member
May 13, 2018
21
34
51
#4
I always use the 1 and 0 share%

Main project is set to 1 (or higher)

Backup is set to 0.

So the backup project will only ask for work when the main project is dry.
 

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#5
I always use the 1 and 0 share%

Main project is set to 1 (or higher)

Backup is set to 0.

So the backup project will only ask for work when the main project is dry.
Where is this share % option ? or priority ? I looked and can't find anything.
 

emoga

Junior Member
May 13, 2018
21
34
51
#6
Under the "Rosetta@home preferences" in the Account settings.

Resource Share
2019_01_28_11_04_30_Edit_Rosetta_home_preferences.png

For WCG. Settings-->Device Manager -->Device Profiles--> click Default (or whatever)-->scroll to bottom
2019_01_28_11_11_47_World_Community_Grid_Device_Manager.png
 
Last edited:

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#7
Under the "Rosetta@home preferences" in the Account settings.

Resource Share
View attachment 2856

For WCG. Settings-->Device Manager -->Device Profiles--> click Default (or whatever)-->scroll to bottom
View attachment 2857
Well, see thats a problem for me. I have 14 computers, and I don't want them all to have the same priorities. My method of manually assigning all of a box toa project works well, until the project is totally off-line, then that box and all like it are wasted. Those are web settings, right ? not BOINC ?
 

emoga

Junior Member
May 13, 2018
21
34
51
#8
Those are the website settings yes.

I might be misunderstanding exactly what you want but ...

If you want certain computers to crunch WCG and others to only crunch Rosetta (or any other project), then the same rules would apply, but you'd have to use custom profiles. (default, home,school,work)

You would just switch the share ratio of the profiles.

Computer A: Crunches WCG (1 Resource Share) and if the project is down, then Rosetta (0 Resource Share). Uses custom profile 'home'

Computer B: Crunches Rosetta (1 Resource Share) and if the project is down, then WCG (0 Resource Share). Uses custom profile 'school'

You have to create the profiles under 'Rosetta@home preferences'
You then assign the profiles under the 'Computers on this account'-->Details-->Update Location.
 

StefanR5R

Platinum Member
Dec 10, 2016
2,258
343
106
#9
I would like the resource allocation to work that that, but what usually happens is when the high resource share project asks for work, the client will report that the queue is full (of the less desired project). The only way I know around this is to do a bit of babysitting, which doesn't always work out if one is busy.
I always use the 1 and 0 share%

Main project is set to 1 (or higher)

Backup is set to 0.

So the backup project will only ask for work when the main project is dry.
To add to what @emoga said,
0 % resource share is special compared to any other percentage: The client fetches work for a project with 0 % resource share as if the queue was set to 0 days + 0 days. I.e. it only requests one task per currently idle CPU, but no additional tasks in advance for this project even if your queue setting is 10 days + 10 days.


--------
I tried reset project, update, everything, and it won't get any tasks. I noticed almost everybody is way low today on Rosetta.
According to @Kiska's site, Rosetta simply went out of ready-to-send (rts) work.

results_rosetta-week.png

IME, this happens at Rosetta from time to time. There is no need to reset the project locally.

Edit: Oh, I see, it didn't run out of RTS tasks completely; there are 8,090 tasks ready to send in this server_status snapshot. This means that repeated "update" may help with getting tasks.
 
Last edited:
Thread starter Similar threads Forum Replies Date
M Distributed Computing 6

Similar threads



ASK THE COMMUNITY

TRENDING THREADS