POST issue...


Senior member
Sep 21, 2001
OK, here's an interesting problem I'm hoping someone can help me with. Working on a PC w/ a Shuttle AN35N Ultra mobo, AthlonXP 2500 Mobile CPU. The problem is that the PC no longer boots, and appears to hang whenever the hard drive is recognized. Let me try and explain this better... Boot order is floppy (which I can successfully boot from), CDR drive (which I can successfully boot from) and HD0, a Seagate 9200.7 IDE drive.

The BIOS discovers the drive just fine, POST even shows the drive as Primary Master. But if the PC tries booting from it (it has a WinXP install) the machine hangs at VERIFYING DMI POOL DATA.... Complete lock up...can't three key it and reboot...have to press reset.

First, I think hmm...bad drive, which is what it sounds like so far, right? Nah...put in another drive, same issue. Take another drive, a 3rd HD, same issue. These drives work just fine in another machine. The 3rd drive I tried is actually working just fine in a USB enclosure as I type this.

Now I'm wondering if maybe it's a controller issue, even though I was able to boot to DOS with the floppy (which I used to upgrade to the latest BIOS to see if that would help) and the CDR drive. I remove the CDR and floppy, and put the HD on the secondary IDE channel. This HD has a bootable XP OS so it should wrong? Nope. Same problem. Got to the DMI POOL step and locked hard.

Another weird thing is that one of the 120GB drives was actually able to be formatted and start the installation from the XP setup CD. The problem started when XP got to the stage where it first needed to reboot during setup. Hard lock again when the PC tried to boot from the HD.

At a loss now, I figured I'd boot an OS using the CDR and see what happens. Pop an old version of Knoppix into the CDR, it boots, runs, everything works fine, but I can't access or mount any of the HDs, even the one that had the partial XP install. Although I get what appears to be HD activity (audible from the drive working and the HD light) whenever performing a task inside the OS.

I tried a boot floppy with a version of FDISK that can see drives over 64GB, and got the message that it could not access drive 1. So, I'm completely baffled.

Long story short: The computer sees all 3 HDs, correct brand name in the BIOS. The controllers seem fine because I've booted Knoppix from a CD drive on both primary and secondary. The HDs I've tested with work because they work just fine in other systems.

Any suggestions?