NTLDR is missing error, Windows 2000/Mandrake


Senior member
Aug 16, 2001
Hey guys,
I've got a problem. I'm trying to update my bios in my Gateway 6400, but when I pop in my disk with the bios on it I get the error... NTLDR is missing.. press any key to continue. I had windows 2000, but at one point had Mandrake 7.1 dual booting.. Installed win2000 first then mandrake... but eventually reformatted got rid of both, and re-installed Win2000.

But the problem was sometimes when I shutdown Win2000, it would bluescreen and restart, so i figured... maybe updating the bios would do it. But anyways... I did a google search, tried:

1. copying sys files from bootdisk <did not work>
2. tried xp and windows2000 recovery, and typing "fixmbr" <did not work>
3. tried copying ntldr from xp cds, and win2000 cd onto HD
4. already deleted partitions, reformatted, reinstalled win2000, xp, but the NTLDR error is still there when I try to update the bios. But the system does boot up fine (still blue screens in win2000 shutdown)

Any suggestions are much appreciated thanks! :)


Nov 12, 2001
You might want to try fdisk /mbr and then the above methods. This clears the mbr IIRC, and you'll need to rewrite it later. I know this function exists in win98 fdisk versions I am unsure if it exists anywhere else and it is undocumented. In fact I was just looking for a win98 boot disk to do the same thing on a linux box that grub decided to take a liking to, even though lilo *should* have been used. My fix was just to use grub instead, yours however I am unsure. Good luck!