NF7 v2.0 Help - Mobo Death?


Junior Member
Jun 18, 2005
Well, I think I just bit a hard bullet;

Seems my mobo will not respond to me anymore. Backstory:

Last night, me and some friends were playing the BF2 demo online together (through a LAN on a cable modem), and we played until about 2:30 or 3am at night. We stopped, and I made the mistake of leaving my computer on. Pretty sure this is the reason it died. I woke up at around 10:30 this morning, and I look at my screen. Black with a flashing light on the monitor. I thought this could be sleep mode, as it likes to do it, even though I set it not to.

Move the mouse. Nothing. Tap on the keyboard. Nothing. So, I decide to reboot. Then I realize, it's not beeping when I reboot. I try a hard reboot (turn off, unplug power, replug it, turn on). Nothing. Now I'm starting to swear.

I opened up my case, and looked around, all capacitors on my mobo and my video card (set up in in sig), seem to be fine and dandy. I blow out some dust, just for the sake of keeping it sort of clean.

Then I went through, took out all components, to see what would be the origin of my problems. Ram, videocard, IDE cables, everything removed but the CPU and power to mobo. No beeping, no boot screen. I try another power supply, hoping that it was just a bad 12V rail line, and that maybe I could just pick up a new one. I tried my friend's Antec TruPower 430V PSU, so a very good, reliable one. Just like before, all the fans turn on, the hard drives spin, the DVD drive spins, everything boots up as normal, except there's no boot screen, no beep, nothing from the mobo.

This is the point I notice that the mobo fan (typical for a nForce2 mobo like the NF2) isn't spinning. I flick it a couple times, then it starts to move finally. This worried me, as I thought it could prove to be power still. So I moved on and tried to flash the damn thing, hoping that it would reset everything. In my mind, it could be the overclock that I had put on the CPU (It's 11x210, or 2300mhz right now). There usually is a special process that the BIOs flash does. You use a jumper, and move it over one pin, press power. Then it should turn on and then shut itself off once again, showing it's completed a successful flash. Now my computer does none of that, it just turns on and stays on. I wait for a while, then turn my computer off again.

Now I'm stumped. I checked power, the seating of my CPU (according to my HSF, the thing shouldn't be able to move AT ALL), components that could possibly screw it up, videocard burn outs, smelled for any sort of burning smell such as silcon to see if I messed up my CPU, and all of this turned up nothing. My last possible idea is that my motherboard, while being left on overnight has I have done with so many other games (Far Cry, World of Warcraft, Everquest 1, Half Life 2, Doom 3), decided it did not like EA games and decided to kill itself, in a seppuku-style death of gutting the very backbone of the computer.

Any other ideas, suggestions, or hopeful rays of light would be nice; but if the mobo is dead, just tell me, so I can cry now, and buy a new one for my aging computer. Thank you in advance.


Diamond Member
Mar 28, 2005
I had that motherboard, the fan died so I RMAd it with Abit. You could try that before buying a new motherboard.