• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Milkyway@Home custom CPU configuration for GPU apps.

ao_ika_red

Golden Member
Aug 11, 2016
1,672
707
136
Last night I was doing Milkyway@Home benchmark and this afternoon finally got time to compare it with others. While doing it, I've found an interesting finding. Here's my partial stderr output.
Code:
<core_client_version>7.8.2</core_client_version>
<![CDATA[
<stderr_txt>
<search_application> milkyway_separation 1.46 Windows x86 double OpenCL </search_application>
Reading preferences ended prematurely
BOINC GPU type suggests using OpenCL vendor 'Advanced Micro Devices, Inc.'
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Switching to Parameter File 'astronomy_parameters.txt'
<number_WUs> 5 </number_WUs>
<number_params_per_WU> 20 </number_params_per_WU>
Using AVX path
CPU: AMD Athlon x4 845 (excavator uarch)

And for comparison, I use iwajabitw's partial stderr output (apologise for unauthorised access on your database).
Code:
<core_client_version>7.8.3</core_client_version>
<![CDATA[
<stderr_txt>
<search_application> milkyway_separation 1.46 Windows x86 double OpenCL </search_application>
Reading preferences ended prematurely
BOINC GPU type suggests using OpenCL vendor 'Advanced Micro Devices, Inc.'
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Switching to Parameter File 'astronomy_parameters.txt'
<number_WUs> 5 </number_WUs>
<number_params_per_WU> 20 </number_params_per_WU>
Using SSE4.1 path
CPU: AMD FX-6300 (piledriver uarch)

My question is, why did even though both client basically use same CPU arch (bulldozer derivative) but milkyway app decide to use different instruction set? Can it be manually selected?
 

[H]Coleslaw

Member
Apr 15, 2014
129
95
101
I am not the Milkyway expert, but it is my understanding that the BOINC server code is supposed to make a best guess at what application is the best fit for your CPU. Since the bulldozer line had crippled the AVX extensions, it is no wonder that the Server may think the SSE4.1 is the better choice on some of those chips. Was it consistent with the application choice at least? Or did it send a few different ones to each chip after these completed?
 

iwajabitw

Senior member
Aug 19, 2014
828
138
106
@ao_ika_red That systems been offline about a week. Just put it back online so you can investigate. Hope MW servers are acting right. I had 6300 tasks in limbo with no validation so I stopped. Jake had ordered parts for upgrades to the servers, have not checked the status but will when I get a chance.
 

ao_ika_red

Golden Member
Aug 11, 2016
1,672
707
136
Was it consistent with the application choice at least? Or did it send a few different ones to each chip after these completed?
A quick glance on my validated tasks tells me that it's consistently using AVX.
The last time I was using custom CPU app was during annual SETI-Wow! event last year on Athlon 860k. I still remember at that time I decided to use lunatic's AVX app because it's a few minutes slower when using SSE4.1 app.
 

ao_ika_red

Golden Member
Aug 11, 2016
1,672
707
136
@ao_ika_red That systems been offline about a week. Just put it back online so you can investigate. Hope MW servers are acting right. I had 6300 tasks in limbo with no validation so I stopped. Jake had ordered parts for upgrades to the servers, have not checked the status but will when I get a chance.
Yes, I notice that, but I don't think it matters much because it still had same points.
Thank you for helping me validating my theory. I hope it won't bother you much.
 

iwajabitw

Senior member
Aug 19, 2014
828
138
106
No problem. Looks like the ram upgrade went good and inconclusive tasks should be clearing out. He posted that they will be adding a second CPU to the server sometime this week.
 

[H]Coleslaw

Member
Apr 15, 2014
129
95
101
ao_ika_red, since each project compiles their own apps, the SETI work units may have better AVX but another project may have better SSE apps for your chip. So, I wouldn't use another project as a comparison. You could always try using an app_info.xml to force it to use the other application for experimenting. However, I don't have the details for making that right now. Might even want to ask in their forums.
 

ao_ika_red

Golden Member
Aug 11, 2016
1,672
707
136
No problem. Looks like the ram upgrade went good and inconclusive tasks should be clearing out. He posted that they will be adding a second CPU to the server sometime this week.
True. Most of my tasks were succesfully validated. He did a good job of maintaining those servers.

You could always try using an app_info.xml to force it to use the other application for experimenting.
That's actually my final goal, but I prefer to post on this forum. Just to keep the bar busy.
 

iwajabitw

Senior member
Aug 19, 2014
828
138
106
Looks like the bugs are still there. AMD gpu users reporting they can't get new tasks. I have one doing the same thing, resets and reboots haven't solved the issue. The other systems are receiving tasks just fine.
 

ao_ika_red

Golden Member
Aug 11, 2016
1,672
707
136
I can see that your "validation inconclusive" tasks are pretty massive. I assume this bug is affecting more to the the big guns rather than the smaller ones like me.
But, one thing still stands. Both your 8370 and 6300 are using SSE4.1 path.
I also did wander around TeAmmates' computers and all of them (Xeons, i5s, i7s, and Ryzens) are using SSE4.1. Now I'm wondering if I altered some configuration in the program data folder that I might not aware of.
 

iwajabitw

Senior member
Aug 19, 2014
828
138
106
I can see that your "validation inconclusive" tasks are pretty massive. I assume this bug is affecting more to the the big guns rather than the smaller ones like me.
But, one thing still stands. Both your 8370 and 6300 are using SSE4.1 path.
I also did wander around TeAmmates' computers and all of them (Xeons, i5s, i7s, and Ryzens) are using SSE4.1. Now I'm wondering if I altered some configuration in the program data folder that I might not aware of.
Could it be because I do not use the CPU application? I'm only running GPU tasks when I crunch Milkyway. And I see that the Inconclusive tasks are starting to back up again, there were only 38 this morning.
 
Last edited:

ao_ika_red

Golden Member
Aug 11, 2016
1,672
707
136
Could it be because I do not use the CPU application? I'm only running GPU tasks when I crunch Milkyway.
I didn't use MW@H CPU app. I ran the MW@H GPU app alongside CPDN CPU app. I also couldn't find any irregularities on ProgramData. I don't even have app_info.xml, just plain app_config.xml file to run 2 tasks per GPU.
 

iwajabitw

Senior member
Aug 19, 2014
828
138
106
I didn't use MW@H CPU app. I ran the MW@H GPU app alongside CPDN CPU app. I also couldn't find any irregularities on ProgramData. I don't even have app_info.xml, just plain app_config.xml file to run 2 tasks per GPU.
Only app_config here also. Dunno whats up.
 

ASK THE COMMUNITY