• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Installing an AMD card and drivers - Help me

psurg

Member
Oct 9, 2013
27
0
0
My 7950 just came in for my i5 4670k build. I had my old gtx 460 in there up until now.

I put the 7950 in and turned my computer on. Fans on the gpu were spinning, but the monitor didn't turn on.

Reinstalled Windows 7 to make sure the nvidia drivers were wiped, but no luck.

Tried taking the GPU out, then reinstalling amd's newest official drivers, but the installation failed.

On board graphics don't work while the GPU is in.

Tried using hdmi and dvi on the card.

Tried installing previous drivers for amd, which installed successfully, but didn't make the card work.

I don't know what to do now.
 

VulgarDisplay

Diamond Member
Apr 3, 2009
6,194
2
76
You may have gotten a bad card. It happens. Haven't you called the board manufacturer with your problem?
 

StinkyMojo

Golden Member
Nov 15, 2004
1,283
0
71
I was in a similar situation and I ended up fixing it by updating the bios of my motherboard. if you have the latest, check to see if there's a newer beta bios.
 

cmdrdredd

Lifer
Dec 12, 2001
26,810
269
126
What motherboard do you have and did you be sure to connect the external power to the card?

Actually list your entire specs for us if you would. It helps with diagnosing things like this.
 

ASK THE COMMUNITY