Help with LILO and diskeeper (unrelated, hehe)


Diamond Member
Mar 3, 2001
First of all, i used to have a mdk7.2/win2k dual boot system... i found myself NEVER booting to linux, and i recently acquired another computer, so i figured i would just delete the partitions with partition magic, and merge them with my main storage partition. however, when i boot, i still get the LILO screen. i assume i should do the fdisk /mbr, but when i open a command prompt in win2k and try to run fdisk, it says fdisk is not recognized as an internal command or something. should i use a win98 boot disk and do the fdisk /mbr or is there an easier way?

Second of all, i had diskeeper 5.03 trial version installed. the 30 day thing expired, so i decided to uninstall it. when i went into control panel, did the add/remove programs thing, and picked "remove" it said "Diskeeper must be installed on Windows Professional" (or something very similar) and i was like WTF!! so i tried to install the new 6.whatever version of diskeeper over the top of it, and it got halfway through the install and gave me the same message! so i said screw it and was going to just use the default defragger that comes with win2k, but since diskeeper wouldn't install, i deleted all the registry keys that pertained to it, along with it's install directory. it's still listed in my control panel, and gives same errors when trying to uninstall. running Computer Management from Administrator Tools gave me an error that "snap-in failed to initialize" and "Name: Disk Defragmenter" so after all that, my question is, how do i get my old defragger back and erase any instances of diskeeper ever being on my computer?


Platinum Member
Mar 16, 2000
"should i use a win98 boot disk and do the fdisk /mbr or is there an easier way?"

you cant run it from the command prompt within win2k. you have to actually be in DOS so yes boot with a win98 disk and fdisk /mbr.