HELP! Having trouble wirelessly connecting to Belkin Pre-n router

RockyM

Junior Member
Oct 14, 2004
16
0
0
Hi all - I took the plunge and picked up the Belkin Pre-n equipment. Installation was a snap, but I'm having trouble connecting wirelessly using the Pre-n notebook card. It says I have a signal, but can't get online. There is no WEP activated on my laptop. I turned off the XP firewall. I tried using both the " Let Windows configure my connection" and the Belkin utility. I see the network, but can't get online.
My laptop had the Intel wireless card when I bought it. A while back I removed that card and installed an Atheros mini-pci wireless card together with its drivers and utility. That connected to the Pre-n router just fine. So I went into the device manager and disabled the Atheros card so I could use the Pre0n card.. I'm running out of thoughts with this, but am thinking of a few ideas:

1) do I need to remove the original Intel wireless drivers?

2) do I need to remove the Atheros drivers?

3) should I clone the MAC address from the router?

4) should I do something with the IP address on my laptop?

Thanks for everyone's input.
 

amdskip

Lifer
Jan 6, 2001
22,530
13
81
Has this router been setup for the connection already? Have you tried just wiping all the settings and starting from scratch.