Question GSync settings for running on a FreeSync 60Hz panel?

SteveGrabowski

Diamond Member
Oct 20, 2014
4,665
3,218
136
Figured it was probably more appropriate to post this question here instead of in the Displays subforum since my problem seems to be with GSync and not the panel. I'm trying to setup GSync between my GTX 1660 Super and my Asus TUF Gaming VG289Q1A, which is a 4k 60Hz FreeSync panel, with the 1660S connected via DisplayPort. I had it working perfectly before but did a reinstall of Windows 10 after getting a new cpu and board and now don't have it right.

In Settings->Display->Advanced Display Settings my monitor always wants to run at 59.97Hz instead of 60Hz so I leave the refresh rate at 59.97Hz.

In Settings->Display->Graphics Settings I have Variable refresh rate set to On.

In Nvidia Control Panel->Manage 3D Settings I have
  • Max Frame Rate: 59
  • Monitor Technology: G-Sync Compatible
  • Vertical Sync: Off
This gets my games to not tear in fullscreen while they do tear if I turn max frame rate to 60 whether I have my monitor's refresh rate set to 59.97Hz or 60.00Hz. But then I get tearing if say I'm watching a 30/60 fps movie in VLC. Ugh what should I be doing that I'm not?

I have to put a Framerate limiter because otherwise GSync will just let the gpu run up to 144 fps output won't it? Since GSync panels are supposed to support 144 Hz?
 

Leeea

Golden Member
Apr 3, 2020
1,913
2,534
106
I have to put a Framerate limiter because otherwise GSync will just let the gpu run up to 144 fps output won't it? Since GSync panels are supposed to support 144 Hz?
my thoughts:
step 1: turn off the frame rate limiter
step 2: turn off variable refresh rate*

see what happens. If tearing persists, turn on Vertical-Sync in application.


*useless detail: Gsync mins out at 36 fps or so. Lower then that, it starts spawning duplicate frames. A desirable behavior on a 120 Hz panel, but on a 60 Hz panel that is just going to hurt you.
 
  • Like
Reactions: SteveGrabowski

SteveGrabowski

Diamond Member
Oct 20, 2014
4,665
3,218
136
These settings seem unlikely to effect VLC.

Perhaps try this?:
https://www.reddit.com/r/VLC/comments/hxtehu
Turns out it was just VLC. I should have tried Media Player Classic and Windows Movies & TVs before posting that, and after trying them with the same movie file they ran fine on them.

Does that seem correct though to always have GSync put a frame limit of 59 on for a 60 Hz panel? My FreeSync range on the panel is 40-60Hz so yeah it looks bad on games if I go below 40 fps.
 
  • Like
Reactions: Leeea

Leeea

Golden Member
Apr 3, 2020
1,913
2,534
106
Turns out it was just VLC. I should have tried Media Player Classic and Windows Movies & TVs before posting that, and after trying them with the same movie file they ran fine on them.

Does that seem correct though to always have GSync put a frame limit of 59 on for a 60 Hz panel? My FreeSync range on the panel is 40-60Hz so yeah it looks bad on games if I go below 40 fps.
For apps/games that you are using gsync with, you should turn the frame limiter off for best results.

If you decide to turn both gsync and vsync off, maybe set your frame limiter to 240.
 
Last edited:

ASK THE COMMUNITY