• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Gothic 3 issues under Vista64

Bateluer

Lifer
Jun 23, 2001
27,730
7
0
While under XP32, Gothic3 ran very well, with only occasional slowdowns. Despite the game's bugs and system hogging, my system was far from weak and able to handle it without problems.

After I installed Vista64, G3 began running like a slideshow, using any detail settings. I even tried the game at 10x7 with low details, and performance was the same. Atrocious.

When I check the mem usage in task manager, the mem usage was around 800MB, but I didn't play very far with the game performing like crap. Under XP, I've seen it go as high as 1.4GB. Total RAM usage for Vista was around 1.5 to 1.6GB with G3 running.

I know others have ran the game successfully under Vista, so any words of wisdom to get performance back up?


C2D E6600@stock
2GB RAM(have another 2GB on the way)
2900XT w/ Cat 7.9


Incidentally, I had the same problem under NWN2 earlier today, however, performance became oustanding once again once I turned down the shadow detail. Seems like shadows always cause performance degradation. Didn't help G3 though.
 

Mem

Lifer
Apr 23, 2000
21,476
13
81
I have not personally tried G3 in Vista x64 yet,however you tried running in XP compatibility mode and also run as admin in properties of the exe. file of the game,also disable Windows Defender real time scan,really no need to have that on all the time(set to scan once a week is personally fine for me).

Don't expect it to be fast since G3 has always been demanding due to poor programming /coding.

 

AzN

Banned
Nov 26, 2001
4,112
0
0
CAT 7.9 has a problem with this game. Revert back to 7.7
 

Bateluer

Lifer
Jun 23, 2001
27,730
7
0
Originally posted by: Mem
I have not personally tried G3 in Vista x64 yet,however you tried running in XP compatibility mode and also run as admin in properties of the exe. file of the game,also disable Windows Defender real time scan,really no need to have that on all the time(set to scan once a week is personally fine for me).

Don't expect it to be fast since G3 has always been demanding due to poor programming /coding.
Haven't tried those yet. I've been working off this thread at the Jowood forums, but so far it has not been much help.

http://forum.jowood.com/showthread.php?t=145243

Azn - Is there documented evidence of the 7.9 Cats having problems with G3? I dislike reverting to old drivers. The 7.10s will be out in another week or so regardless.

Edit - Running in compatibility mode has no effect.
 

AdamK47

Lifer
Oct 9, 1999
13,588
967
126
Originally posted by: Bateluer
Originally posted by: AdamK47
Try this:

http://forum.jowood.com/showth...?p=2033475#post2033475

It worked for me.
Hmm, trying a new Font . . . don't see how that will help the game very much, but I'll give it a shot.

I sincerely hope the new Gothic devs at Spellbound release some updates to this game soon. It really needs it.

Edit - Wow, that actually worked. Thanks.
No problem. When I first heard about the fix I didn't believe it either.
 

Bateluer

Lifer
Jun 23, 2001
27,730
7
0
I still get massive system instability though, usually crashes every 10 minutes or so.

 

AdamK47

Lifer
Oct 9, 1999
13,588
967
126
Originally posted by: Bateluer
I still get massive system instability though, usually crashes every 10 minutes or so.
Well that I don't know. Mine seems stable enough. As stable as Gothic 3 can be anyways.
 

Bateluer

Lifer
Jun 23, 2001
27,730
7
0
Originally posted by: AdamK47
Originally posted by: Bateluer
I still get massive system instability though, usually crashes every 10 minutes or so.
Well that I don't know. Mine seems stable enough. As stable as Gothic 3 can be anyways.
Are you running the latest community patch, 1.4? Do any memory hacks?

Edit - The game merely goes black on me, though the sound/music still plays, until I hit the Ctrl-Alt-Del and kill it. As I'm attempting to kill it, there is an error box that gives a random error every time. Sometimes its a memory error, sometimes its just a generic 'Offending application will be shut down.'
 

Bateluer

Lifer
Jun 23, 2001
27,730
7
0
I think I got it. When my extra 2GB of RAM arrived today, I applied the memory hack/fix to the G3 exe. Seems to be semi-stable now. Played for almost 30min without the game dying on me.

Edit - New problem: The game blue screens on me every time I try to reload after dying. However, if I exit the game and restart G3, then reload the game, it works.

Needless to say, this is going to get really tedious really fast, especially as I fight my way through Vengard to the king. :(

Edit 2 - The damn shaman throwing fireballs that kill in almost 1 hit are brutal with this situation.
 
Thread starter Similar threads Forum Replies Date
A PC Games 2
Whitestar127 PC Games 4

ASK THE COMMUNITY

TRENDING THREADS