Getting a '0x80070057' Failed to format Windows error when I try to clean format!


Senior member
Sep 6, 2005
Hi guys ...

I have a Windows 7 system which has a 250 GB Western Digital SATA drive ... I haven't used this system in like 4-5 months .. I recently wanted to format the system, so I used my Windows 7 Ultimate x64 Installation CD to try a clean install ... I removed the previous partitions and let the Installer create new partitions. However when I choose to format the newly created partition (so that I can install Windows on it in the next step), I get a '0x80070057' Windows 7 error which tells me that it cannot format the drive.

I also tried using 'diskpart' utility to first do 'clean all', and then try formatting using 'diskpart'. Again I get the same error.

To test is the drive is faulty or not, I ran Seagate's Seatools v2.23 DOS tool (excellent tool for Hard Drive testing!) to test the drive. I did both Short and Long tests, and both tests passed without reporting any drive problems.

I also found a Windows guide on this error, but what it suggests is what I'm doing in the first place anyway, so it doesn't really help. Here's the guide anyway:

So what's the issue here then ?


Apr 1, 2014
You can try changing your RAM sticks or diagnose it with Memtest86. I have encountered several issues like this before when installing Windows OS in a PC. You can try installing Linux also and find out if it gives you the same error.


Diamond Member
Jun 15, 2000
If you have external USB drive attached to the system try again with it unplugged.