[FTP] Failed to establish data socket Error?

beyonddc

Senior member
May 17, 2001
911
0
71
#1
Currently I setup a FTP server at home behind a Linksys router. I enabled port forwarding 20-21 to my server system. I asked 12 friends to logon to my server, and 10 of them got it inside. At the beginning, I thought it was their problem, because they might behind a firewall. Today is my first time trying to login to FTP server from work. I am using CuteFTP 4.2 and below is my LOG. I can't login to my home server. However, I can connect to other people server. That's why I am confused. I tried SmartFTP, EFTP and CuteFTP to get onto my home server at work, but all of them failed on me. Weird thing happened, when I use America Online 7.0 and use their FTP feature, I can login! I am hoping if anyone got any idea on what's going on. Thanks for reading my post! :)

by the way, my passive mode in CuteFTP is enabled and I am using AT&T Cable Broadband at home.


STATUS:> Socket connected. Waiting for welcome message...
220-GuildFTPd FTP Server (c) 1997-2002
220-Version 0.998.2
220 Please enter your name:
STATUS:> Connected. Authenticating...
COMMAND:> USER beyonddc
331 User name okay, Need password.
COMMAND:> PASS ********
230 User logged in.
STATUS:> Login successful
COMMAND:> TYPE I
200 Type set to I.
COMMAND:> REST 100
350 Restarting at byte offset 100. Send RETR to initiate transfer.
STATUS:> This site can resume broken downloads
COMMAND:> REST 0
350 Restarting at byte offset 0. Send RETR to initiate transfer.
COMMAND:> pwd
257 "/" is current directory.
COMMAND:> TYPE A
200 Type set to A.
STATUS:> Retrieving directory listing...
COMMAND:> PASV
227 Entering Passive Mode (66,30,129,180,4,112)
COMMAND:> LIST
STATUS:> Connecting data socket...
150 Opening ASCII mode data connection for /bin/ls (505 bytes).
ERROR:> Failed to establish data socket
STATUS:> Trashed response received
425 Can't build data connection.
:(
 

Nothinman

Elite Member
Sep 14, 2001
30,672
0
0
#2
Try PORT instead of PASV mode.
 

beyonddc

Senior member
May 17, 2001
911
0
71
#3


<< Try PORT instead of PASV mode. >>



Tried already. I disabled PASV mode and set port to 21. It is not working.
 

ASK THE COMMUNITY

TRENDING THREADS