Firefox (v96) on Linux - anyone finding it going squirrelly lately?

mikeymikec

Lifer
May 19, 2011
15,226
5,369
136
I think it started yesterday - I was browsing a few sites and when loading new pages in various tabs suddenly they stopped loading pages for any site at all. GeckoMain sat there saturating a CPU core, closing Firefox resulted in GeckoMain continuing to sit there and saturating a core. Terminating GeckoMain would allow me to restart Firefox but with the same problem straight away. The problem survived a reboot as well. Another Firefox profile didn't immediately have the problem, leading me to think it was profile-specific, so I 'refreshed' Firefox, reinstated UBO and everything was OK for a while, then the problem started again but went after closing Firefox and killing GeckoMain I think.

It's happened once today and went away after closing FF + killing GeckoMain.

I'm using Kubuntu 20.04 LTS.
 

Fallen Kell

Diamond Member
Oct 9, 1999
5,758
285
126
Yep, I see all kinds of issues with the last few Firefox versions (pretty much been having problems since v90 and up). Getting close to the point in time that I ditch it for something else.
 
  • Like
Reactions: VirtualLarry

lxskllr

No Lifer
Nov 30, 2004
55,506
5,509
126
I had to disable hardware acceleration on debian kde, or it would fuxxor xorg, and I'd have to restart the machine. This is version 91.x. There may have been other ways to gracefully recover, but I didn't spend much time with it. I also haven't retried hardware acceleration over the last couple point releases. Maybe it's better?
 

ASK THE COMMUNITY