Efficient Networks 5260: How to Restore Firmware Defaults?!

GoodRevrnd

Diamond Member
Dec 27, 2001
6,803
581
126
How do I restore the firmware defaults on an Efficient Networks Speedstream 5260 modem/router? I couldn't find any info on their website and the router only has a power button, a RJ-9 and RJ-11 -- no pinholes or anything! I tried press and holding the power button but I don't think it worked. The modem is using the 5660 hacked firmware (and has been working fine for 4 months, mind you). One day it just up and died. All indicator lights are solid green for go, but I can't browse the net and I can't login to or ping the router (on any of the logical default ip's or the one I assigned to it.)
 

Special K

Diamond Member
Jun 18, 2000
7,098
0
76
I also have one of these "converted" routers. You may have some luck with this, although I have never tried it (I don't have any experience working with breadboards and other eletronics). From what I read, it will allow a "small memory" 5260/5660 to upgrade its firmware more than once (most of these hybrid models don't have as much memory as a real 5660 and won't allow more than one firmware upgrade, unless you make the above modification). If you could do that, then you could try to access the router via serial cable and hyper terminal, and then reflash its firmware from there.
 

GoodRevrnd

Diamond Member
Dec 27, 2001
6,803
581
126
Well, I guess I have the large memory model because I upgraded more than once. Anyway, I don't need to run a firmware update -- I need to have the router restored to the defaults specd in the firmware. How do I do this?



Alternatively, can anyone suggest any good, cheap dsl modem/router combos?