Double NAT question

Discussion in 'Networking' started by Peklucher, Apr 21, 2017.

Tags:
  1. Peklucher

    Peklucher Junior Member

    Joined:
    Apr 21, 2017
    Messages:
    1
    Likes Received:
    0
    I have at&t dsl at home. It uses at&t supplied wifi router/modem gateway. I have turned off wifi function and am running an asus wifi router from it. The dsl gateway has only 2 ethernet ports whereas my asus has about 5, which I have devices connected to it by wifi and hardwired ethernet. Both are doing routing so I am running a double NAT. I need to open some ports to run my plex media server to the outside. Which I cant seem to do running double NAT. AT&T does not allow you to turn off routing in its gateway, only the wifi function. If I turn off the routing function (bridge mode) on the asus and allow the at&t gateway to do the routing, open the port I need on said at&t gateway, will the devices I have connected by hardwire ethernet and wifi to the asus still be able to connect to the internet? Should this fix my problem with forwarding the port I need, since cant seem to get it to work through double NAT? Thx for any assistance.
     
  2. Loading...


  3. Genx87

    Genx87 Lifer

    Joined:
    Apr 8, 2002
    Messages:
    39,858
    Likes Received:
    81
    Plug the AT&T LAN port into a LAN port on the ASUS router. Turn the ASUS router into an access point. Double NAT is a bad idea.
     
  4. Ichinisan

    Ichinisan Lifer

    Joined:
    Oct 9, 2002
    Messages:
    24,430
    Likes Received:
    209
    This isn't necessary because Asus routers already have a bridged AP mode.

    OP's suggestion is sound. In that setup, he should only need to open ports on the AT&T device.
     
  5. razel

    razel Golden Member

    Joined:
    May 14, 2002
    Messages:
    1,877
    Likes Received:
    8
    Both suggestions above are sound. I prefer to set the AT&T box to bridge mode, but it's not always possible, so you maybe left to set your ASUS as an AP. I used to have a AT&T DSL modem that was a shaky bridge. Basically if it's turned off or rebooted, you may have to reapply some settings you set for bridge.