Do I need a static IP address to use VPN? *UPDATED* Please help.

Discussion in 'Networking' started by ddeder, Jun 28, 2003.

  1. ddeder

    ddeder Golden Member

    Joined:
    Jul 5, 2001
    Messages:
    1,018
    Likes Received:
    0
    I have a network of three computers at my office which has cable internet. I did not get a static IP address from the cable company. I would like to be able to access this network from home or on the road through the internet (that is what VPN allows me to do - right?). How hard is it to set this up? Do I need a static IP address at the office?
     
  2. Loading...

    Similar Threads - static address *UPDATED* Forum Date
    static address for pc Networking Jul 4, 2015
    How does a static IP address work? Networking Jan 22, 2015
    Setting up IP addresses for static IP Networking Jun 8, 2014
    Static Ipv6 Address for server 2008 r2 Networking Jun 23, 2010
    Fios and static ip address config Networking Aug 31, 2009

  3. wirelessenabled

    wirelessenabled Platinum Member

    Joined:
    Feb 5, 2001
    Messages:
    2,107
    Likes Received:
    13
    Cable IPs are "almost" static. My IP while not assigned or guaranteed not to change has been the same for months.

    You can also use a dynamic DNS service although that probably violates your cable TOS.

    Years ago we used to have our VPN server e-mail its IP address to a free webmail inbox. Then when we wanted to VPN in we could grab that e-mail and set up the VPN client accordingly.
     
  4. ddeder

    ddeder Golden Member

    Joined:
    Jul 5, 2001
    Messages:
    1,018
    Likes Received:
    0
    Thanks for the reply. I am trying to set up my VPN connection and am having some problems. On the Windows 2000 machine at home, I run the wizard to set up a VPN connection. It asks for the IP address of the server. Well the IP address of the server at the office is 192.168.0.2 which is an internal IP address that cannot be seen outside of the LAN (as I understand it). So I assume that there is an IP address associated with the broadband connection to the internet. I go to Google and do a search on "IP Address". The first page that I pull up runs a little utility that displays my IP addess - 68.112.135.14. Every computer in the LAN displays this same IP address when accessing this webpage. (the webpage is here.) So I type in this IP address in the wizard and finish the wizard. I then setup my dial-up accress through my local phone company and dial into the internet. The internet connection is made so I try to access the VPN. I am prompted for a user Id and password so I type in the administrator user id and password and hit OK. Another window then pops up saying: Connecting to 68.112.135.14... After a short time, the following error is displayed below this:

    Error 678: There was no answer

    I am able to ping 68.112.135.14 from the dial-up connection.

    I am using a router at the office. There is a disclaimer on the webpage mentioned above that the IP address will not be correct if you are using a router/proxy. If this is the case, how can I find my true IP address?

    Any help is appreciated.
     
  5. JW310

    JW310 Golden Member

    Joined:
    Oct 30, 1999
    Messages:
    1,582
    Likes Received:
    0

    68.112.135.14 is the true IP address of the internet connection going to the router (so it is the one you want to connect to). Sounds like the reason the VPN is not working is because the router is blocking the incoming VPN connection request. Since I'm not that familiar with how VPN works, that's about the most I can help.

    JW
     
  6. Hossenfeffer

    Hossenfeffer Diamond Member

    Joined:
    Jul 16, 2000
    Messages:
    7,462
    Likes Received:
    1
    I'm guessing you would need to forward the necessary ports (in the router config) to the machine you wanted to access. That, or set up the office machine as a DMZ (making it very visible). Granted, there goes your security, but it's an "option".

    I'm not sure what ports are required for VPN and whether you need "built-in" vpn support in the router.

    Translation: Didn't help ya much. D'oh, sorry.
     
  7. triatma

    triatma Junior Member

    Joined:
    Jul 6, 2003
    Messages:
    1
    Likes Received:
    0
    what is the server software configuration that is dishing out the vpn connection ?

    there is no problem running a vpn server over a dynamic ip .... you have to change the vpn connection ip each time your cable/dsl provider changes your ip. a router with vpn passthrough would be recommendable though.
     
  8. ddeder

    ddeder Golden Member

    Joined:
    Jul 5, 2001
    Messages:
    1,018
    Likes Received:
    0
    Thanks for the replies. I now have the VPN connection working. I had to enable Virtual Server Mapping for my router and configure the VPN server settings.

    So now I can dial into the internet from my PC at home and double-click my VPN connection to establish the connection with my server at the office. Once connected, I can start Terminal Services and it all works great.

    Now for my next problem...

    I have a computer at another office that I would like to establish the same type of connection for. This computer however has a DSL connection to the internet, not dial-up like my computer at home. I'm thinking that this ought to be easier to configure for VPN because the computer is already on the internet - no need to dial in. So I set up my VPN connection and double-click it to connect to my server at the other office. It displays the "Verifying username and password" window for about 30 seconds and then displays "Disconnected error 721: The remote computer did not respond. For further assistance...". It then says it will attempt to redial in 60 seconds, which is interesting since there is no dialup connection involved here.

    So the gist of this is, I can get the VPN connection to work when using dial-up internet access but not when using broadband. Is there a setting somewhere on the server that needs to be tweaked to allow VPN via broadband?

    Any help is appreciated.