DELL computer: can't upgrade OS! Missing file...


Nov 12, 2004
I have a DELL Dimension 9100 at home as a workstation computer; originally, it came with a copy of Windows XP Home installed, as well as plenty of random software. Now, I've tried to upgrade the OS to XP Pro w/ SP2 using the MSDN 11/2005 DVD (Disc 2428.8), but when it starts copying the installation files, at about 51 minutes to completion (~99% for copying the installation files), it prompts that a system file is missing (Retry/Ignore/Cancel). I attempted to "Retry" but the same message appeared again; thus I tried Ignore. The system restarted as normal, but would the setup failed. The second time I re-attempted the upgrade from the XP environment; this time a different file was missing: 'arov1edb.sys'. I decided to try to upgrade not to XP Pro this time, but to XP Home (I cannot simply Repair, because that would require finding a disk drive or modding the installation CD).. this also did not work, and there was a missing file detected again.

I located another MSDN DVD -- Disc 2429.5 from 1/2007, but the same thing happened again, though this time a different file was missing: 'adt1bbs1.sys'. I searched online for each of these files, but could find absolutely nothing. I suspected from the beginning that something was wrong: that these files were actually non-existent, since they are quite meaningless in terms of their nomenclature.

Now this is a fresh "recovery" (using CTRL + F11 at startup to bring up the DELL Recovery Menu; I believe this is a DELL-branded version of Norton Ghost, since it was made by Symantec). In any case, this means the setup was as good as new.

Please let me know what is going on. Can DELLs not be upgraded to other OS's without completely wiping out the HDD?