• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Dead Space 2 hitching while walking

toyota

Lifer
Apr 15, 2001
12,957
1
0
I fired up Dead Space 2 for the first time since getting my gtx670 and noticed some hitching when just walking around. I had vsync forced on from the control panel and thought that might be causing it since the 600 series are having issues staying at 60 fps with vsync. before going to the control panel though I noticed when it hitched it was not always dropping below 60fps. anyway I turned vsync off and started the game up again and it was still there.

to be clear all I have to do is walk around and Isaac will hitch every 2 to 3 seconds at what seems like perfectly spaced intervals. its like something is polling so I turned off Precision completely and restarted the game and it is still there. it might not be very noticeable to some people at first and does not seem to hitch when running but as soon as you see it happen while walking its obvious that something is not right.

I tried Dead Space 1 and it is perfectly fine so it seems to just be Dead Space 2 that is affected. I know it has never done this before because I have played through this game numerous times on my gtx570 as well as some other lower end systems. I guess it is either the gtx670 or 301.42 driver that is the culprit here.
 
Last edited:

The_Golden_Man

Senior member
Apr 7, 2012
816
0
0
I fired up Dead Space 2 for the first time since getting my gtx670 and noticed some hitching when just walking around. I had vsync forced on from the control panel and thought that might be causing it since the 600 series are having issues staying at 60 fps with vsync. before going to the control panel though I noticed when it hitched it was not always dropping below 60fps. anyway I turned vsync off and started the game up again and it was still there.

to be clear all I have to do is walk around and Isaac will hitch every 2 to 3 seconds at what seems like perfectly spaced intervals. its like something is polling so I turned off Precision completely and restarted the game and it is still there. it might not be very noticeable to some people at first and does not seem to hitch when running but as soon as you see it happen while walking its obvious that something is not right.

I tried Dead Space 1 and it is perfectly fine so it seems to just be Dead Space 2 that is affected. I know it has never done this before because I have played through this game numerous times on my gtx570 as well as some other lower end systems. I guess it is either the gtx670 or 301.42 driver that is the culprit here.
Try using precision to lock FPS at different values. Try with both V-sync on and off and try to cap the fps at different values.

Also, you could experiment with adaptive V-sync.

You could also try the Beta 302.59 driver to see if there are any difference.
 

blackened23

Diamond Member
Jul 26, 2011
8,548
1
0
I'd suggest not using the 302 beta drivers. I get the hitching issue too but mine goes away if I disable vsync - but I don't get it in dead space 2, I get it in some other games. It really is an annoying as hell problem.

Anyway - 302 helps BUT it causes some of my games to flat out crash. I can't even play assassins creed brotherhood with it, I get a TDR on launch. Reverting back to 301.42 fixes it to be playable again.

Also: report the issue here : http://forums.nvidia.com/index.php?showforum=256
 
Last edited:

borisvodofsky

Diamond Member
Feb 12, 2010
3,606
0
0
I believe this is due to "flip queue depth", aka, # of frames rendered ahead.

Check the menu and make the # of frames to 0, this may result in a slight drop in total performance, but may help with this "hitch"
 

blackened23

Diamond Member
Jul 26, 2011
8,548
1
0
I believe this is due to "flip queue depth", aka, # of frames rendered ahead.

Check the menu and make the # of frames to 0, this may result in a slight drop in total performance, but may help with this "hitch"
More like...nvidia just needs to fix their drivers. Pretty stupid since they're so highly coveted on this front apparently. Problem was identified late april.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
I believe this is due to "flip queue depth", aka, # of frames rendered ahead.

Check the menu and make the # of frames to 0, this may result in a slight drop in total performance, but may help with this "hitch"
I remember that was an issue in Bioshock a couple of years ago. the control panel has changed since then though and there is no "0" option now. I tried 1 and then I tried 4 and it made no difference.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
Try using precision to lock FPS at different values. Try with both V-sync on and off and try to cap the fps at different values.

Also, you could experiment with adaptive V-sync.

You could also try the Beta 302.59 driver to see if there are any difference.
I had already tried different framerates and vsync options and I prefer not to use those developer drivers.
 

Rvenger

Elite Member <br> Super Moderator <br> Video Cards
Super Moderator
Apr 6, 2004
6,282
5
76
Ill test mine as well for you. I have Dead space 2.


Using 301.42
 
Last edited:

The_Golden_Man

Senior member
Apr 7, 2012
816
0
0
I had already tried different framerates and vsync options and I prefer not to use those developer drivers.
Try setting the Powermanagement mode to maximum performance instead of Adaptive in the Nvidia control panel. Just a thought...
 

Rvenger

Elite Member <br> Super Moderator <br> Video Cards
Super Moderator
Apr 6, 2004
6,282
5
76
I have no hitching what so ever. Its perfectly smooth when vsync is enabled too.


Do you have C1E enabled on your MSI board?

My performance would tank when I had C1E enabled on my P67A-G43. It would start skipping randomly at times during games.
 
Last edited:

Hauk

Platinum Member
Nov 22, 2001
2,808
0
0
I'd say texture loading from HD but you say you've played without issue on a 570 before.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
I have no hitching what so ever. Its perfectly smooth when vsync is enabled too.


Do you have C1E enabled on your MSI board?

My performance would tank when I had C1E enabled on my P67A-G43. It would start skipping randomly at times during games.
thanks for checking but I don't think most people would even notice it. I don't recall ever having an issue with a game that could not be replicated on another pc with similar hardware.

again this did not do it last week with my gtx570 so I know it has to be a driver or gtx670 issue.

I'd say texture loading from HD but you say you've played without issue on a 570 before.
it is certainly not that. its exactly like some app is polling because it happens at about 2 second intervals when walking. Ican see Isaac make this little consistent twitch and its very annoying once I notice it.
 
Last edited:

toyota

Lifer
Apr 15, 2001
12,957
1
0
I tried uninstalling the game from Origin so I could install it from disc. well that was a waste because once I install it on the pc, Origin picks it and puts all my settings and saves right back even without Origin running.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
okay I have tried completely uninstalling Precision, re installing game, going to all low settings, 301.25 drivers, various pre rendered frame settings, disabling all cp settings, using max power, using controller instead of mouse, and unplugging controller but no dice.

I have done everything but use 302.71 drivers which I do not really want to do. I am really pissed off right now because this is not normal and I want to fix it. again last week this was not an issue on my gtx570 and 301.24 drivers.
 

Rvenger

Elite Member <br> Super Moderator <br> Video Cards
Super Moderator
Apr 6, 2004
6,282
5
76
Reinstall windows on another HDD and run nothing but Steam and deadspace 2 and see what happens.
 

tviceman

Diamond Member
Mar 25, 2008
6,733
514
126
www.facebook.com
Toyota, I had hitching on a game or two (can't remember which ones) on of my old systems that I couldn't figure out for the life of me what was causing it. I felt like I tried everything to to fix it before I finally started getting creative and pinpointed the problem - it was a driver for my mouse. After killing the process via the task manager, the hitching was completely gone.

You may or may not have mouse drivers loaded, but I'd start looking at tasks that are loaded in the windows task manager, and kill off all the tasks that aren't essential to windows. Then try the game again, and if it works fine, you will at least then know it was one of the tasks you stopped and you can run further tests from there to pinpoint the exact task causing the problem. Hope this helps!
 

The_Golden_Man

Senior member
Apr 7, 2012
816
0
0
Look here. Dead Space 2 is listed as one of those games confirmed to have stuttering on Nvidia 6xx cards.

So this issue is not only affecting toyota's system.

Quote:

"I've moved to the 300.83 driver that came with the card, gave it a good hammering last night and the stutter I had in Alan Wake AN has gone.

Most users in the Nvidia thread report using this driver removes the
stutter also so that virtually guarantees this issue can be fixed with a new driver update." Link to post
 
Last edited:

toyota

Lifer
Apr 15, 2001
12,957
1
0
well its not the 670 that is the culprit. I installed my 8600gt in the other slot and tested the game and does it on it too. it has to be the drivers but I could not install the older drivers I was using on my gtx570 because they dont support the gtx670. to be clear I had both the 8600gt and gtx670 in my pc and could not use an older driver just for the 8600gt because then the pc would freak out because the gtx670 was unsupported. I was too lazy to go to all the trouble of removing the gtx670 and putting the 8600gt in the main slot. I might try a different pc to day.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
Toyota, I had hitching on a game or two (can't remember which ones) on of my old systems that I couldn't figure out for the life of me what was causing it. I felt like I tried everything to to fix it before I finally started getting creative and pinpointed the problem - it was a driver for my mouse. After killing the process via the task manager, the hitching was completely gone.

You may or may not have mouse drivers loaded, but I'd start looking at tasks that are loaded in the windows task manager, and kill off all the tasks that aren't essential to windows. Then try the game again, and if it works fine, you will at least then know it was one of the tasks you stopped and you can run further tests from there to pinpoint the exact task causing the problem. Hope this helps!
thanks but I dont think that is it. all I have is the basic windows driver and none of the Logitech stuff installed.
 

tviceman

Diamond Member
Mar 25, 2008
6,733
514
126
www.facebook.com
On a side question, what speeds are you running your gtx670 at? Have you OC'd the vram at all to see what sustainable speeds it could hit? I'm going to give MSI until the end of next week to get their gtx670 power edition out before giving up on them and getting the evga gtx 670 ftw.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
On a side question, what speeds are you running your gtx670 at? Have you OC'd the vram at all to see what sustainable speeds it could hit? I'm going to give MSI until the end of next week to get their gtx670 power edition out before giving up on them and getting the evga gtx 670 ftw.
1283/7000 was stable in Alien vs Predator bench and 3DMark. 7200 actually scaled too in Alien vs Predator bench but anything higher probably would have leveled off. I accidently put the slider too far and went to 7600 and it freaked out and slowed way way down. I had to reboot the pc to get it the error correction to reset.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
toyota,

did you try the 300.83 driver suggested from my post?
that driver does not support 670.

I have no issues with this type of hitching in any other game I have tested. btw its not just vsync that is an issue with these cards. they cannot stay at ANY framerate that you limit it to whether that's using vsync, framerate target or a framerate limiter. no matter what it will drop 1 fps below that every few seconds in every game for no reason at all. heck you can just stand still and it will do it. if the next driver does not fix all this crap then my card is going back.
 
Last edited:

ASK THE COMMUNITY