• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

CS:GO FPS randomly drops

pontifex

Lifer
Dec 5, 2000
43,806
44
91
Been playing CS:GO, mostly by myself with offline bots, but my friend got it on the sale too so we started playing together (against bots, just the 2 of us).

I don't remember this issue before my friend started to join me in game.

sometimes it's find and then other times it drop so bad you can barely aim or move right.

Anyone else have this issue or know whats going on?

now that i think about it, i had similar issues when we played NFS: hot pursuit the other day as well. Is it my friend thats somehow causing this? He has a slow internet connection than me but our PCs are pretty close to the same spec.
I don't recall it happening in NFS before, but it had been awhile since we played it (or any games really).
 
Last edited:

chalmers

Platinum Member
Mar 14, 2008
2,565
0
76
Just play cs_office on T on maps with player collisions=on and stand in the doorway of the main exit from the T spawn and block your entire team in until you get bored of it.
 

pontifex

Lifer
Dec 5, 2000
43,806
44
91
Did you have any problems while playing online with bots?
yep, even just by myself with bots online, it starts out at like 100+ fps and then drops for like 8-10 fps for a minute then goes back to 100+ for a minute, then back to 8-10. found several hits online where people have the same issue. didn't see a solution though.
 

Tweak155

Lifer
Sep 23, 2003
11,403
239
106
Only time I've had a problem was playing by myself... something happened and the game slowed down until I restarted it.

Other than that, I notice if I have 18 bots or so in game, the game slows down a little (not even something I concern myself with). And as the bots die it speeds back up. This all depends on the map.
 

darkewaffle

Diamond Member
Oct 7, 2005
8,152
1
81
I've had sudden FPS stutters/freezes in a number of Source engine games before. It's pretty rare but I've experienced it in HL2 (+ episodes), TF2 and CSS at least. Though I feel like I haven't had it in quite some time, maybe some driver or engine update eventually resolved it for me.
 

z1ggy

Diamond Member
May 17, 2008
9,945
56
91
Do you need to update Steam/drivers or something??? I've never had this issue before with any CS game.
 

pontifex

Lifer
Dec 5, 2000
43,806
44
91
Its weird that it happens when its only an online game, never happens in an offline game.

video driver is up to date
steam is up to date
 
Last edited:

z1ggy

Diamond Member
May 17, 2008
9,945
56
91
Its weird that it happens when its only an online game, never happens in an offline game.

video driver is up to date
steam is up to date
Modem problems? ISP problems? Router (if applicable) problems?
 
Feb 6, 2007
16,432
1
81
Its weird that it happens when its only an online game, never happens in an offline game.

video driver is up to date
steam is up to date
It's because in an offline game your computer is only responsible for the bot calculations whereas in an online game your computer is acting as a server in addition to handling bot calculations. Try finding a dedicated server run by somebody else that has bots running on it and play there to see if the issue continues. If it does, then you have an actual problem. If not, your computer or internet connection is not powerful enough to act as an online server and run bot calculation while simultaneously connected to the game.
 

pontifex

Lifer
Dec 5, 2000
43,806
44
91
It's because in an offline game your computer is only responsible for the bot calculations whereas in an online game your computer is acting as a server in addition to handling bot calculations. Try finding a dedicated server run by somebody else that has bots running on it and play there to see if the issue continues. If it does, then you have an actual problem. If not, your computer or internet connection is not powerful enough to act as an online server and run bot calculation while simultaneously connected to the game.
It does it when I play by myself online with it set to friends only invite, so why doesn't it do it in offline mode too? there's no work to do as a server.

also, it just seems like FPS drop, not internet lag. tried some settings changes I found online for the issue but none worked.
 

ad3pt7

Member
Mar 7, 2013
37
0
16
About a month ago I started running into really odd issues in CSGO. My specs are in my sig, but I was playing quite a bit of the Operation Payback playlist, and I'd just get this really odd mouse/framerate lag even though my FPS wasn't dropping at all. I changed a bunch of settings, played with the current NVIDIA drivers, played without MSI Afterburner and the issue still persisted. The map I noticed it the most on big time was de_seaside.

I tried disabling SLI to see if that did anything, and the issue still persisted. One thing I found funny, was that this issue never ever happened on the original maps that launched with the game. NVIDIA has released like 1-2 drivers since then I believe so I'll have to try it out again.
 

zokudu

Diamond Member
Nov 11, 2009
4,364
1
81
Just play cs_office on T on maps with player collisions=on and stand in the doorway of the main exit from the T spawn and block your entire team in until you get bored of it.
Uh? There's 3 exits from T spawn on cs_office.
 

ASK THE COMMUNITY