crossfire 6950 issues since i installed the latest drivers

Discussion in 'Video Cards and Graphics' started by eastyy123, Nov 11, 2012.

  1. eastyy123

    eastyy123 Member

    Joined:
    Oct 16, 2007
    Messages:
    49
    Likes Received:
    0
    when i installed the latest drivers everything seemed to work ok but after i rebooted the desktop flickers ( with extreme image tearing its so bad can may using the mouse almost impossible).When i reinstall the drivers it goes back to normal until i reboot again i tried uninstalling a reverting back to previous drivers but no luck .

    Has anyone else had this issue ?
     
  2. Durvelle27

    Durvelle27 Diamond Member

    Joined:
    Jun 3, 2012
    Messages:
    4,102
    Likes Received:
    0
    did you fully uninstall the old drivers and use Driver Sweeper to clean the rest as i had the same problem with my HD 6950 and that solved it.
     
  3. aaksheytalwar

    aaksheytalwar Diamond Member

    Joined:
    Feb 17, 2012
    Messages:
    3,388
    Likes Received:
    0
    Who uses driver sweeper these days.
     
  4. Shmee

    Shmee Moderator <BR> Memory and Storage <BR> Video Cards
    Super Moderator

    Joined:
    Sep 13, 2008
    Messages:
    2,850
    Likes Received:
    6
    you say the latest drivers, but which ones? were they beta, or the WHQL 12.10?
     
  5. eastyy123

    eastyy123 Member

    Joined:
    Oct 16, 2007
    Messages:
    49
    Likes Received:
    0
    12.10 when i got the problem tried the beta 12.11 tried drive sweeper but still get the same problem think it might be time for a fresh install with windows 7
     
  6. djshortsleeve

    djshortsleeve Member

    Joined:
    Jan 11, 2011
    Messages:
    125
    Likes Received:
    0
    I installed the latest 12**10 driver and my system is pretty poor performing as well** I have a single 6870** In Black Ops my system lags often** This system has been smooth as butter with all other drivers in the past 2 years**

    This is such a joke!
     
  7. CryHavoc

    CryHavoc Senior member

    Joined:
    Jan 17, 2003
    Messages:
    978
    Likes Received:
    0


    And I thought it was just me.
    With the latest released version (non beta)
    i get tearing, stuttering video, and generally poorer performance than the previous revision. I'm glad I kept the previous rev installer...time to remove and install.
     
  8. codyray10

    codyray10 Senior member

    Joined:
    Apr 14, 2008
    Messages:
    816
    Likes Received:
    3
    The newest drivers broke my games on my 5850 (Steam, BF3). Then I tried the beta drivers, which didnt change anything. Reinstalled the 12.8 suite and everything was back to normal.
     
  9. Shmee

    Shmee Moderator <BR> Memory and Storage <BR> Video Cards
    Super Moderator

    Joined:
    Sep 13, 2008
    Messages:
    2,850
    Likes Received:
    6
    interesting, I found that the 12.10 seem much better than the 12.8 in ETQW and WoT, and BF3 seems about the same. I have 6950 xfire, play games at 1600p. I think the biggest bonus is I dont need to turn off Xfire in ETQW and WoT to get a good frame rate.

    Looking forward to 12.11 WHQL
     
  10. djshortsleeve

    djshortsleeve Member

    Joined:
    Jan 11, 2011
    Messages:
    125
    Likes Received:
    0
    I guess I should not assume things - I though for sure I had .net4 framework installed like AMD mentioned for this driver. Im going to install and see how the driver is after.
     
  11. djshortsleeve

    djshortsleeve Member

    Joined:
    Jan 11, 2011
    Messages:
    125
    Likes Received:
    0
  12. eastyy123

    eastyy123 Member

    Joined:
    Oct 16, 2007
    Messages:
    49
    Likes Received:
    0
    ok well thats bizzare i reinstalled it again (same as every time i have booted up the computer ) and now its fine done several reboots and still ok
     
Loading...