connecting PSU

9mak9

Senior member
Dec 3, 2007
494
0
76
Hey guys, I just got all the parts to my computer and this PSU

It has so much wiring I am not sure what to connect...

1- I know I connect the 24 pin to the MB and then I'm sorta confused...

2- I have 2 SATA drives (HD and DVD-ROM) so do I connect the cords from the PSU to the both of those? I see the SATA connectors but there is 2 on the same wire...does it matter which is connected?

3- I have to connect the fan power connector to the MB...what about the CPU power connector 4-pin and 8-pin? Does it depend on the MB to only connect 1 or do i connect both? I do not know about the 4-pin molex power connector... (i am using this MB)

4- I have a geforce 8800gt which has an power cord that attaches to the 6-pin PCIe power connected on the side of the GPU...do i plug that into the GPU and then both (power connecter)
3 pin connectors to the PSU?

Is there anything else that needs to be connected?

Any help would be appreciated :) thanks
 

humanure

Senior member
Dec 28, 2005
443
0
0
connect 1 SATA connector to each drive, doesn't matter what order. They are keyed so should not take much force.
that motherboard uses the 4 pin cpu connector
plug 1 6 pin pci express connector into you video card, as far as other connections you'll have to connect your case fans to the psu or a header on the motherboard, depends on the fans your using, the cpu fan will have a header on the motherboard
 

LOUISSSSS

Diamond Member
Dec 5, 2005
8,771
54
91
Originally posted by: humanure
connect 1 SATA connector to each drive, doesn't matter what order. They are keyed so should not take much force.
that motherboard uses the 4 pin cpu connector
plug 1 6 pin pci express connector into you video card, as far as other connections you'll have to connect your case fans to the psu or a header on the motherboard, depends on the fans your using, the cpu fan will have a header on the motherboard

do exactly as he says, did u get everything working?
 

Auffhammer

Junior Member
May 1, 2002
5
0
0
I have not built a computer in years, and times have changed a bit...

I have a similar problem:

Q6600 Kentsfield 2.4Ghz
Gigabyte GA-P35-DS3L
G.Skill 4GB DDR2

The Power Supply I have is a Shark ATX SP-635 635W RT
http://www.newegg.com/Product/...16817226002&Tpk=SP-635

I have a 24 pin connector on the MB and a 4 pin connector on the MB near the CPU.

The power supply cables have two 4-pin connectors.
Further, it does not have a 24 pin connector, but a 20 pin with a small 4-pin.

When I plug in the 20+4 in to the 24 pin and a 4 pin into the 4pin connector, the MB boots for 3 seconds and then shuts down.

The manual is not helpful. Any suggestions?