• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

CATALYST 8.12 are live

Page 2 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.

evolucion8

Platinum Member
Jun 17, 2005
2,867
3
61
I found a nice boost in performance with Far Cry 2, but I still experimenting the weird erratic FPS in DX10 mode. I used the AVIVO Encoder and Everest showed a GPU usage between 18% to 44% while encoding some MKV files to PSP, MPEG 2 and DivX format, but strangely enough the CPU usage was quite high, specially on one core, also using the WMV format didn't show any GPU usage during encoding.
 

AmberClad

Diamond Member
Jul 23, 2005
4,914
0
0
Originally posted by: neothe0ne
Originally posted by: RallyMaster
Catalyst Control Center says it doesn't support my driver version for some reason. I've used DriverSweeper already and reinstalled and it gives me the same problem...
I wish I had heard from you before trying on my own system. You're running Server 2008 32-bit, right?

Everyone on the ATI forums is having trouble with Vista x64 and "incompatible hardware". I'm running Server 2008 x64 and having the same issue.

Also, I did a uninstall and sweep and now have the error in 8.11 when they used to work fine.
Worked fine for me and Vista Ultimate x64. Is it possible you guys forgot to uninstall CCC 8.11 along with Cat 8.11 before updating to 8.12?
 

Mem

Lifer
Apr 23, 2000
21,476
13
81
Originally posted by: AmberClad
Originally posted by: neothe0ne
Originally posted by: RallyMaster
Catalyst Control Center says it doesn't support my driver version for some reason. I've used DriverSweeper already and reinstalled and it gives me the same problem...
I wish I had heard from you before trying on my own system. You're running Server 2008 32-bit, right?

Everyone on the ATI forums is having trouble with Vista x64 and "incompatible hardware". I'm running Server 2008 x64 and having the same issue.

Also, I did a uninstall and sweep and now have the error in 8.11 when they used to work fine.
Worked fine for me and Vista Ultimate x64. Is it possible you guys forgot to uninstall CCC 8.11 along with Cat 8.11 before updating to 8.12?
I always uninstall the old version(full CCC package) then reboot then install my new ATI drivers and finally another reboot,never had any issues so far in Vista x64 doing it that way.
 

Qbah

Diamond Member
Oct 18, 2005
3,754
10
81
From the moment you don't have to reboot your computer I never uninstall them. I never reboot after installation. Everything worked A-OK so far.
 

Cookie Monster

Diamond Member
May 7, 2005
5,161
32
86
Are these worth the upgrade? Im still with the cat 8.8s. Playing deadspace atm. Should I just stick with the "dont fix it if it aint broken" mentality here?
 

manimal

Lifer
Mar 30, 2007
13,560
8
0
I get nice improvements in gaming on both my systems but I may have to go back to 11s on my htpc since I am getting those blocky Grey squares and ghosts in my hd rips and other assorted videos. I may try reinstalling all my video related software-ffdshow, matroska-etc- and see if I can isolate the issue.

Man x64 has been a pain on the htpc.....
 

AmberClad

Diamond Member
Jul 23, 2005
4,914
0
0
Originally posted by: Cookie Monster
Are these worth the upgrade? Im still with the cat 8.8s. Playing deadspace atm. Should I just stick with the "dont fix it if it aint broken" mentality here?
That's usually my policy actually :laugh:. I was stuck on Cat 8.8 for three months before I finally updated to 8.11 (on a whim). I'd probably be more diligent about doing it if I had a 1920x1080 and needed to squeeze out every last framerate.

I ended up updating immediately with this release only because I'm currently playing three of the games on the "performance improvements" list. Otherwise, I'd probably just leave it alone.
 

Mem

Lifer
Apr 23, 2000
21,476
13
81
Originally posted by: Cookie Monster
Are these worth the upgrade? Im still with the cat 8.8s. Playing deadspace atm. Should I just stick with the "dont fix it if it aint broken" mentality here?
I always update every month,basically there's normally a bug fix or two and if you are lucky performance increase,drivers are so easy to uninstall(if you don't install over the top) and update that I have got into the habbit of updating all the time.

8.8s to 8.12s I would say go for it :).
 

cmdrdredd

Lifer
Dec 12, 2001
26,835
278
126
Seems like people are pulling their hair out because 8.12 broke crossfire in many cases. http://forums.guru3d.com/showthread.php?t=281348

What's ridiculous though is people are saying that their problems were caused by driver sweeper which is not possible. It's like saying a fresh windows install won't work with these drivers. All driver sweeper does is remove the latent registry entries and temporary ATI install files left over from an uninstall. They're basically trying to cover up the underlying issues they are having with crossfire.

note: These aren't the miracle drivers people were hyping up a couple weeks ago.
 

Sylvanas

Diamond Member
Jan 20, 2004
3,752
0
0
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
 

cmdrdredd

Lifer
Dec 12, 2001
26,835
278
126
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:

That could even be margin of error. sometimes after a fresh restart I get 2fps extra.
 

Tempered81

Diamond Member
Jan 29, 2007
6,374
0
76
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:
It's 10% in his case. Maybe your 280 could use a "couple fps" to catch up ;)
 

dguy6789

Diamond Member
Dec 9, 2002
8,558
3
76
Drivers work perfectly fine for me. I only played UT3 so far, but it runs smooth as glass(like it did before). I didn't bother to check numbers, as long as it works fine that's all I care about.
 

Sylvanas

Diamond Member
Jan 20, 2004
3,752
0
0
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:

That could even be margin of error. sometimes after a fresh restart I get 2fps extra.
Yes, any improvement is great. The fact is that my result match up to what is stated, therefore I am sure the other results are mostly spot on in which case it is indeed awesome, 25% increase in Crysis? You don't want that? Also the F@H client has improved since I last used it, still no Crossfire support but according to CCC my first GPU is running at 97% load when doing F@H, I tried it months back on my 3850's and could never get over 60% load.
 

neothe0ne

Member
Feb 26, 2006
197
0
0
Originally posted by: AmberClad
Originally posted by: neothe0ne
Originally posted by: RallyMaster
Catalyst Control Center says it doesn't support my driver version for some reason. I've used DriverSweeper already and reinstalled and it gives me the same problem...
I wish I had heard from you before trying on my own system. You're running Server 2008 32-bit, right?

Everyone on the ATI forums is having trouble with Vista x64 and "incompatible hardware". I'm running Server 2008 x64 and having the same issue.

Also, I did a uninstall and sweep and now have the error in 8.11 when they used to work fine.
Worked fine for me and Vista Ultimate x64. Is it possible you guys forgot to uninstall CCC 8.11 along with Cat 8.11 before updating to 8.12?
You don't have to uninstall CCC before upgrading. And people who did uninstall CCC before upgrading to 8.12 also had problems, as can be seen on the Catalyst forums.

Also, I already found a fix for the problem, which says that something isn't right with ATI or Microsoft's code (most likely ATI's).

And yeah, these aren't miracle drivers by any means. That supposed 25% performance increase in Crysis didn't happen, I had absolutely zero change in performance. (I also can't find the AVIVO encoder but I wasn't really planning on using it either)
 

cmdrdredd

Lifer
Dec 12, 2001
26,835
278
126
Originally posted by: Sylvanas
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:

That could even be margin of error. sometimes after a fresh restart I get 2fps extra.
Yes, any improvement is great. The fact is that my result match up to what is stated, therefore I am sure the other results are mostly spot on in which case it is indeed awesome, 25% increase in Crysis? You don't want that? Also the F@H client has improved since I last used it, still no Crossfire support but according to CCC my first GPU is running at 97% load when doing F@H, I tried it months back on my 3850's and could never get over 60% load.
They didn't ever post specific resolutions/settings/situations either. Maybe the benchmark goes up but gameplay is the same *shrug* it's happened before.

BTW: for the AVIVO app you have to custom install for it to show up. Express install skips over it.
 

SlowSpyder

Lifer
Jan 12, 2005
17,305
998
126
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:

That could even be margin of error. sometimes after a fresh restart I get 2fps extra.
Going from 150 to 153 FPS is meaningless. Going from 32 to 35 has some benefit. You know, kind of like how the 'Big Bang' drivers for Nvidia gave it that extra few FPS to win some benches, this does the same thing for AMD.
 

Sylvanas

Diamond Member
Jan 20, 2004
3,752
0
0
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:

That could even be margin of error. sometimes after a fresh restart I get 2fps extra.
Yes, any improvement is great. The fact is that my result match up to what is stated, therefore I am sure the other results are mostly spot on in which case it is indeed awesome, 25% increase in Crysis? You don't want that? Also the F@H client has improved since I last used it, still no Crossfire support but according to CCC my first GPU is running at 97% load when doing F@H, I tried it months back on my 3850's and could never get over 60% load.
They didn't ever post specific resolutions/settings/situations either. Maybe the benchmark goes up but gameplay is the same *shrug* it's happened before.

BTW: for the AVIVO app you have to custom install for it to show up. Express install skips over it.
I didn't see it in Custom install. Go to the AMD Game download page and the AVIVO package is there, it says X1000 but it hasn't been updated (note it's dated 10/12). Once it's installed go into the CCC and switch to 'Basic' View, from there you can use the Stream converter.
 

neothe0ne

Member
Feb 26, 2006
197
0
0
Yeah uh, the AVIVO converter definitely isn't working correctly (also it's a separate download entirely, so it won't be in custom install.. and then you can only see it in Basic CCC mode, not Advanced). Many different XviD/Lame avi's are turning into AAC audio in mp4 container only for me when trying the iPod Video and PSP profiles.
 

evolucion8

Platinum Member
Jun 17, 2005
2,867
3
61
Originally posted by: SlowSpyder
Originally posted by: cmdrdredd
Originally posted by: Sylvanas
These drivers are awesome. Installed fine as usual (I have never had problems on either my 3850 Crossfire or my current 4870X2) and fired up Clear sky Maxed out 1920x1200 DX10.1 2xAA where my last save was I was getting around 32 FPS on the 8.11's, it is now around 34 or 35 with these 8.12s- not too shabby at all. Will try Crysis later.
2fps difference is considered "awesome"? :confused:

That could even be margin of error. sometimes after a fresh restart I get 2fps extra.
Going from 150 to 153 FPS is meaningless. Going from 32 to 35 has some benefit. You know, kind of like how the 'Big Bang' drivers for Nvidia gave it that extra few FPS to win some benches, this does the same thing for AMD.
I second that, 2fps can make a difference between 28fps and 30fps and same improvements happened in some games with the Big Bang drivers, but not all people are happy with such accomplishments and just keep trolling, hard to please everybody.

Originally posted by: neothe0ne
Yeah uh, the AVIVO converter definitely isn't working correctly (also it's a separate download entirely, so it won't be in custom install.. and then you can only see it in Basic CCC mode, not Advanced). Many different XviD/Lame avi's are turning into AAC audio in mp4 container only for me when trying the iPod Video and PSP profiles.
Try to update to the latest .Net 3.5 SP1 framework, clean your registry, mine installed correctly and the AVIVO converter always has been like that, only can be seen through the Basic CCC mode. I used the PSP profile with the CCC to convert a video and it used the mp4 container and the AAC audio, it also happened with the previous version, may be you have a codec conflict.
 

dguy6789

Diamond Member
Dec 9, 2002
8,558
3
76
This forum is full of so many Nvidia trolls it's insane. If nvidia sends someone out to suck your cock for saying ati sucks, tell me where to sign up.
 

habbakuk87

Member
Jun 8, 2008
117
0
0
Wtf, fan control doesn't work for me and the ati overdrive which finally was giving me some stable oc's in 8.12 beta on my gfx card seems to not work either with 8.12 .Tested using running furmark 640x480 in windowed mode andt Ati overdrive and gpuz side by side.OC'ed to 665 Mhz but gpuz shows only 625Mhz.Fan set at 50% but gpuz and ATi overdrive in right corner only show 6%.
 

AmberClad

Diamond Member
Jul 23, 2005
4,914
0
0
Originally posted by: dguy6789
This forum is full of so many Nvidia trolls it's insane. If nvidia sends someone out to suck your cock for saying ati sucks, tell me where to sign up.


We don't need that kind of language in the video forum, so keep it to yourself.

- AmberClad
 

Qbah

Diamond Member
Oct 18, 2005
3,754
10
81
Originally posted by: cmdrdredd
They didn't ever post specific resolutions/settings/situations either. Maybe the benchmark goes up but gameplay is the same *shrug* it's happened before.

BTW: for the AVIVO app you have to custom install for it to show up. Express install skips over it.
Nobody posts resolutions and settings for speed increases! Unless it's a specific fix like for AA for example. And you assuming things is not a very nice thing to do. You don't even own an ATi card - why would you assume anything (and obviously negative from the beginning). Now if you owned one, installed and tested - great, your argument would be valid. Because you didn't all you do is bait people with your blatant and obvious ATi hate - which starts flaming, thread gets closed, discussion is stopped. Mission accomplished!

EDIT: And my screens do blink in the end when adding a new display. But they don't switch or mess up or one gets turned off or w/e, so still improvement for me :) That was my last gripe with the drivers. Checked if Fallout 3 runs fine. It does. So do a few other games. So far nothing bad to say for those from me. Obviously I don't have CrossFire so can't comment on it.
 

dguy6789

Diamond Member
Dec 9, 2002
8,558
3
76
Just going to confirm some performance improvement in UT3. I imagine the real UT3 players are familiar with that spot in DM Deck near the teleporter and rocket launcher that has severe frame rate drop for some reason. The fps drop there is less now :)
 
Thread starter Similar threads Forum Replies Date
Rigg Graphics Cards 7

ASK THE COMMUNITY