Bizarre Reboot Issue

vicwang

Member
Oct 5, 2000
181
0
71
Having a really bizarre issue with random reboots. Basically my PC is rebooting semi-randomly, but the behavior is completely the opposite of what would typically be expected: when playing games which stress the system under heavy load it never reboots, but when the system is completely idle it reboots frequently.

The issue is definitely not software, driver, or OS related, since the reboots occur even when it has not been booted into Windows.

It also comes and goes in waves: sometimes it happens every few minutes, then sometimes it will go days without happening.

I replaced the PSU and that seemed to offer some improvement at first, but it did not resolve the issue.

Also I've performed plenty of stress testing using Memtest, Windows Memory Diagnostics, Furmark, BOINC, heavy gaming, etc. and none have resulted in any issues (and as noted, it actually seems far LESS likely to happen when the system is under heavy load).

Has anyone ever experienced this kind of issue before? I'm thinking it's somehow motherboard related but it would be nice to get some kind of confirmation before buying a new one and replacing it. I'm also curious how it's even theoretically possible that a system would be MORE stable under full load than when completely idle.
 
Last edited:

VirtualLarry

No Lifer
Aug 25, 2001
56,301
10,026
126
Disable power-saving. When idle, the system will lower the voltage and clockspeed to the CPU, and apparently, that is dropping below what is necessary for stability at idle.

If your motherboard offers an "offset voltage", also consider using that setting, with a positive offset.

That said, the mobo or CPU could just be faulty.

Edit: This can also happen if you are using a modern low-power-at-idle CPU / mobo, and don't have a "Haswell Ready" PSU.
 
  • Like
Reactions: vicwang

VirtualLarry

No Lifer
Aug 25, 2001
56,301
10,026
126
Oh, before I forget, don't get carried away with the offset voltage thing. Too much, and your chip will run hotter, fans will be louder, and really too much can burn out your CPU.
 
  • Like
Reactions: vicwang

vicwang

Member
Oct 5, 2000
181
0
71
I didn't see anything in the BIOS about offset voltage, but I did see options for C-states (i.e. power saving) so I disabled it. After Googling a bit about C-states I found others had the EXACT same issue. Won't know for sure for a while if it worked but I'm pretty optimistic that it did the trick!
 

VirtualLarry

No Lifer
Aug 25, 2001
56,301
10,026
126
What are the specs, for the rig in question, if you don't mind me asking?

And approx. how old is it?

As CPUs and other chips (and mobo VRMs) age, they can sag, or CPUs can require a touch more voltage to remain stable.

CPUs (Intel ones, at least) come from the factory, with a table of voltage and frequency states built-in, that is (supposedly) specific to each particular CPU.

As CPUs age, those voltage may not be quite enough.

Or you may just be having issues with your PSU and low-power states, if it's an older-model (Non-Haswell Ready) model. (Haswell is when Intel introduced the really lower-power states, that caused contemporary PSUs of that time to drop out of regulation, due to too low a load on the +12V line. Newer ("Haswell Ready") PSUs remedied this issue.)
 
  • Like
Reactions: vicwang

vicwang

Member
Oct 5, 2000
181
0
71
It's a fairly new i7-7700 system, and the problem has been there ever since I bought it (though strangely it has occasionally gone for extremely long stretches of time, like as long as a month or so, without the issue happening).

The PSU I replaced the original with is a new Corsair, which presumably shouldn't have any issues with the latest CPU's.

Anyway after I disabled the C-states earlier today, after several hours I didn't get any reboots. So that gave me enough confidence to update the BIOS (until now, I didn't want to risk updating the BIOS since I figured a reboot during the update could brick the entire motherboard). And since then, still no reboots even with the C-states re-enabled! So I'm feeling pretty confident now that disabling the power saving fixed the issue (over the past couple days, it had been rebooting at least every hour or so). Thanks for your help!
 
Last edited: