• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

bf4 settings

Page 2 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.

looper

Golden Member
Oct 22, 1999
1,654
10
81
I activated that utility prog to unpark the cpu cores...in the window that comes up, under 'AC', I enabled it at 50%, and in the other section called 'battery' I left that alone and did not activate that.

I then called Cox Cable here in RI, and upped my web speed package to 'Premier' (50Down/25Up) for a promo price of another $5/month for 6 months...checked it at SpeedTest site... got 63Down/28Up to a server @ 60 miles away w/ a 26 ping... :)

And by next Monday, I should have both the new faster monitor and video card installed.....My dang K/D ratio in BF4 better improve....
 
Last edited:

Owls

Senior member
Feb 22, 2006
735
0
76
If anyone is playing BF4 with tri SLI please let's share in our sorrow. I have 3x 680s and I get massive FPS spikes when getting shot at, using the tv missile, or dying. I was able to mitigate this somewhat by reverting to 327.23. However, I discovered today that the 64bit client performs THE WORST when it comes to tri SLI. The 32bit client is such a massive difference that I only launch the 32bit game now.
 

Childs

Lifer
Jul 9, 2000
11,450
7
81
That fix is only for i7 right?
Normally i7 and AMD 8 core cpus, but I would run the utility and check thee status. If you see your cores parked, just unpark them. I would check your performance on the test range first just to establish a baseline. If it doesnt smooth out your graph and increase your fps, you can simply revert back.
 

escrow4

Diamond Member
Feb 4, 2013
3,333
113
106
I only play singleplayer:

4770 + 280X + 16GB RAM, all Ultra, FXAA, Vsync off, 60+, dips into 40's when lots of things go BOOM, some levels (China one, that huge opening before the building). Frostbite still seems less heavy/demanding. than CryEngine, with Crysis 3 I set everything to High for a smooth 60 FPS.
 

moonbogg

Lifer
Jan 8, 2011
10,173
1,982
126
This game engine needs lots of ram, but it isn't very harsh on GPU and CPU power, at least not in windows 8.1. I'd have to say this game runs better than BF3 did on my rig, yet its supposed to look better.
 

MBrown

Diamond Member
Jul 5, 2001
5,720
33
91
This game engine needs lots of ram, but it isn't very harsh on GPU and CPU power, at least not in windows 8.1. I'd have to say this game runs better than BF3 did on my rig, yet its supposed to look better.
GPU memory or system memory? Do you think 8GB is enough?

BTW I didn't see a difference with the unpark utility. The utility said that my cores were parked but the resource manager said otherwise. I think my issue is just that is some areas of some maps the frames just drop. Not every map drops for me. Also turning vsync off makes the game unplayable for me. Yeah all of the frames are between 60 and 100 without vsync, but the game stutters so friggin much without vsync because of the constant fluctuation of the FPS. This is with a singe card too.
 
Last edited:

AtenRa

Lifer
Feb 2, 2009
13,597
2,689
126
No need to unparcked cores in Win 8 for the FX CPUs

FX8350
8GB DDR-3 1866MHz
ASUS CU II HD7950 @ 1GHz
Cat 13.11 -8 Beta
Win 8 Pro 64bit


Video settings


 

MBrown

Diamond Member
Jul 5, 2001
5,720
33
91
I think I have settled for this.
Textures ultra.
Texture filtering high
Lighting quality medium
Effects quality medium
Mesh quality high
Terrain quality high
Terrain decoration high
Msaa off
Fxaa low
Ssaa 125%
Vsync on.

I haven't seen it dip below 60 fps with this so far.
 

Unoid

Senior member
Dec 20, 2012
461
0
76
I'm still tweaking. My goal is constant 90FPS at 1440P. I'm on win7 and unparked cores. (upgrading to 8.1 shortly :()

Ultra everything FXAA no SMAA, I get 60-90fps bouncing around. So I'm not sure where I want to start cutting back to get 80-90FPS constant.
 

Childs

Lifer
Jul 9, 2000
11,450
7
81
I'm still tweaking. My goal is constant 90FPS at 1440P. I'm on win7 and unparked cores. (upgrading to 8.1 shortly :()

Ultra everything FXAA no SMAA, I get 60-90fps bouncing around. So I'm not sure where I want to start cutting back to get 80-90FPS constant.
Try Texture Quality to High, Ambient occlusion to off, post process quality to low, and lighting quality to med or low. I saw a good improvement, and didn't notice a significant drop in quality.
 

Unoid

Senior member
Dec 20, 2012
461
0
76
Try Texture Quality to High, Ambient occlusion to off, post process quality to low, and lighting quality to med or low. I saw a good improvement, and didn't notice a significant drop in quality.
:thumbsup:

well played sir
 

MBrown

Diamond Member
Jul 5, 2001
5,720
33
91
Sort of a bump but I've found my best settings for 1440P...well actually AMD Raptr did but hey...it works.

texture quality high
texture filtering high
lighting quality medium
effects quality medium
post process quality high
mesh quality medium
terrain quality medium
terrain decoration high
msaa off
fxaa low
ambient occlusion off
ssaa 100&
 

ASK THE COMMUNITY