BF2 Voip problems

mrfatboy

Senior member
Sep 3, 2006
841
0
76
I am having problems getting my VOIP to work in game. It used to work before. When I now try to use VOIP I get a RED speaker and squad mates only hear static.

Here is what I know and or what I done to try to fix it.

1) Skype works fine
2) Teamspeak works fine
3) Used BF2VoiceSetup to reset
4) BF2 Audio options only lets me adjust send/transmit options.
5) BF2 Audio options says threshold is at 100% and "microphone test" is grey'd out.

Anybody have any ideas? Any config files I would tweak? The only thing I can think of is reinstalling BF2.

 

GullyFoyle

Diamond Member
Dec 13, 2000
4,362
11
81
I think I had this problem when I was running both BF2 VOIP & TeamSpeak, and TeamSpeak was set to Wave, instead of Direct Sound. Setting TeamSpeak back to Direct Sound I believe corrected it.
 

GullyFoyle

Diamond Member
Dec 13, 2000
4,362
11
81
Addendum to my previous answer. I was having the same problem as you, at the same time.
What I stated previously did not fix the issue, I was fooled because the mic was working good in TS. But, after I did what I stated above (which may be irrelevant), I Googled for more info, and tried turning off Mic boost in BF2, and that did seem to resolve the issue for me, last night.
Mic Boost is still set On in Windows sound settings, and in TS.
I have a Sound Blaster installed, if you have sound on the motherboard, other changes to your sound driver settings may be required. Google for BF2 VOIP STATIC for more info.
 

mrfatboy

Senior member
Sep 3, 2006
841
0
76
I do have a soundblaster live 24 card. I have tried with mic boost on and off. I got it working the other night but last night it was static again. It must be something to do with TS, Skype, & BF voip interacting together.

It all used to work flawlessly. I even had all 3 going at once onetime. That was too crazy for me :)

I did install a USB VOIP/skype device that works with a telephone. I thought that was the culprit. I unistalled the drivers, reinstalled skype and that when everything worked 2 nights ago. Like I said, as of last night -- red speaker static in BF2 voip.

I'm not sure if its an hardware or software issue. I bought a new SB xtremegamer card to try out. I have not put it in yet. I can't believe it's hardward but who knows.
 

DannyLove

Lifer
Oct 17, 2000
12,876
4
76
try updating your drivers of course...

I have VOIP disabled because my Mic Boost kept going out because of it. VOIP and Ventrilo don't mix, and so I'd rather talk to my mates instead of squad strangers. I can't hear VOIP people either. I would assume its a conflict of any teamspeak type of program with VOIP.

I never bothered to try and fix it. I know its also a bug cause of soundblaster.

Just use your teamspeak.
 

mrfatboy

Senior member
Sep 3, 2006
841
0
76
i just installed the SB xtremegamer. It was $80 and everything worked so far. Of course, the drivers were reinstalled so that still could have been the problem. My old SB live card was so old anyway. The xtremegamer blows it out of the water.

 

ASK THE COMMUNITY