Question Asrock x570 pro 4 bios update problem

Rango

Junior Member
Jan 13, 2023
1
0
6
Hello everyone,
Yesterday I have updated my Bios via special instructions provided on asrock support page using ryzen 5 2600 instaled in my pc and curently version of bios is P3.0 UEFI version.Then i installed my new Ryzen 7 5800x processor and want to upgrade Bios on latest version which is 4.50.
I have downloaded latest version of bios and exctracted file rom to usb pen drive which is previously Fat 32 formated.When I restart pc and try to flash bios using instant flash utility i have message on my screen "no image file ".
Do I need any files besides latest bios rom on my usb drive in order to proced with update?Am i missing something?
Thanks in advance for all your help.
 

Shmee

Memory & Storage, Graphics Cards Mod Elite Member
Super Moderator
Sep 13, 2008
7,512
2,528
146
Hmm, since you already mentioned the USB is properly formatted to FAT32, and you did extract the BIOS file to the USB (some may forget to extract the file from the archive), the main thing I can think of is to make sure that there is no earlier BIOS on the ASrock website that you need to upgrade to first before going to the latest. Another thing to check is to make sure you are viewing the right folder on the USB, or you could try re-extracting the file.
 

Iron Woode

Elite Member
Super Moderator
Oct 10, 1999
30,911
12,406
136
Hello everyone,
Yesterday I have updated my Bios via special instructions provided on asrock support page using ryzen 5 2600 instaled in my pc and curently version of bios is P3.0 UEFI version.Then i installed my new Ryzen 7 5800x processor and want to upgrade Bios on latest version which is 4.50.
I have downloaded latest version of bios and exctracted file rom to usb pen drive which is previously Fat 32 formated.When I restart pc and try to flash bios using instant flash utility i have message on my screen "no image file ".
Do I need any files besides latest bios rom on my usb drive in order to proced with update?Am i missing something?
Thanks in advance for all your help.
did you try keeping the zip file on the USB stick? It maybe able to unzip it.
 

RLGL

Platinum Member
Jan 8, 2013
2,083
301
126
Pretty sure you need to rename the bios file. Did you do that OP?
Not with the Asrock, extract to USB, restart with USB inserted, enter the bios, reset defaults, disable FTPM, restart, find instant flash, select the file................