Your Dynamic Range setting may be off if you use HDMI

flexy

Diamond Member
Sep 28, 2001
8,464
154
106
I discovered a weird issue and can confirm what I read on the web about it.

So, in Nvidia control panel, under "change resolution", at the bottom you find the setting "output dynamic range".
There are two options, "Limited", and "Full". In simple terms, "Full" makes your blacks "blacker" and your whites "whiter", and "limited" can give you a washed-out look.

When you have a monitor that is connected via HDMI (like most newer monitors), this setting still doesn't correctly work. (I just ran into hours adjusting my gamma settings and calibrating and simply couldn't get my black levels right)

The reason is that when you connect your monitor via HDMI, your resolution is then in NV control panel listed as "Ultra HD, HD or SD", but this seems to apply the wrong dynamic range no matter what you set it at.

Solution: Create a CUSTOM RESOLUTION in Nvidia control panel and activate it. Eg. you can create with with the same settings +1HZ and use this. Say, if you are at 60hz make one 61Hz.
I created one at 75Hz (which works), although my monitor is only specced to 60Hz.

When your resolution is NOT listed under "Ultra HD, HD, SD" but instead under "CUSTOM", the "limited" and "full" range now works properly.

Edit: There also seems some patch flying around on the net (Google "nvidia limited color range" and you will get some hits, also from Geforce forum etc. Since the custom resolution however works I didn't see a need for the patch).

TLDR: It may be that your black/white and colors levels are "capped" due to a bug (?) with Nvidia when you have a normal monitor connected via HDMI.

Edit: I can only explain this as if Nvidia assumes that a monitor connected via HDMI is a TV which (often) need a "limited" range. This however is not the case with a normal monitor, you want a full dynamic range with black blacks and white whites. It can make A HELL of a difference how your picture looks, try it out! As said, there is a setting in NV control panel, but this does NOT work unless you make a custom resolution.

https://www.reddit.com/r/pcgaming/comments/2p3xs7/nvidia_users_using_hdmi_output_youre_most_likely/

https://forums.geforce.com/default/topic/523992/tip-for-nvidia-users-using-hdmi-and-getting-accurate-color-format/

Edit: People claim this has been resolved with later drivers, but I cannot confirm this. I use the very latest 372.90. There is a difference in dynamic range when I use the "CUSTOM" resolution or the default one. "Out of the box", with the 372.90 drivers and no custom resolution and normal Gamma etc. settings, Gamma is WAAAAYYY too low and you need to set it to "limited" to see details in dark scenes. With the custom resolution, you can activate "Full" and can have Gamma at 1.0 in NV control panel and everything is right.
 
Last edited:
  • Like
Reactions: nopainnogain

sxr7171

Diamond Member
Jun 21, 2002
5,079
40
91
The setting worked for me on an LG OLED. It does not for some reason work on all displays. That TV required "full" or it looked washed out, but I think that's because I renamed the input PC and it was expecting a PC input at that point. Most TVs I think require limited.

The OLED also required me to play with color gamma settings in control panel to get it right. I used this website: http://www.lagom.nl/lcd-test/gamma_calibration.php

Monitors should always be on "full" as you said.
 

flexy

Diamond Member
Sep 28, 2001
8,464
154
106
Let me a add something possibly important:

I don't remember what the previous drivers were (I think some 35x.xx series?), but I had "out of the box", after using DDU and then installing new drivers, never those issues with gamma. Usually, in NV panel I actually used to set my gamma down to 0.87 or so. This also without making any custom resolution.

So yesterday I installed the 372.90, and without any changes etc. I had to set my gamma in NV control panel to 1.40 (which is absurdly high) to get a normal picture. I had never seen something like this. So there is a possibility that this issue is also driver related and that the dynamic range values vary depending on drivers. Just a guess.
 

flexy

Diamond Member
Sep 28, 2001
8,464
154
106
Let me add a little more after a week of reading and experimenting:

This is a rather common issue but it depends on several factors, like your monitor, OS, drivers etc.
For example, wife has also a Samsung monitor connected via HDMI, running Win 7, but her resolution(s) are listed as "PC", so there is everything ok.

For a quick check whether you're affected see this test image:



(You should see four distinctive shades of whites, gray, and black. If your blacks or whites are crushed you see on the left only white and/or on the right only black. You should see the 4 shades fine at default color/gamma settings in NV Control panel which is 1.0)


Also, you likely have the problem if you use a monitor (not a HDTV) but your resolution is listed under "Ultra HD, HD, SD" rather than "PC".

The most compatible and easiest way to solve the issue is with CustomResolutionUtility.
Load up CRU, click on the menu and select "No extension block", click "OK", rebooot.
This turns all your HDTV resolutions into PC resolutions which by default use the "full" color range.
 
Last edited:
Thread starter Similar threads Forum Replies Date
S Nvidia 11

ASK THE COMMUNITY

TRENDING THREADS