XBMC bit streaming issues

rbk123

Senior member
Aug 22, 2006
566
39
106
#1
I recently loaded XBMC on 2 different HTPC's of mine, Kodi 14.0 in particular. One HTPC uses a GeForce GT610 card and bit streams DTS-HD/True-HD just fine. The other uses an older ATI Radeon 5450 card and is all kinds of quirky. It passes Dolby Digital fine but for DTS-HD and True-HD, the receiver sees it as "multi-channel PCM". This happens for both an Onkyo HT receiver as well as an Emotiva Pre-processor.

The 5450 can pass DTS-HD/True-HD as it worked fine previously when I used FFDShow along with Media Player Classic.

In the XBMC audio settings I have it set to WASAPI - 5450's HDMI, although I have tried all of the other options as well. I have selected DTS-HD, etc... capable receiver (all formats) but no luck -> it does play, but the receiver and processor don't recognize the High Def audio streams.

1) Is Kodi 14.0 too new/buggy and I should try an older version?
2) Is the 5450 just too old and I should boot it for something more modern (or go back to FFDShow)?

This is my first foray into XBMC and I really like it.
 

tential

Diamond Member
May 13, 2008
7,363
0
121
#2
I recently loaded XBMC on 2 different HTPC's of mine, Kodi 14.0 in particular. One HTPC uses a GeForce GT610 card and bit streams DTS-HD/True-HD just fine. The other uses an older ATI Radeon 5450 card and is all kinds of quirky. It passes Dolby Digital fine but for DTS-HD and True-HD, the receiver sees it as "multi-channel PCM". This happens for both an Onkyo HT receiver as well as an Emotiva Pre-processor.

The 5450 can pass DTS-HD/True-HD as it worked fine previously when I used FFDShow along with Media Player Classic.

In the XBMC audio settings I have it set to WASAPI - 5450's HDMI, although I have tried all of the other options as well. I have selected DTS-HD, etc... capable receiver (all formats) but no luck -> it does play, but the receiver and processor don't recognize the High Def audio streams.

1) Is Kodi 14.0 too new/buggy and I should try an older version?
2) Is the 5450 just too old and I should boot it for something more modern (or go back to FFDShow)?

This is my first foray into XBMC and I really like it.
I would post this on their forum under their support section if I wanted timely correct manners of resolving this issue.
 
Nov 20, 2005
14,612
2
126
#3
What drivers are you using? That card should work, but it will need properly configured AMD drivers. They can be quite finicky.
 

rbk123

Senior member
Aug 22, 2006
566
39
106
#4
They are AMD drivers but outside of that I don't know anything else as I loaded them quite a while back. I can look into seeing if there's a newer set out there. I'll also see about posting in the XBMC forums. Thanks.
 

ASK THE COMMUNITY