• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Wireless Problem on Toshiba L500 laptop w/ Windows 7 Realtek

rfsapiens

Member
Mar 6, 2008
51
0
61
Hello people,

I have a Toshiba L500 laptop with dual boot Windows 7 Home Premium and Windows XP. In Windows XP all works perfectly including the wireless and so on... but on Windows 7 it doesn't. My Wireless NIC is a Realtek 8191SE and It all happened after I remove Microsoft Virtual PC and Windows XP Mode all was correctly removed but then the problems started. When I start the system it boots normally but the wireless symbol on the tray stays about a minute in waiting state (blue ring) then after that it stays with the symbol of available connections and it doesn't do anything. After one or two minutes it changes to normal operation and the symbol turns white first with limited connectivity but then it starts to work normally. Other times it does all the same I described but then the internet is very slow / failing to the point of losing connection and when I do a ping to google DNS it takes about 2500ms to the requests.
I tried almost everything I know. Disabling windows firewall, unninstall Kaspersky, resetting the connection ip and netsock with the netsh command; changing wireless drivers, disabling all non Microsoft services, running roguekiller and Hijackthis and registry fix. In safe mode I created another user profile (thinking it would be corrupted something in the existing user profile) and it worked right away with the symbol turning white immediately and pinging google with 42ms requests but then in the next time even in safe mode it starts having the same symptoms even in the new created user account. The route print command shows the correct route as the wireless connection routes everything to my gateway 192.168.1.1 and the DNS server is also set to the gateway and I can ping localhost with <1 ms. I also disabled IPv6 and it remain the same. Also when I can access to the pages the download speed is very very slow in order of a few KB/s. On task manager / msconfig I can only see services stopped or executing so I don't know exactly how to catch a service starting. How can I do that? I know something broke my wireless connection on my Win7 installation but I don't know what to do :/ So what can I do? Did the unninstalling of the Virtual PC broke anything? Should I reinstall it that in order to "reconfigure" the network adapters? What else can I do in order to restore my connection's normal function besides formatting the pc? How can I catch the culprit service?

Thank you in advance for your kind help and sorry about my english.
I'm looking forward to hear a reply from you soon.

With the best regards,

Rfsapiens
 

ASK THE COMMUNITY