Wireless Adapter stops working after sleep

boozie

Senior member
Oct 12, 2006
486
1
81
Whenever I awake my computer from sleep mode, my internet connection is gone. When I check in the device manager it just says it's (TP-LINK 150 Mbps Wireless Lite N Adapter) not working properly. Win7 (64-bit) troubleshoot just says there is an issue with the driver.

The drivers are the most up to date. I can fix the problem sometimes by unplugging the USB wireless adapter and plugging it back in but it has also caused me a bsod before. Another way to fix it is to disable it in device manage and re-enable it. At this point it claims to be working properly but it also will auto install "Microsoft Virtual WiFi Miniport Adapter" which will disappear upon reboot. Rebooting is the last way to fix the problem until it goes into sleep mode again.

It may be worth noting that it doesn't break 100% of the time it goes into sleep mode, roughly 50%.

I don't think this is relevant but I also have "PCI Simple Communications Controller" sitting in my Other Devices with no drivers installed for it.
 

Texashiker

Lifer
Dec 18, 2010
18,811
197
106
Have you disabled power saving on the device? This prevents the computer from turning off the device.

Start - control panel - network and sharing options - change adapter settings - right click connection - properties - configure button - power management tab - uncheck "allow the computer to turn off this device to save power" - click save.

When I was working for a cable modem provider, this was a common issue. After going into sleep mode the computer could not connect to the internet until it was restarted. Disabling power saving on the device usually fixed the issue.
 

boozie

Senior member
Oct 12, 2006
486
1
81
Have you disabled power saving on the device? This prevents the computer from turning off the device.

Very good idea. I should have been able to think of that. I will try this out when I get home but I have good faith it will fix things.
 

boozie

Senior member
Oct 12, 2006
486
1
81
Update: So by not allowing it to turn off, when I come out of sleep I'm just not connected to any network. Is there some way I can force the connection to remain active while in sleep? By manually selecting my wireless network I was able to reconnect which is better than where I was at least.
 

Sunburn74

Diamond Member
Oct 5, 2009
5,027
2,595
136
I realize this is an old thread but the OP never solved the problem and I developed it recently. After much searching the net, there really were no viable answers. This is what I did to resolve the problem after losing probably 10 hours of work time.

The basic problem is that my TP link wn-722n USB adapter either isn't recognized by windows after a resumption from sleep or is recognized but cannot find my default network and takes a really long time to connect (in fact in general it doesn't connect at all and I am forced to manually reset the adapter). The problem appears to be related to a driver issue.

Strangely if I told windows to install the driver this way the problem was solved (also I have USB suspend off and unchecked the option to allow windows to turn off the device)
1) in device manager, find the Tp-link wn722 adapter under whatever current driver it is using. Click properties and the driver tab.
2) Click update driver and click browse for driver software
3) THEN click pick from a list of drivers, pick something in the network adapter category, and have disk. I may be missing a step or 2 but essentially you have to go through the "have disk" route where you pick the specific driver file.
4) Install the specific driver inf file from that. I used the TP link beta driver on their website and the file name was netahur.inf

If i installed the drivers any other way (including the option where I told windows to browse a folder for the driver or the options with the software that TP-link supplies), I would have problems with reconnecting after sleep. Either the device would not be recognized or it would be recognized but for reasons unclear could not connect to the network. I hope this helps others.
 
Last edited: