Windows XP ASPI layer, need some help?!?


Aug 25, 2002
I recently upgraded my dads pc to XP, and apparently he uses AudioCatalyst (a cd ripping program) and cant live without it. Xp doesnt natively have an ASPI layer so i downloaded the roxio/adaptec 4.71 version and succesfully installed it. Upon using AspiCheck it only shows 2 of the 4 files installed, but i believe those are the only ones needed because i tried on another xp machine and still only the same 2 are installed for xp.

Anyway, when i launch AudioCatalyst and go the settings, it STILL wont let me choose Aspi as a ripping method and will only go through the soundcard as a way of ripping. Is the aspi layer not installed correctly?

What can i do.........should i work on the aspi layer or should i look at a different cd ripping program?!?!


Diamond Member
Feb 12, 2001
what i did was use the actual adaptec ASPI layer. you use to have to use a "hack" to be able to use it on win2k, but i just did it and it installed it on WinXP with no problems.

Adaptec ASPI

when you extract the files into whatever folder, click on the file named "aspiinst" NOT "install.bat" for some reason, the install.bat file doesn't work, or at elast it didnt't when i tried that file. But when i ran "aspiinst" it worked. you can then use the aspichk to verify that aspi was installed correctly.

In fact, run ASPIchk first to determine if you have a broken apsi layer, or if it is even installed at all.

edit: i just reread your post. shoulda read it before replying;) anywho, if you only have two files showing up even after installing the aspi layer over again and restarting the computer, then you have a broken aspi layer. When i did that install yesterday, i had no layers at all, no files even showed up with aspichk. then i did the "aspiinst" and all the layers showed up. the check screen should look like: ASPI screen