• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Solved! Windows not seeing hard drives, help.

LeeT522

Junior Member
Jul 11, 2021
2
0
6
Hi, I have a new build that I just did. It is an ASRock x470 taichi ultimate. ryzen 2700x processor, 32gb ram. I have 2 2tb ssd drives in a raid 1 array. Windows sees these just fine. I have two 2tb regular sata drives that windows is not seeing. I can see all the drives in uefi. I tried creating a second raid array with the two regular drives, windows does not see that new array. I deleted the new array, rebooted. I still only see the ssds (the raid array) as drive c. How can I get windows to see my sata drives? It’s probably something that I have set up improperly in the uefi.

Thank you in advance!
 

Attachments

Last edited:

mxnerd

Diamond Member
Jul 6, 2007
6,141
884
126
Use 3rd party free partition utilities?

EaseUS Partition Master free

Minitool Partition Wizard

==

You need to hit "Apply" button to make it really happen when you use these utilities to make changes.
 
Last edited:
  • Like
Reactions: LeeT522

mxnerd

Diamond Member
Jul 6, 2007
6,141
884
126
Use 3rd party free partition utilities?

EaseUS Partition Master free

Minitool Partition Wizard

==

You need to hit "Apply" button to make it really happen when you use these utilities to make changes.
 
Last edited:
  • Like
Reactions: LeeT522

VirtualLarry

No Lifer
Aug 25, 2001
51,924
6,885
126
Using AMD RAID drivers? drives not in a RAID config should show up as pass-through. Do they show up in Device Manager or Disk Management.
 
  • Like
Reactions: LeeT522

ASK THE COMMUNITY